NVENC - NVIDIA Video Encoder API Reference Manual
NVIDIA Video Codec SDK License Agreement
Version 5.0
2014-2015
  • Main Page
  • Modules
  • Data Structures
Modules
Here is a list of all modules:
  • NvEncodeAPI Data structures
  • NvEncodeAPI Functions
Released Under NVIDIA Video Codec SDK License Agreement
Copyright (c) 2014-2015 NVIDIA Corporation. All rights reserved.


  • Main Page
  • Modules
  • Data Structures
Data Structures | Defines | Typedefs | Enumerations
NvEncodeAPI Data structures

Data Structures

struct | _NV_ENC_CAPS_PARAM
struct | _NV_ENC_CODEC_CONFIG
union | _NV_ENC_CODEC_PIC_PARAMS
struct | _NV_ENC_CONFIG
struct | _NV_ENC_CONFIG_H264
struct | _NV_ENC_CONFIG_H264_VUI_PARAMETERS
struct | _NV_ENC_CONFIG_HEVC
struct | _NV_ENC_CREATE_BITSTREAM_BUFFER
struct | _NV_ENC_CREATE_INPUT_BUFFER
struct | _NV_ENC_EVENT_PARAMS
struct | _NV_ENC_H264_SEI_PAYLOAD
struct | _NV_ENC_INITIALIZE_PARAMS
struct | _NV_ENC_LOCK_BITSTREAM
struct | _NV_ENC_LOCK_INPUT_BUFFER
struct | _NV_ENC_MAP_INPUT_RESOURCE
struct | _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS
struct | _NV_ENC_PIC_PARAMS
struct | _NV_ENC_PIC_PARAMS_H264
struct | _NV_ENC_PIC_PARAMS_HEVC
struct | _NV_ENC_PRESET_CONFIG
struct | _NV_ENC_QP
struct | _NV_ENC_RC_PARAMS
struct | _NV_ENC_RECONFIGURE_PARAMS
struct | _NV_ENC_REGISTER_RESOURCE
struct | _NV_ENC_SEQUENCE_PARAM_PAYLOAD
struct | _NV_ENC_STAT
struct | _NV_ENCODE_API_FUNCTION_LIST
struct | _NVENC_EXTERNAL_ME_HINT
struct | _NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE
struct | _NVENC_RECT
struct | GUID

Defines

#define | NV_ENC_CAPS_PARAM_VER NVENCAPI_STRUCT_VERSION(NV_ENC_CAPS_PARAM, 1)
#define | NV_ENC_CONFIG_VER (NVENCAPI_STRUCT_VERSION(NV_ENC_CONFIG, 5) | ( 1<<31 ))
#define | NV_ENC_CREATE_BITSTREAM_BUFFER_VER NVENCAPI_STRUCT_VERSION(NV_ENC_CREATE_BITSTREAM_BUFFER, 1)
#define | NV_ENC_CREATE_INPUT_BUFFER_VER NVENCAPI_STRUCT_VERSION(NV_ENC_CREATE_INPUT_BUFFER, 1)
#define | NV_ENC_EVENT_PARAMS_VER NVENCAPI_STRUCT_VERSION(NV_ENC_EVENT_PARAMS, 1)
#define | NV_ENC_INITIALIZE_PARAMS_VER (NVENCAPI_STRUCT_VERSION(NV_ENC_INITIALIZE_PARAMS, 5) | ( 1<<31 ))
#define | NV_ENC_LOCK_BITSTREAM_VER NVENCAPI_STRUCT_VERSION(NV_ENC_LOCK_BITSTREAM, 1)
#define | NV_ENC_LOCK_INPUT_BUFFER_VER NVENCAPI_STRUCT_VERSION(NV_ENC_LOCK_INPUT_BUFFER, 1)
#define | NV_ENC_MAP_INPUT_RESOURCE_VER NVENCAPI_STRUCT_VERSION(NV_ENC_MAP_INPUT_RESOURCE, 4)
#define | NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER NVENCAPI_STRUCT_VERSION(NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS, 1)
#define | NV_ENC_PARAMS_RC_CBR2 NV_ENC_PARAMS_RC_CBR
#define | NV_ENC_PIC_PARAMS_VER (NVENCAPI_STRUCT_VERSION(NV_ENC_PIC_PARAMS, 4) | ( 1<<31 ))
#define | NV_ENC_PRESET_CONFIG_VER (NVENCAPI_STRUCT_VERSION(NV_ENC_PRESET_CONFIG, 4) | ( 1<<31 ))
#define | NV_ENC_RC_PARAMS_VER NVENCAPI_STRUCT_VERSION(NV_ENC_RC_PARAMS, 1)
#define | NV_ENC_RECONFIGURE_PARAMS_VER (NVENCAPI_STRUCT_VERSION(NV_ENC_RECONFIGURE_PARAMS, 1) | ( 1<<31 ))
#define | NV_ENC_REGISTER_RESOURCE_VER NVENCAPI_STRUCT_VERSION(NV_ENC_REGISTER_RESOURCE, 3)
#define | NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER NVENCAPI_STRUCT_VERSION(NV_ENC_SEQUENCE_PARAM_PAYLOAD, 1)
#define | NV_ENC_STAT_VER NVENCAPI_STRUCT_VERSION(NV_ENC_STAT, 1)

Typedefs

typedef enum _NV_ENC_BUFFER_FORMAT | NV_ENC_BUFFER_FORMAT
typedef enum _NV_ENC_CAPS | NV_ENC_CAPS
typedef struct _NV_ENC_CAPS_PARAM | NV_ENC_CAPS_PARAM
typedef union
_NV_ENC_CODEC_PIC_PARAMS 		NV_ENC_CODEC_PIC_PARAMS
typedef struct
_NV_ENC_CREATE_BITSTREAM_BUFFER 		NV_ENC_CREATE_BITSTREAM_BUFFER
typedef struct
_NV_ENC_CREATE_INPUT_BUFFER 		NV_ENC_CREATE_INPUT_BUFFER
typedef enum _NV_ENC_DEVICE_TYPE | NV_ENC_DEVICE_TYPE
typedef struct _NV_ENC_EVENT_PARAMS | NV_ENC_EVENT_PARAMS
typedef enum
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE 		NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
typedef enum
_NV_ENC_H264_BDIRECT_MODE 		NV_ENC_H264_BDIRECT_MODE
typedef enum
_NV_ENC_H264_ENTROPY_CODING_MODE 		NV_ENC_H264_ENTROPY_CODING_MODE
typedef enum _NV_ENC_H264_FMO_MODE | NV_ENC_H264_FMO_MODE
typedef enum _NV_ENC_HEVC_CUSIZE | NV_ENC_HEVC_CUSIZE
typedef enum
_NV_ENC_INPUT_RESOURCE_TYPE 		NV_ENC_INPUT_RESOURCE_TYPE
typedef enum _NV_ENC_LEVEL | NV_ENC_LEVEL
typedef enum _NV_ENC_MEMORY_HEAP | NV_ENC_MEMORY_HEAP
typedef enum _NV_ENC_MV_PRECISION | NV_ENC_MV_PRECISION
typedef struct
_NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS 		NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
typedef enum
_NV_ENC_PARAMS_FRAME_FIELD_MODE 		NV_ENC_PARAMS_FRAME_FIELD_MODE
typedef enum _NV_ENC_PARAMS_RC_MODE | NV_ENC_PARAMS_RC_MODE
typedef enum _NV_ENC_PIC_FLAGS | NV_ENC_PIC_FLAGS
typedef enum _NV_ENC_PIC_STRUCT | NV_ENC_PIC_STRUCT
typedef enum _NV_ENC_PIC_TYPE | NV_ENC_PIC_TYPE
typedef struct _NV_ENC_QP | NV_ENC_QP
typedef struct _NV_ENC_RC_PARAMS | NV_ENC_RC_PARAMS
typedef enum
_NV_ENC_STEREO_PACKING_MODE 		NV_ENC_STEREO_PACKING_MODE
typedef struct
_NV_ENCODE_API_FUNCTION_LIST 		NV_ENCODE_API_FUNCTION_LIST
typedef enum _NVENCSTATUS | NVENCSTATUS

Enumerations

enum _NV_ENC_BUFFER_FORMAT {
NV_ENC_BUFFER_FORMAT_UNDEFINED = 0x0,
NV_ENC_BUFFER_FORMAT_NV12_PL = 0x1,
NV_ENC_BUFFER_FORMAT_NV12_TILED16x16 = 0x2,
NV_ENC_BUFFER_FORMAT_NV12_TILED64x16 = 0x3,
NV_ENC_BUFFER_FORMAT_YV12_PL = 0x10,
NV_ENC_BUFFER_FORMAT_YV12_TILED16x16 = 0x20,
NV_ENC_BUFFER_FORMAT_YV12_TILED64x16 = 0x30,
NV_ENC_BUFFER_FORMAT_IYUV_PL = 0x100,
NV_ENC_BUFFER_FORMAT_IYUV_TILED16x16 = 0x200,
NV_ENC_BUFFER_FORMAT_IYUV_TILED64x16 = 0x300,
NV_ENC_BUFFER_FORMAT_YUV444_PL = 0x1000,
NV_ENC_BUFFER_FORMAT_YUV444_TILED16x16 = 0x2000,
NV_ENC_BUFFER_FORMAT_YUV444_TILED64x16 = 0x3000
}
enum _NV_ENC_CAPS {
NV_ENC_CAPS_NUM_MAX_BFRAMES,
NV_ENC_CAPS_SUPPORTED_RATECONTROL_MODES,
NV_ENC_CAPS_SUPPORT_FIELD_ENCODING,
NV_ENC_CAPS_SUPPORT_MONOCHROME,
NV_ENC_CAPS_SUPPORT_FMO,
NV_ENC_CAPS_SUPPORT_QPELMV,
NV_ENC_CAPS_SUPPORT_BDIRECT_MODE,
NV_ENC_CAPS_SUPPORT_CABAC,
NV_ENC_CAPS_SUPPORT_ADAPTIVE_TRANSFORM,
NV_ENC_CAPS_SUPPORT_RESERVED,
NV_ENC_CAPS_NUM_MAX_TEMPORAL_LAYERS,
NV_ENC_CAPS_SUPPORT_HIERARCHICAL_PFRAMES,
NV_ENC_CAPS_SUPPORT_HIERARCHICAL_BFRAMES,
NV_ENC_CAPS_LEVEL_MAX,
NV_ENC_CAPS_LEVEL_MIN,
NV_ENC_CAPS_SEPARATE_COLOUR_PLANE,
NV_ENC_CAPS_WIDTH_MAX,
NV_ENC_CAPS_HEIGHT_MAX,
NV_ENC_CAPS_SUPPORT_TEMPORAL_SVC,
NV_ENC_CAPS_SUPPORT_DYN_RES_CHANGE,
NV_ENC_CAPS_SUPPORT_DYN_BITRATE_CHANGE,
NV_ENC_CAPS_SUPPORT_DYN_FORCE_CONSTQP,
NV_ENC_CAPS_SUPPORT_DYN_RCMODE_CHANGE,
NV_ENC_CAPS_SUPPORT_SUBFRAME_READBACK,
NV_ENC_CAPS_SUPPORT_CONSTRAINED_ENCODING,
NV_ENC_CAPS_SUPPORT_INTRA_REFRESH,
NV_ENC_CAPS_SUPPORT_CUSTOM_VBV_BUF_SIZE,
NV_ENC_CAPS_SUPPORT_DYNAMIC_SLICE_MODE,
NV_ENC_CAPS_SUPPORT_REF_PIC_INVALIDATION,
NV_ENC_CAPS_PREPROC_SUPPORT,
NV_ENC_CAPS_ASYNC_ENCODE_SUPPORT,
NV_ENC_CAPS_MB_NUM_MAX,
NV_ENC_CAPS_MB_PER_SEC_MAX,
NV_ENC_CAPS_SUPPORT_YUV444_ENCODE,
NV_ENC_CAPS_SUPPORT_LOSSLESS_ENCODE,
NV_ENC_CAPS_EXPOSED_COUNT
}
enum _NV_ENC_DEVICE_TYPE {
NV_ENC_DEVICE_TYPE_DIRECTX = 0x0,
NV_ENC_DEVICE_TYPE_CUDA = 0x1
}
enum _NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE {
NV_ENC_H264_ADAPTIVE_TRANSFORM_AUTOSELECT = 0x0,
NV_ENC_H264_ADAPTIVE_TRANSFORM_DISABLE = 0x1,
NV_ENC_H264_ADAPTIVE_TRANSFORM_ENABLE = 0x2
}
enum _NV_ENC_H264_BDIRECT_MODE {
NV_ENC_H264_BDIRECT_MODE_AUTOSELECT = 0x0,
NV_ENC_H264_BDIRECT_MODE_DISABLE = 0x1,
NV_ENC_H264_BDIRECT_MODE_TEMPORAL = 0x2,
NV_ENC_H264_BDIRECT_MODE_SPATIAL = 0x3
}
enum _NV_ENC_H264_ENTROPY_CODING_MODE {
NV_ENC_H264_ENTROPY_CODING_MODE_AUTOSELECT = 0x0,
NV_ENC_H264_ENTROPY_CODING_MODE_CABAC = 0x1,
NV_ENC_H264_ENTROPY_CODING_MODE_CAVLC = 0x2
}
enum _NV_ENC_H264_FMO_MODE {
NV_ENC_H264_FMO_AUTOSELECT = 0x0,
NV_ENC_H264_FMO_ENABLE = 0x1,
NV_ENC_H264_FMO_DISABLE = 0x2
}
enum | _NV_ENC_HEVC_CUSIZE
enum _NV_ENC_INPUT_RESOURCE_TYPE {
NV_ENC_INPUT_RESOURCE_TYPE_DIRECTX = 0x0,
NV_ENC_INPUT_RESOURCE_TYPE_CUDADEVICEPTR = 0x1,
NV_ENC_INPUT_RESOURCE_TYPE_CUDAARRAY = 0x2
}
enum | _NV_ENC_LEVEL
enum _NV_ENC_MEMORY_HEAP {
NV_ENC_MEMORY_HEAP_AUTOSELECT = 0,
NV_ENC_MEMORY_HEAP_VID = 1,
NV_ENC_MEMORY_HEAP_SYSMEM_CACHED = 2,
NV_ENC_MEMORY_HEAP_SYSMEM_UNCACHED = 3
}
enum _NV_ENC_MV_PRECISION {
NV_ENC_MV_PRECISION_DEFAULT = 0x0,
NV_ENC_MV_PRECISION_FULL_PEL = 0x01,
NV_ENC_MV_PRECISION_HALF_PEL = 0x02,
NV_ENC_MV_PRECISION_QUARTER_PEL = 0x03
}
enum _NV_ENC_PARAMS_FRAME_FIELD_MODE {
NV_ENC_PARAMS_FRAME_FIELD_MODE_FRAME = 0x01,
NV_ENC_PARAMS_FRAME_FIELD_MODE_FIELD = 0x02,
NV_ENC_PARAMS_FRAME_FIELD_MODE_MBAFF = 0x03
}
enum _NV_ENC_PARAMS_RC_MODE {
NV_ENC_PARAMS_RC_CONSTQP = 0x0,
NV_ENC_PARAMS_RC_VBR = 0x1,
NV_ENC_PARAMS_RC_CBR = 0x2,
NV_ENC_PARAMS_RC_VBR_MINQP = 0x4,
NV_ENC_PARAMS_RC_2_PASS_QUALITY = 0x8,
NV_ENC_PARAMS_RC_2_PASS_FRAMESIZE_CAP = 0x10,
NV_ENC_PARAMS_RC_2_PASS_VBR = 0x20
}
enum _NV_ENC_PIC_FLAGS {
NV_ENC_PIC_FLAG_FORCEINTRA = 0x1,
NV_ENC_PIC_FLAG_FORCEIDR = 0x2,
NV_ENC_PIC_FLAG_OUTPUT_SPSPPS = 0x4,
NV_ENC_PIC_FLAG_EOS = 0x8
}
enum _NV_ENC_PIC_STRUCT {
NV_ENC_PIC_STRUCT_FRAME = 0x01,
NV_ENC_PIC_STRUCT_FIELD_TOP_BOTTOM = 0x02,
NV_ENC_PIC_STRUCT_FIELD_BOTTOM_TOP = 0x03
}
enum _NV_ENC_PIC_TYPE {
NV_ENC_PIC_TYPE_P = 0x0,
NV_ENC_PIC_TYPE_B = 0x01,
NV_ENC_PIC_TYPE_I = 0x02,
NV_ENC_PIC_TYPE_IDR = 0x03,
NV_ENC_PIC_TYPE_BI = 0x04,
NV_ENC_PIC_TYPE_SKIPPED = 0x05,
NV_ENC_PIC_TYPE_INTRA_REFRESH = 0x06,
NV_ENC_PIC_TYPE_UNKNOWN = 0xFF
}
enum _NV_ENC_STEREO_PACKING_MODE {
NV_ENC_STEREO_PACKING_MODE_NONE = 0x0,
NV_ENC_STEREO_PACKING_MODE_CHECKERBOARD = 0x1,
NV_ENC_STEREO_PACKING_MODE_COLINTERLEAVE = 0x2,
NV_ENC_STEREO_PACKING_MODE_ROWINTERLEAVE = 0x3,
NV_ENC_STEREO_PACKING_MODE_SIDEBYSIDE = 0x4,
NV_ENC_STEREO_PACKING_MODE_TOPBOTTOM = 0x5,
NV_ENC_STEREO_PACKING_MODE_FRAMESEQ = 0x6
}
enum _NVENCSTATUS {
NV_ENC_SUCCESS,
NV_ENC_ERR_NO_ENCODE_DEVICE,
NV_ENC_ERR_UNSUPPORTED_DEVICE,
NV_ENC_ERR_INVALID_ENCODERDEVICE,
NV_ENC_ERR_INVALID_DEVICE,
NV_ENC_ERR_DEVICE_NOT_EXIST,
NV_ENC_ERR_INVALID_PTR,
NV_ENC_ERR_INVALID_EVENT,
NV_ENC_ERR_INVALID_PARAM,
NV_ENC_ERR_INVALID_CALL,
NV_ENC_ERR_OUT_OF_MEMORY,
NV_ENC_ERR_ENCODER_NOT_INITIALIZED,
NV_ENC_ERR_UNSUPPORTED_PARAM,
NV_ENC_ERR_LOCK_BUSY,
NV_ENC_ERR_NOT_ENOUGH_BUFFER,
NV_ENC_ERR_INVALID_VERSION,
NV_ENC_ERR_MAP_FAILED,
NV_ENC_ERR_NEED_MORE_INPUT,
NV_ENC_ERR_ENCODER_BUSY,
NV_ENC_ERR_EVENT_NOT_REGISTERD,
NV_ENC_ERR_GENERIC,
NV_ENC_ERR_INCOMPATIBLE_CLIENT_KEY,
NV_ENC_ERR_UNIMPLEMENTED,
NV_ENC_ERR_RESOURCE_REGISTER_FAILED,
NV_ENC_ERR_RESOURCE_NOT_REGISTERED,
NV_ENC_ERR_RESOURCE_NOT_MAPPED
}


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_CAPS_PARAM Struct Reference
NvEncodeAPI Data structures

Data Fields

NV_ENC_CAPS capsToQuery
uint32_t | reserved [62]
uint32_t | version

Detailed Description

Input struct for querying Encoding capabilities.


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_CODEC_CONFIG Struct Reference
NvEncodeAPI Data structures

Data Fields

NV_ENC_CONFIG_H264 h264Config
NV_ENC_CONFIG_HEVC hevcConfig
uint32_t reserved [256]

Detailed Description

Codec-specific encoder configuration parameters to be set during initialization.


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_CODEC_PIC_PARAMS Union Reference
NvEncodeAPI Data structures

Data Fields

NV_ENC_PIC_PARAMS_H264 h264PicParams
NV_ENC_PIC_PARAMS_HEVC hevcPicParams
uint32_t reserved [256]

Detailed Description

Codec specific per-picture encoding parameters.


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_CONFIG Struct Reference
NvEncodeAPI Data structures

Data Fields

NV_ENC_CODEC_CONFIG encodeCodecConfig
NV_ENC_PARAMS_FRAME_FIELD_MODE frameFieldMode
int32_t | frameIntervalP
uint32_t | gopLength
uint32_t | monoChromeEncoding
NV_ENC_MV_PRECISION mvPrecision
GUID profileGUID
NV_ENC_RC_PARAMS rcParams
uint32_t | reserved [278]
void * | reserved2 [64]
uint32_t | version

Detailed Description

Encoder configuration parameters to be set during initialization.


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_CONFIG_H264 Struct Reference
NvEncodeAPI Data structures

Data Fields

NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE adaptiveTransformMode
NV_ENC_H264_BDIRECT_MODE bdirectMode
uint32_t | chromaFormatIDC
uint32_t | disableDeblockingFilterIDC
uint32_t | disableSPSPPS:1
uint32_t | enableConstrainedEncoding:1
uint32_t | enableIntraRefresh:1
uint32_t | enableLTR:1
uint32_t | enableStereoMVC:1
uint32_t | enableTemporalSVC:1
uint32_t | enableVFR:1
NV_ENC_H264_ENTROPY_CODING_MODE entropyCodingMode
NV_ENC_H264_FMO_MODE fmoMode
NV_ENC_CONFIG_H264_VUI_PARAMETERS h264VUIParameters
uint32_t | hierarchicalBFrames:1
uint32_t | hierarchicalPFrames:1
uint32_t | idrPeriod
uint32_t | intraRefreshCnt
uint32_t | intraRefreshPeriod
uint32_t | level
uint32_t | ltrNumFrames
uint32_t | ltrTrustMode
uint32_t | maxNumRefFrames
uint32_t | numTemporalLayers
uint32_t | outputAUD:1
uint32_t | outputBufferingPeriodSEI:1
uint32_t | outputFramePackingSEI:1
uint32_t | outputPictureTimingSEI:1
uint32_t | outputRecoveryPointSEI:1
uint32_t | ppsId
uint32_t | qpPrimeYZeroTransformBypassFlag:1
uint32_t | repeatSPSPPS:1
uint32_t | reserved1 [271]
void * | reserved2 [64]
uint32_t | reservedBitFields:16
uint32_t | separateColourPlaneFlag
uint32_t | sliceMode
uint32_t | sliceModeData
uint32_t | spsId
NV_ENC_STEREO_PACKING_MODE stereoMode

Detailed Description

H264 encoder configuration parameters


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_CONFIG_H264_VUI_PARAMETERS Struct Reference
NvEncodeAPI Data structures

Data Fields

uint32_t | bitstreamRestrictionFlag
uint32_t | chromaSampleLocationBot
uint32_t | chromaSampleLocationFlag
uint32_t | chromaSampleLocationTop
uint32_t | colourDescriptionPresentFlag
uint32_t | colourMatrix
uint32_t | colourPrimaries
uint32_t | overscanInfo
uint32_t | overscanInfoPresentFlag
uint32_t | transferCharacteristics
uint32_t | videoFormat
uint32_t | videoFullRangeFlag
uint32_t | videoSignalTypePresentFlag

Detailed Description

H264 Video Usability Info parameters


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_CONFIG_HEVC Struct Reference
NvEncodeAPI Data structures

Data Fields

uint32_t | disableDeblockAcrossSliceBoundary:1
uint32_t | disableSPSPPS:1
uint32_t | enableIntraRefresh:1
uint32_t | enableLTR:1
uint32_t | idrPeriod
uint32_t | intraRefreshCnt
uint32_t | intraRefreshPeriod
uint32_t | level
uint32_t | ltrNumFrames
NV_ENC_HEVC_CUSIZE maxCUSize
uint32_t | maxNumRefFramesInDPB
uint32_t | maxTemporalLayersMinus1
NV_ENC_HEVC_CUSIZE minCUSize
uint32_t | outputAUD:1
uint32_t | outputBufferingPeriodSEI:1
uint32_t | outputPictureTimingSEI:1
uint32_t | ppsId
uint32_t | repeatSPSPPS:1
uint32_t | reserved:23
uint32_t | reserved1 [246]
void * | reserved2 [64]
uint32_t | sliceMode
uint32_t | sliceModeData
uint32_t | spsId
uint32_t | tier
uint32_t | useConstrainedIntraPred:1
uint32_t | vpsId

Detailed Description

HEVC encoder configuration parameters to be set during initialization.


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_CREATE_BITSTREAM_BUFFER Struct Reference
NvEncodeAPI Data structures

Data Fields

NV_ENC_OUTPUT_PTR | bitstreamBuffer
void * | bitstreamBufferPtr
NV_ENC_MEMORY_HEAP memoryHeap
uint32_t | reserved
uint32_t | reserved1 [58]
void * | reserved2 [64]
uint32_t | size
uint32_t | version

Detailed Description

Creation parameters for output bitstream buffer.


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_CREATE_INPUT_BUFFER Struct Reference
NvEncodeAPI Data structures

Data Fields

NV_ENC_BUFFER_FORMAT bufferFmt
uint32_t | height
NV_ENC_INPUT_PTR | inputBuffer
NV_ENC_MEMORY_HEAP memoryHeap
void * | pSysMemBuffer
uint32_t | reserved
uint32_t | reserved1 [57]
void * | reserved2 [63]
uint32_t | version
uint32_t | width

Detailed Description

Creation parameters for input buffer.


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_EVENT_PARAMS Struct Reference
NvEncodeAPI Data structures

Data Fields

void * | completionEvent
uint32_t | reserved
uint32_t | reserved1 [253]
void * | reserved2 [64]
uint32_t | version

Detailed Description

Event registration/unregistration parameters.


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_H264_SEI_PAYLOAD Struct Reference
NvEncodeAPI Data structures

Data Fields

uint8_t * | payload
uint32_t | payloadSize
uint32_t | payloadType

Detailed Description

User SEI message


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_INITIALIZE_PARAMS Struct Reference
NvEncodeAPI Data structures

Data Fields

uint32_t | darHeight
uint32_t | darWidth
uint32_t | enableEncodeAsync
uint32_t | enableExternalMEHints:1
uint32_t | enablePTD
uint32_t | enableSubFrameWrite:1
NV_ENC_CONFIG * encodeConfig
GUID encodeGUID
uint32_t | encodeHeight
uint32_t | encodeWidth
uint32_t | frameRateDen
uint32_t | frameRateNum
uint32_t | maxEncodeHeight
uint32_t | maxEncodeWidth
NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE | maxMEHintCountsPerBlock [2]
GUID presetGUID
void * | privData
uint32_t | privDataSize
uint32_t | reportSliceOffsets:1
uint32_t | reserved [289]
void * | reserved2 [64]
uint32_t | reservedBitFields:29
uint32_t | version

Detailed Description

Encode Session Initialization parameters.


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_LOCK_BITSTREAM Struct Reference
NvEncodeAPI Data structures

Data Fields

void * | bitstreamBufferPtr
uint32_t | bitstreamSizeInBytes
uint32_t | doNotWait:1
uint32_t | frameAvgQP
uint32_t | frameIdx
uint32_t | frameSatd
uint32_t | hwEncodeStatus
uint32_t | ltrFrame:1
uint32_t | ltrFrameBitmap
uint32_t | ltrFrameIdx
uint32_t | numSlices
void * | outputBitstream
uint64_t | outputDuration
uint64_t | outputTimeStamp
NV_ENC_PIC_STRUCT pictureStruct
NV_ENC_PIC_TYPE pictureType
uint32_t | reserved [236]
void * | reserved2 [64]
uint32_t | reservedBitFields:30
uint32_t * | sliceOffsets
uint32_t | version

Detailed Description

Bitstream buffer lock parameters.


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_LOCK_INPUT_BUFFER Struct Reference
NvEncodeAPI Data structures

Data Fields

void * | bufferDataPtr
uint32_t | doNotWait:1
NV_ENC_INPUT_PTR | inputBuffer
uint32_t | pitch
uint32_t | reserved1 [251]
void * | reserved2 [64]
uint32_t | reservedBitFields:31
uint32_t | version

Detailed Description

Uncompressed Input Buffer lock parameters.


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_MAP_INPUT_RESOURCE Struct Reference
NvEncodeAPI Data structures

Data Fields

void * | inputResource
NV_ENC_BUFFER_FORMAT mappedBufferFmt
NV_ENC_INPUT_PTR | mappedResource
NV_ENC_REGISTERED_PTR | registeredResource
uint32_t | reserved1 [251]
void * | reserved2 [63]
uint32_t | subResourceIndex
uint32_t | version

Detailed Description

Map an input resource to a Nvidia Encoder Input Buffer


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS Struct Reference
NvEncodeAPI Data structures

Data Fields

uint32_t | apiVersion
void * | device
NV_ENC_DEVICE_TYPE deviceType
void * | reserved
uint32_t | reserved1 [253]
void * | reserved2 [64]
uint32_t | version

Detailed Description

Encoder Session Creation parameters


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_PIC_PARAMS Struct Reference
NvEncodeAPI Data structures

Data Fields

NV_ENC_BUFFER_FORMAT bufferFmt
NV_ENC_CODEC_PIC_PARAMS codecPicParams
void * | completionEvent
uint32_t | encodePicFlags
uint32_t | frameIdx
NV_ENC_INPUT_PTR | inputBuffer
uint64_t | inputDuration
uint32_t | inputHeight
uint32_t | inputPitch
uint64_t | inputTimeStamp
uint32_t | inputWidth
NVENC_EXTERNAL_ME_HINT * meExternalHints
NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE | meHintCountsPerBlock [2]
NV_ENC_OUTPUT_PTR | outputBitstream
NV_ENC_PIC_STRUCT pictureStruct
NV_ENC_PIC_TYPE pictureType
int8_t * | qpDeltaMap
uint32_t | qpDeltaMapSize
uint32_t | reserved1 [6]
void * | reserved2 [2]
uint32_t | reserved3 [287]
void * | reserved4 [60]
uint32_t | reservedBitFields
uint32_t | version

Detailed Description

Encoding parameters that need to be sent on a per frame basis.


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_PIC_PARAMS_H264 Struct Reference
NvEncodeAPI Data structures

Data Fields

uint32_t | colourPlaneId
uint32_t | constrainedFrame:1
uint32_t | displayPOCSyntax
uint32_t | forceIntraRefreshWithFrameCnt
uint32_t | ltrMarkFrame:1
uint32_t | ltrMarkFrameIdx
uint32_t | ltrUsageMode
uint32_t | ltrUseFrameBitmap
uint32_t | ltrUseFrames:1
uint32_t | refPicFlag
uint32_t | reserved [243]
void * | reserved2 [62]
uint32_t | reserved3
uint32_t | reservedBitFields:28
NV_ENC_H264_SEI_PAYLOAD * seiPayloadArray
uint32_t | seiPayloadArrayCnt
uint32_t | sliceMode
uint32_t | sliceModeData
uint32_t | sliceModeDataUpdate:1

Detailed Description

H264 specific enc pic params. sent on a per frame basis.


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_PIC_PARAMS_HEVC Struct Reference
NvEncodeAPI Data structures

Data Fields

uint32_t | constrainedFrame:1
uint32_t | displayPOCSyntax
uint32_t | forceIntraRefreshWithFrameCnt
uint32_t | ltrMarkFrame:1
uint32_t | ltrMarkFrameIdx
uint32_t | ltrUsageMode
uint32_t | ltrUseFrameBitmap
uint32_t | ltrUseFrames:1
uint32_t | refPicFlag
uint32_t | reserved [246]
void * | reserved2 [62]
uint32_t | reservedBitFields:28
uint32_t | sliceMode
uint32_t | sliceModeData
uint32_t | sliceModeDataUpdate:1
uint32_t | sliceTypeArrayCnt
uint8_t * | sliceTypeData
uint32_t | temporalId

Detailed Description

HEVC specific enc pic params. sent on a per frame basis.


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_PRESET_CONFIG Struct Reference
NvEncodeAPI Data structures

Data Fields

NV_ENC_CONFIG presetCfg
uint32_t | reserved1 [255]
void * | reserved2 [64]
uint32_t | version

Detailed Description

Encoder preset config


  • Data Structure Index
  • Data Fields
_NV_ENC_QP Struct Reference
NvEncodeAPI Data structures

Detailed Description

QP value for frames


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_RC_PARAMS Struct Reference
NvEncodeAPI Data structures

Data Fields

uint32_t | averageBitRate
NV_ENC_QP constQP
uint32_t | enableAQ:1
uint32_t | enableExtQPDeltaMap:1
uint32_t | enableInitialRCQP:1
uint32_t | enableMaxQP:1
uint32_t | enableMinQP:1
NV_ENC_QP initialRCQP
uint32_t | maxBitRate
NV_ENC_QP maxQP
NV_ENC_QP minQP
NV_ENC_PARAMS_RC_MODE rateControlMode
uint32_t | reservedBitFields:27
uint32_t | temporallayerIdxMask
uint8_t | temporalLayerQP [8]
uint32_t | vbvBufferSize
uint32_t | vbvInitialDelay

Detailed Description

Rate Control Configuration Paramters


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_RECONFIGURE_PARAMS Struct Reference
NvEncodeAPI Data structures

Data Fields

uint32_t | forceIDR:1
NV_ENC_INITIALIZE_PARAMS reInitEncodeParams
uint32_t | resetEncoder:1
uint32_t | version

Detailed Description

Encode Session Reconfigured parameters.


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_REGISTER_RESOURCE Struct Reference
NvEncodeAPI Data structures

Data Fields

NV_ENC_BUFFER_FORMAT bufferFormat
uint32_t | height
uint32_t | pitch
NV_ENC_REGISTERED_PTR | registeredResource
uint32_t | reserved1 [248]
void * | reserved2 [62]
void * | resourceToRegister
NV_ENC_INPUT_RESOURCE_TYPE resourceType
uint32_t | subResourceIndex
uint32_t | version
uint32_t | width

Detailed Description

Register a resource for future use with the Nvidia Video Encoder Interface.


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_SEQUENCE_PARAM_PAYLOAD Struct Reference
NvEncodeAPI Data structures

Data Fields

uint32_t | inBufferSize
uint32_t * | outSPSPPSPayloadSize
uint32_t | ppsId
uint32_t | reserved [250]
void * | reserved2 [64]
uint32_t | spsId
void * | spsppsBuffer
uint32_t | version

Detailed Description

Sequence and picture paramaters payload.


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENC_STAT Struct Reference
NvEncodeAPI Data structures

Data Fields

uint32_t | bitStreamSize
uint32_t | lastValidByteOffset
NV_ENC_OUTPUT_PTR | outputBitStream
uint32_t | picIdx
uint32_t | picType
uint32_t | reserved
uint32_t | reserved1 [233]
void * | reserved2 [64]
uint32_t | sliceOffsets [16]
uint32_t | version

Detailed Description

Encode Stats structure.


  • Data Structure Index
  • Data Fields
Data Fields
_NV_ENCODE_API_FUNCTION_LIST Struct Reference
NvEncodeAPI Data structures

Data Fields

PNVENCCREATEBITSTREAMBUFFER | nvEncCreateBitstreamBuffer
PNVENCCREATEINPUTBUFFER | nvEncCreateInputBuffer
PNVENCDESTROYBITSTREAMBUFFER | nvEncDestroyBitstreamBuffer
PNVENCDESTROYENCODER | nvEncDestroyEncoder
PNVENCDESTROYINPUTBUFFER | nvEncDestroyInputBuffer
PNVENCENCODEPICTURE | nvEncEncodePicture
PNVENCGETENCODECAPS | nvEncGetEncodeCaps
PNVENCGETENCODEGUIDCOUNT | nvEncGetEncodeGUIDCount
PNVENCGETENCODEGUIDS | nvEncGetEncodeGUIDs
PNVENCGETENCODEPRESETCONFIG | nvEncGetEncodePresetConfig
PNVENCGETENCODEPRESETCOUNT | nvEncGetEncodePresetCount
PNVENCGETENCODEPRESETGUIDS | nvEncGetEncodePresetGUIDs
PNVENCGETENCODEPRESETCOUNT | nvEncGetEncodeProfileGUIDCount
PNVENCGETENCODEPRESETGUIDS | nvEncGetEncodeProfileGUIDs
PNVENCGETENCODESTATS | nvEncGetEncodeStats
PNVENCGETINPUTFORMATCOUNT | nvEncGetInputFormatCount
PNVENCGETINPUTFORMATS | nvEncGetInputFormats
PNVENCGETSEQUENCEPARAMS | nvEncGetSequenceParams
PNVENCINITIALIZEENCODER | nvEncInitializeEncoder
PNVENCINVALIDATEREFFRAMES | nvEncInvalidateRefFrames
PNVENCLOCKBITSTREAM | nvEncLockBitstream
PNVENCLOCKINPUTBUFFER | nvEncLockInputBuffer
PNVENCMAPINPUTRESOURCE | nvEncMapInputResource
PNVENCOPENENCODESESSION | nvEncOpenEncodeSession
PNVENCOPENENCODESESSIONEX | nvEncOpenEncodeSessionEx
PNVENCRECONFIGUREENCODER | nvEncReconfigureEncoder
PNVENCREGISTERASYNCEVENT | nvEncRegisterAsyncEvent
PNVENCREGISTERRESOURCE | nvEncRegisterResource
PNVENCUNLOCKBITSTREAM | nvEncUnlockBitstream
PNVENCUNLOCKINPUTBUFFER | nvEncUnlockInputBuffer
PNVENCUNMAPINPUTRESOURCE | nvEncUnmapInputResource
PNVENCUNREGISTERASYNCEVENT | nvEncUnregisterAsyncEvent
PNVENCUNREGISTERRESOURCE | nvEncUnregisterResource
uint32_t | reserved
void * | reserved2 [285]
uint32_t | version

Detailed Description

NV_ENCODE_API_FUNCTION_LIST


  • Data Structure Index
  • Data Fields
Data Fields
_NVENC_EXTERNAL_ME_HINT Struct Reference
NvEncodeAPI Data structures

Data Fields

int32_t | dir: 1
int32_t | lastOfMB: 1
int32_t | lastofPart: 1
int32_t | mvx: 12
int32_t | mvy: 10
int32_t | partType: 2
int32_t | refidx: 5

Detailed Description

External Motion Vector hint structure.


  • Data Structure Index
  • Data Fields
Data Fields
_NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE Struct Reference
NvEncodeAPI Data structures

Data Fields

uint32_t | numCandsPerBlk16x16: 4
uint32_t | numCandsPerBlk16x8: 4
uint32_t | numCandsPerBlk8x16: 4
uint32_t | numCandsPerBlk8x8: 4
uint32_t | reserved: 16
uint32_t | reserved1 [3]

Detailed Description

External motion vector hint counts per block type.


  • Data Structure Index
  • Data Fields
Data Fields
_NVENC_RECT Struct Reference
NvEncodeAPI Data structures

Data Fields

uint32_t | bottom
uint32_t | left
uint32_t | right
uint32_t | top

Detailed Description

Defines a Rectangle. Used in ::NV_ENC_PREPROCESS_FRAME.


  • Data Structure Index
  • Data Fields
Data Fields
GUID Struct Reference
NvEncodeAPI Data structures

Data Fields

uint32_t | Data1
uint16_t | Data2
uint16_t | Data3
uint8_t | Data4 [8]

Detailed Description

Abstracts the GUID structure for non-windows platforms.


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
#define NV_ENC_CAPS_PARAM_VER NVENCAPI_STRUCT_VERSION(NV_ENC_CAPS_PARAM, 1)

NV_ENC_CAPS_PARAM struct version.


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
#define NV_ENC_CONFIG_VER (NVENCAPI_STRUCT_VERSION(NV_ENC_CONFIG, 5) | ( 1<<31 ))

macro for constructing the version field of _NV_ENC_CONFIG


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
#define NV_ENC_CREATE_BITSTREAM_BUFFER_VER NVENCAPI_STRUCT_VERSION(NV_ENC_CREATE_BITSTREAM_BUFFER, 1)

NV_ENC_CREATE_BITSTREAM_BUFFER struct version.


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
#define NV_ENC_CREATE_INPUT_BUFFER_VER NVENCAPI_STRUCT_VERSION(NV_ENC_CREATE_INPUT_BUFFER, 1)

NV_ENC_CREATE_INPUT_BUFFER struct version.


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
#define NV_ENC_EVENT_PARAMS_VER NVENCAPI_STRUCT_VERSION(NV_ENC_EVENT_PARAMS, 1)

Macro for constructing the version field of _NV_ENC_EVENT_PARAMS


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
#define NV_ENC_INITIALIZE_PARAMS_VER (NVENCAPI_STRUCT_VERSION(NV_ENC_INITIALIZE_PARAMS, 5) | ( 1<<31 ))

macro for constructing the version field of _NV_ENC_INITIALIZE_PARAMS


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
#define NV_ENC_LOCK_BITSTREAM_VER NVENCAPI_STRUCT_VERSION(NV_ENC_LOCK_BITSTREAM, 1)

Macro for constructing the version field of _NV_ENC_LOCK_BITSTREAM


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
#define NV_ENC_LOCK_INPUT_BUFFER_VER NVENCAPI_STRUCT_VERSION(NV_ENC_LOCK_INPUT_BUFFER, 1)

Macro for constructing the version field of _NV_ENC_LOCK_INPUT_BUFFER


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
#define NV_ENC_MAP_INPUT_RESOURCE_VER NVENCAPI_STRUCT_VERSION(NV_ENC_MAP_INPUT_RESOURCE, 4)

Macro for constructing the version field of _NV_ENC_MAP_INPUT_RESOURCE


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
#define NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER NVENCAPI_STRUCT_VERSION(NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS, 1)

Macro for constructing the version field of _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
#define NV_ENC_PARAMS_RC_CBR2 NV_ENC_PARAMS_RC_CBR

Deprecated


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
#define NV_ENC_PIC_PARAMS_VER (NVENCAPI_STRUCT_VERSION(NV_ENC_PIC_PARAMS, 4) | ( 1<<31 ))

Macro for constructing the version field of _NV_ENC_PIC_PARAMS


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
#define NV_ENC_PRESET_CONFIG_VER (NVENCAPI_STRUCT_VERSION(NV_ENC_PRESET_CONFIG, 4) | ( 1<<31 ))

macro for constructing the version field of _NV_ENC_PRESET_CONFIG


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
#define NV_ENC_RC_PARAMS_VER NVENCAPI_STRUCT_VERSION(NV_ENC_RC_PARAMS, 1)

macro for constructing the version field of _NV_ENC_RC_PARAMS


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
#define NV_ENC_RECONFIGURE_PARAMS_VER (NVENCAPI_STRUCT_VERSION(NV_ENC_RECONFIGURE_PARAMS, 1) | ( 1<<31 ))

macro for constructing the version field of _NV_ENC_RECONFIGURE_PARAMS


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
#define NV_ENC_REGISTER_RESOURCE_VER NVENCAPI_STRUCT_VERSION(NV_ENC_REGISTER_RESOURCE, 3)

Macro for constructing the version field of _NV_ENC_REGISTER_RESOURCE


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
#define NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER NVENCAPI_STRUCT_VERSION(NV_ENC_SEQUENCE_PARAM_PAYLOAD, 1)

Macro for constructing the version field of _NV_ENC_SEQUENCE_PARAM_PAYLOAD


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
#define NV_ENC_STAT_VER NVENCAPI_STRUCT_VERSION(NV_ENC_STAT, 1)

Macro for constructing the version field of _NV_ENC_STAT


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef enum _NV_ENC_BUFFER_FORMAT NV_ENC_BUFFER_FORMAT

Input buffer formats


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef enum _NV_ENC_CAPS NV_ENC_CAPS

Encoder capabilities enumeration.


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef struct _NV_ENC_CAPS_PARAM NV_ENC_CAPS_PARAM

Input struct for querying Encoding capabilities.


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef union _NV_ENC_CODEC_PIC_PARAMS NV_ENC_CODEC_PIC_PARAMS

Codec specific per-picture encoding parameters.


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef struct _NV_ENC_CREATE_BITSTREAM_BUFFER NV_ENC_CREATE_BITSTREAM_BUFFER

Creation parameters for output bitstream buffer.


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef struct _NV_ENC_CREATE_INPUT_BUFFER NV_ENC_CREATE_INPUT_BUFFER

Creation parameters for input buffer.


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef enum _NV_ENC_DEVICE_TYPE NV_ENC_DEVICE_TYPE

Encoder Device type


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef struct _NV_ENC_EVENT_PARAMS NV_ENC_EVENT_PARAMS

Event registration/unregistration parameters.


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef enum _NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE

H.264 specific Adaptive Transform modes


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef enum _NV_ENC_H264_BDIRECT_MODE NV_ENC_H264_BDIRECT_MODE

H.264 specific Bdirect modes


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef enum _NV_ENC_H264_ENTROPY_CODING_MODE NV_ENC_H264_ENTROPY_CODING_MODE

H.264 entropy coding modes.


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef enum _NV_ENC_H264_FMO_MODE NV_ENC_H264_FMO_MODE

H.264 specific FMO usage


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef enum _NV_ENC_HEVC_CUSIZE NV_ENC_HEVC_CUSIZE

HEVC CU SIZE


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef enum _NV_ENC_INPUT_RESOURCE_TYPE NV_ENC_INPUT_RESOURCE_TYPE

Input Resource type


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef enum _NV_ENC_LEVEL NV_ENC_LEVEL

Encoding levels


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef enum _NV_ENC_MEMORY_HEAP NV_ENC_MEMORY_HEAP

Memory heap to allocate input and output buffers.


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef enum _NV_ENC_MV_PRECISION NV_ENC_MV_PRECISION

Motion vector precisions


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef struct _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS

Encoder Session Creation parameters


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef enum _NV_ENC_PARAMS_FRAME_FIELD_MODE NV_ENC_PARAMS_FRAME_FIELD_MODE

Input frame encode modes


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef enum _NV_ENC_PARAMS_RC_MODE NV_ENC_PARAMS_RC_MODE

Rate Control Modes


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef enum _NV_ENC_PIC_FLAGS NV_ENC_PIC_FLAGS

Encode Picture encode flags.


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef enum _NV_ENC_PIC_STRUCT NV_ENC_PIC_STRUCT

Input picture structure


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef enum _NV_ENC_PIC_TYPE NV_ENC_PIC_TYPE

Input picture type


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef struct _NV_ENC_QP NV_ENC_QP

QP value for frames


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef struct _NV_ENC_RC_PARAMS NV_ENC_RC_PARAMS

Rate Control Configuration Paramters


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef enum _NV_ENC_STEREO_PACKING_MODE NV_ENC_STEREO_PACKING_MODE

Stereo frame packing modes.


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef struct _NV_ENCODE_API_FUNCTION_LIST NV_ENCODE_API_FUNCTION_LIST

NV_ENCODE_API_FUNCTION_LIST


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
typedef enum _NVENCSTATUS NVENCSTATUS

Error Codes


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
enum _NV_ENC_BUFFER_FORMAT

Input buffer formats

Enumerator:
NV_ENC_BUFFER_FORMAT_UNDEFINED

Undefined buffer format.

NV_ENC_BUFFER_FORMAT_NV12_PL

Semi-Planar YUV [UV interleaved] allocated as serial 2D buffer.

NV_ENC_BUFFER_FORMAT_NV12_TILED16x16

Semi-Planar YUV [UV interleaved] allocated as 16x16 tiles.

NV_ENC_BUFFER_FORMAT_NV12_TILED64x16

Semi-Planar YUV [UV interleaved] allocated as 64x16 tiles.

NV_ENC_BUFFER_FORMAT_YV12_PL

Planar YUV [YUV separate planes] allocated as serial 2D buffer.

NV_ENC_BUFFER_FORMAT_YV12_TILED16x16

Planar YUV [YUV separate planes] allocated as 16x16 tiles.

NV_ENC_BUFFER_FORMAT_YV12_TILED64x16

Planar YUV [YUV separate planes] allocated as 64x16 tiles.

NV_ENC_BUFFER_FORMAT_IYUV_PL

Packed YUV [YUV separate bytes per pixel] allocated as serial 2D buffer.

NV_ENC_BUFFER_FORMAT_IYUV_TILED16x16

Packed YUV [YUV separate bytes per pixel] allocated as 16x16 tiles.

NV_ENC_BUFFER_FORMAT_IYUV_TILED64x16

Packed YUV [YUV separate bytes per pixel] allocated as 64x16 tiles.

NV_ENC_BUFFER_FORMAT_YUV444_PL

Planar YUV [YUV separate bytes per pixel] allocated as serial 2D buffer.

NV_ENC_BUFFER_FORMAT_YUV444_TILED16x16

Planar YUV [YUV separate bytes per pixel] allocated as 16x16 tiles.

NV_ENC_BUFFER_FORMAT_YUV444_TILED64x16

Planar YUV [YUV separate bytes per pixel] allocated as 64x16 tiles.


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
enum _NV_ENC_CAPS

Encoder capabilities enumeration.

Enumerator:
NV_ENC_CAPS_NUM_MAX_BFRAMES

Maximum number of B-Frames supported.

NV_ENC_CAPS_SUPPORTED_RATECONTROL_MODES

Rate control modes supported.
The API return value is a bitmask of the values in NV_ENC_PARAMS_RC_MODE.

NV_ENC_CAPS_SUPPORT_FIELD_ENCODING

Indicates HW support for field mode encoding.
0 : Interlaced mode encoding is not supported.
1 : Interlaced field mode encoding is supported.
2 : Interlaced frame encoding and field mode encoding are both supported.

NV_ENC_CAPS_SUPPORT_MONOCHROME

Indicates HW support for monochrome mode encoding.
0 : Monochrome mode not supported.
1 : Monochrome mode supported.

NV_ENC_CAPS_SUPPORT_FMO

Indicates HW support for FMO.
0 : FMO not supported.
1 : FMO supported.

NV_ENC_CAPS_SUPPORT_QPELMV

Indicates HW capability for Quarter pel motion estimation.
0 : QuarterPel Motion Estimation not supported.
1 : QuarterPel Motion Estimation supported.

NV_ENC_CAPS_SUPPORT_BDIRECT_MODE

H.264 specific. Indicates HW support for BDirect modes.
0 : BDirect mode encoding not supported.
1 : BDirect mode encoding supported.

NV_ENC_CAPS_SUPPORT_CABAC

H264 specific. Indicates HW support for CABAC entropy coding mode.
0 : CABAC entropy coding not supported.
1 : CABAC entropy coding supported.

NV_ENC_CAPS_SUPPORT_ADAPTIVE_TRANSFORM

Indicates HW support for Adaptive Transform.
0 : Adaptive Transform not supported.
1 : Adaptive Transform supported.

NV_ENC_CAPS_SUPPORT_RESERVED

Reserved enum field.

NV_ENC_CAPS_NUM_MAX_TEMPORAL_LAYERS

Indicates HW support for encoding Temporal layers.
0 : Encoding Temporal layers not supported.
1 : Encoding Temporal layers supported.

NV_ENC_CAPS_SUPPORT_HIERARCHICAL_PFRAMES

Indicates HW support for Hierarchical P frames.
0 : Hierarchical P frames not supported.
1 : Hierarchical P frames supported.

NV_ENC_CAPS_SUPPORT_HIERARCHICAL_BFRAMES

Indicates HW support for Hierarchical B frames.
0 : Hierarchical B frames not supported.
1 : Hierarchical B frames supported.

NV_ENC_CAPS_LEVEL_MAX

Maximum Encoding level supported (See NV_ENC_LEVEL for details).

NV_ENC_CAPS_LEVEL_MIN

Minimum Encoding level supported (See NV_ENC_LEVEL for details).

NV_ENC_CAPS_SEPARATE_COLOUR_PLANE

Indicates HW support for separate colour plane encoding.
0 : Separate colour plane encoding not supported.
1 : Separate colour plane encoding supported.

NV_ENC_CAPS_WIDTH_MAX

Maximum output width supported.

NV_ENC_CAPS_HEIGHT_MAX

Maximum output height supported.

NV_ENC_CAPS_SUPPORT_TEMPORAL_SVC

Indicates Temporal Scalability Support.
0 : Temporal SVC encoding not supported.
1 : Temporal SVC encoding supported.

NV_ENC_CAPS_SUPPORT_DYN_RES_CHANGE

Indicates Dynamic Encode Resolution Change Support. Support added from NvEncodeAPI version 2.0.
0 : Dynamic Encode Resolution Change not supported.
1 : Dynamic Encode Resolution Change supported.

NV_ENC_CAPS_SUPPORT_DYN_BITRATE_CHANGE

Indicates Dynamic Encode Bitrate Change Support. Support added from NvEncodeAPI version 2.0.
0 : Dynamic Encode bitrate change not supported.
1 : Dynamic Encode bitrate change supported.

NV_ENC_CAPS_SUPPORT_DYN_FORCE_CONSTQP

Indicates Forcing Constant QP On The Fly Support. Support added from NvEncodeAPI version 2.0.
0 : Forcing constant QP on the fly not supported.
1 : Forcing constant QP on the fly supported.

NV_ENC_CAPS_SUPPORT_DYN_RCMODE_CHANGE

Indicates Dynamic rate control mode Change Support.
0 : Dynamic rate control mode change not supported.
1 : Dynamic rate control mode change supported.

NV_ENC_CAPS_SUPPORT_SUBFRAME_READBACK

Indicates Subframe readback support for slice-based encoding.
0 : Subframe readback not supported.
1 : Subframe readback supported.

NV_ENC_CAPS_SUPPORT_CONSTRAINED_ENCODING

Indicates Constrained Encoding mode support. Support added from NvEncodeAPI version 2.0.
0 : Constrained encoding mode not supported.
1 : Constarined encoding mode supported. If this mode is supported client can enable this during initialisation. Client can then force a picture to be coded as constrained picture where each slice in a constrained picture will have constrained_intra_pred_flag set to 1 and disable_deblocking_filter_idc will be set to 2 and prediction vectors for inter macroblocks in each slice will be restricted to the slice region.

NV_ENC_CAPS_SUPPORT_INTRA_REFRESH

Indicates Intra Refresh Mode Support. Support added from NvEncodeAPI version 2.0.
0 : Intra Refresh Mode not supported.
1 : Intra Refresh Mode supported.

NV_ENC_CAPS_SUPPORT_CUSTOM_VBV_BUF_SIZE

Indicates Custom VBV Bufer Size support. It can be used for capping frame size. Support added from NvEncodeAPI version 2.0.
0 : Custom VBV buffer size specification from client, not supported.
1 : Custom VBV buffer size specification from client, supported.

NV_ENC_CAPS_SUPPORT_DYNAMIC_SLICE_MODE

Indicates Dynamic Slice Mode Support. Support added from NvEncodeAPI version 2.0.
0 : Dynamic Slice Mode not supported.
1 : Dynamic Slice Mode supported.

NV_ENC_CAPS_SUPPORT_REF_PIC_INVALIDATION

Indicates Reference Picture Invalidation Support. Support added from NvEncodeAPI version 2.0.
0 : Reference Picture Invalidation not supported.
1 : Reference Picture Invalidation supported.

NV_ENC_CAPS_PREPROC_SUPPORT

Indicates support for PreProcessing. The API return value is a bitmask of the values defined in ::NV_ENC_PREPROC_FLAGS

NV_ENC_CAPS_ASYNC_ENCODE_SUPPORT

Indicates support Async mode.
0 : Async Encode mode not supported.
1 : Async Encode mode supported.

NV_ENC_CAPS_MB_NUM_MAX

Maximum MBs per frame supported.

NV_ENC_CAPS_MB_PER_SEC_MAX

Maximum aggregate throughput in MBs per sec.

NV_ENC_CAPS_SUPPORT_YUV444_ENCODE

Indicates HW support for YUV444 mode encoding.
0 : YUV444 mode encoding not supported.
1 : YUV444 mode encoding supported.

NV_ENC_CAPS_SUPPORT_LOSSLESS_ENCODE

Indicates HW support for lossless encoding.
0 : lossless encoding not supported.
1 : lossless encoding supported.

NV_ENC_CAPS_EXPOSED_COUNT

Reserved - Not to be used by clients.


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
enum _NV_ENC_DEVICE_TYPE

Encoder Device type

Enumerator:
NV_ENC_DEVICE_TYPE_DIRECTX

encode device type is a directx9 device

NV_ENC_DEVICE_TYPE_CUDA

encode device type is a cuda device


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
enum _NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE

H.264 specific Adaptive Transform modes

Enumerator:
NV_ENC_H264_ADAPTIVE_TRANSFORM_AUTOSELECT

Adaptive Transform 8x8 mode is auto selected by the encoder driver

NV_ENC_H264_ADAPTIVE_TRANSFORM_DISABLE

Adaptive Transform 8x8 mode disabled

NV_ENC_H264_ADAPTIVE_TRANSFORM_ENABLE

Adaptive Transform 8x8 mode should be used


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
enum _NV_ENC_H264_BDIRECT_MODE

H.264 specific Bdirect modes

Enumerator:
NV_ENC_H264_BDIRECT_MODE_AUTOSELECT

BDirect mode is auto selected by the encoder driver

NV_ENC_H264_BDIRECT_MODE_DISABLE

Disable BDirect mode

NV_ENC_H264_BDIRECT_MODE_TEMPORAL

Temporal BDirect mode

NV_ENC_H264_BDIRECT_MODE_SPATIAL

Spatial BDirect mode


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
enum _NV_ENC_H264_ENTROPY_CODING_MODE

H.264 entropy coding modes.

Enumerator:
NV_ENC_H264_ENTROPY_CODING_MODE_AUTOSELECT

Entropy coding mode is auto selected by the encoder driver

NV_ENC_H264_ENTROPY_CODING_MODE_CABAC

Entropy coding mode is CABAC

NV_ENC_H264_ENTROPY_CODING_MODE_CAVLC

Entropy coding mode is CAVLC


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
enum _NV_ENC_H264_FMO_MODE

H.264 specific FMO usage

Enumerator:
NV_ENC_H264_FMO_AUTOSELECT

FMO usage is auto selected by the encoder driver

NV_ENC_H264_FMO_ENABLE

Enable FMO

NV_ENC_H264_FMO_DISABLE

Disble FMO


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
enum _NV_ENC_HEVC_CUSIZE

HEVC CU SIZE


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
enum _NV_ENC_INPUT_RESOURCE_TYPE

Input Resource type

Enumerator:
NV_ENC_INPUT_RESOURCE_TYPE_DIRECTX

input resource type is a directx9 surface

NV_ENC_INPUT_RESOURCE_TYPE_CUDADEVICEPTR

input resource type is a cuda device pointer surface

NV_ENC_INPUT_RESOURCE_TYPE_CUDAARRAY

input resource type is a cuda array surface


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
enum _NV_ENC_LEVEL

Encoding levels


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
enum _NV_ENC_MEMORY_HEAP

Memory heap to allocate input and output buffers.

Enumerator:
NV_ENC_MEMORY_HEAP_AUTOSELECT

Memory heap to be decided by the encoder driver based on the usage

NV_ENC_MEMORY_HEAP_VID

Memory heap is in local video memory

NV_ENC_MEMORY_HEAP_SYSMEM_CACHED

Memory heap is in cached system memory

NV_ENC_MEMORY_HEAP_SYSMEM_UNCACHED

Memory heap is in uncached system memory


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
enum _NV_ENC_MV_PRECISION

Motion vector precisions

Enumerator:
NV_ENC_MV_PRECISION_DEFAULT

Driver selects QuarterPel motion vector precision by default

NV_ENC_MV_PRECISION_FULL_PEL

FullPel motion vector precision

NV_ENC_MV_PRECISION_HALF_PEL

HalfPel motion vector precision

NV_ENC_MV_PRECISION_QUARTER_PEL

QuarterPel motion vector precision


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
enum _NV_ENC_PARAMS_FRAME_FIELD_MODE

Input frame encode modes

Enumerator:
NV_ENC_PARAMS_FRAME_FIELD_MODE_FRAME

Frame mode

NV_ENC_PARAMS_FRAME_FIELD_MODE_FIELD

Field mode

NV_ENC_PARAMS_FRAME_FIELD_MODE_MBAFF

MB adaptive frame/field


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
enum _NV_ENC_PARAMS_RC_MODE

Rate Control Modes

Enumerator:
NV_ENC_PARAMS_RC_CONSTQP

Constant QP mode

NV_ENC_PARAMS_RC_VBR

Variable bitrate mode

NV_ENC_PARAMS_RC_CBR

Constant bitrate mode

NV_ENC_PARAMS_RC_VBR_MINQP

Variable bitrate mode with MinQP

NV_ENC_PARAMS_RC_2_PASS_QUALITY

Multi pass encoding optimized for image quality and works only with low latency mode

NV_ENC_PARAMS_RC_2_PASS_FRAMESIZE_CAP

Multi pass encoding optimized for maintaining frame size and works only with low latency mode

NV_ENC_PARAMS_RC_2_PASS_VBR

Multi pass VBR


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
enum _NV_ENC_PIC_FLAGS

Encode Picture encode flags.

Enumerator:
NV_ENC_PIC_FLAG_FORCEINTRA

Encode the current picture as an Intra picture

NV_ENC_PIC_FLAG_FORCEIDR

Encode the current picture as an IDR picture. This flag is only valid when Picture type decision is taken by the Encoder [_NV_ENC_INITIALIZE_PARAMS::enablePTD == 1].

NV_ENC_PIC_FLAG_OUTPUT_SPSPPS

Write the sequence and picture header in encoded bitstream of the current picture

NV_ENC_PIC_FLAG_EOS

Indicates end of the input stream


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
enum _NV_ENC_PIC_STRUCT

Input picture structure

Enumerator:
NV_ENC_PIC_STRUCT_FRAME

Progressive frame

NV_ENC_PIC_STRUCT_FIELD_TOP_BOTTOM

Field encoding top field first

NV_ENC_PIC_STRUCT_FIELD_BOTTOM_TOP

Field encoding bottom field first


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
enum _NV_ENC_PIC_TYPE

Input picture type

Enumerator:
NV_ENC_PIC_TYPE_P

Forward predicted

NV_ENC_PIC_TYPE_B

Bi-directionally predicted picture

NV_ENC_PIC_TYPE_I

Intra predicted picture

NV_ENC_PIC_TYPE_IDR

IDR picture

NV_ENC_PIC_TYPE_BI

Bi-directionally predicted with only Intra MBs

NV_ENC_PIC_TYPE_SKIPPED

Picture is skipped

NV_ENC_PIC_TYPE_INTRA_REFRESH

First picture in intra refresh cycle

NV_ENC_PIC_TYPE_UNKNOWN

Picture type unknown


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
enum _NV_ENC_STEREO_PACKING_MODE

Stereo frame packing modes.

Enumerator:
NV_ENC_STEREO_PACKING_MODE_NONE

No Stereo packing required

NV_ENC_STEREO_PACKING_MODE_CHECKERBOARD

Checkerboard mode for packing stereo frames

NV_ENC_STEREO_PACKING_MODE_COLINTERLEAVE

Column Interleave mode for packing stereo frames

NV_ENC_STEREO_PACKING_MODE_ROWINTERLEAVE

Row Interleave mode for packing stereo frames

NV_ENC_STEREO_PACKING_MODE_SIDEBYSIDE

Side-by-side mode for packing stereo frames

NV_ENC_STEREO_PACKING_MODE_TOPBOTTOM

Top-Bottom mode for packing stereo frames

NV_ENC_STEREO_PACKING_MODE_FRAMESEQ

Frame Sequential mode for packing stereo frames


  • NvEncodeAPI Data structures
_NV_ENC_BUFFER_FORMAT
_NV_ENC_CAPS
_NV_ENC_DEVICE_TYPE
_NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
_NV_ENC_H264_BDIRECT_MODE
_NV_ENC_H264_ENTROPY_CODING_MODE
_NV_ENC_H264_FMO_MODE
_NV_ENC_HEVC_CUSIZE
_NV_ENC_INPUT_RESOURCE_TYPE
_NV_ENC_LEVEL
_NV_ENC_MEMORY_HEAP
_NV_ENC_MV_PRECISION
_NV_ENC_PARAMS_FRAME_FIELD_MODE
_NV_ENC_PARAMS_RC_MODE
_NV_ENC_PIC_FLAGS
_NV_ENC_PIC_STRUCT
_NV_ENC_PIC_TYPE
_NV_ENC_STEREO_PACKING_MODE
_NVENCSTATUS
NV_ENC_BUFFER_FORMAT
NV_ENC_CAPS
NV_ENC_CAPS_PARAM
NV_ENC_CAPS_PARAM_VER
NV_ENC_CODEC_PIC_PARAMS
NV_ENC_CONFIG_VER
NV_ENC_CREATE_BITSTREAM_BUFFER
NV_ENC_CREATE_BITSTREAM_BUFFER_VER
NV_ENC_CREATE_INPUT_BUFFER
NV_ENC_CREATE_INPUT_BUFFER_VER
NV_ENC_DEVICE_TYPE
NV_ENC_EVENT_PARAMS
NV_ENC_EVENT_PARAMS_VER
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE
NV_ENC_H264_BDIRECT_MODE
NV_ENC_H264_ENTROPY_CODING_MODE
NV_ENC_H264_FMO_MODE
NV_ENC_HEVC_CUSIZE
NV_ENC_INITIALIZE_PARAMS_VER
NV_ENC_INPUT_RESOURCE_TYPE
NV_ENC_LEVEL
NV_ENC_LOCK_BITSTREAM_VER
NV_ENC_LOCK_INPUT_BUFFER_VER
NV_ENC_MAP_INPUT_RESOURCE_VER
NV_ENC_MEMORY_HEAP
NV_ENC_MV_PRECISION
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS
NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER
NV_ENC_PARAMS_FRAME_FIELD_MODE
NV_ENC_PARAMS_RC_CBR2
NV_ENC_PARAMS_RC_MODE
NV_ENC_PIC_FLAGS
NV_ENC_PIC_PARAMS_VER
NV_ENC_PIC_STRUCT
NV_ENC_PIC_TYPE
NV_ENC_PRESET_CONFIG_VER
NV_ENC_QP
NV_ENC_RC_PARAMS
NV_ENC_RC_PARAMS_VER
NV_ENC_RECONFIGURE_PARAMS_VER
NV_ENC_REGISTER_RESOURCE_VER
NV_ENC_SEQUENCE_PARAM_PAYLOAD_VER
NV_ENC_STAT_VER
NV_ENC_STEREO_PACKING_MODE
NV_ENCODE_API_FUNCTION_LIST
NVENCSTATUS
enum _NVENCSTATUS

Error Codes

Enumerator:
NV_ENC_SUCCESS

This indicates that API call returned with no errors.

NV_ENC_ERR_NO_ENCODE_DEVICE

This indicates that no encode capable devices were detected.

NV_ENC_ERR_UNSUPPORTED_DEVICE

This indicates that devices pass by the client is not supported.

NV_ENC_ERR_INVALID_ENCODERDEVICE

This indicates that the encoder device supplied by the client is not valid.

NV_ENC_ERR_INVALID_DEVICE

This indicates that device passed to the API call is invalid.

NV_ENC_ERR_DEVICE_NOT_EXIST

This indicates that device passed to the API call is no longer available and needs to be reinitialized. The clients need to destroy the current encoder session by freeing the allocated input output buffers and destroying the device and create a new encoding session.

NV_ENC_ERR_INVALID_PTR

This indicates that one or more of the pointers passed to the API call is invalid.

NV_ENC_ERR_INVALID_EVENT

This indicates that completion event passed in NvEncEncodePicture() call is invalid.

NV_ENC_ERR_INVALID_PARAM

This indicates that one or more of the parameter passed to the API call is invalid.

NV_ENC_ERR_INVALID_CALL

This indicates that an API call was made in wrong sequence/order.

NV_ENC_ERR_OUT_OF_MEMORY

This indicates that the API call failed because it was unable to allocate enough memory to perform the requested operation.

NV_ENC_ERR_ENCODER_NOT_INITIALIZED

This indicates that the encoder has not been initialized with NvEncInitializeEncoder() or that initialization has failed. The client cannot allocate input or output buffers or do any encoding related operation before successfully initializing the encoder.

NV_ENC_ERR_UNSUPPORTED_PARAM

This indicates that an unsupported parameter was passed by the client.

NV_ENC_ERR_LOCK_BUSY

This indicates that the NvEncLockBitstream() failed to lock the output buffer. This happens when the client makes a non blocking lock call to access the output bitstream by passing NV_ENC_LOCK_BITSTREAM::doNotWait flag. This is not a fatal error and client should retry the same operation after few milliseconds.

NV_ENC_ERR_NOT_ENOUGH_BUFFER

This indicates that the size of the user buffer passed by the client is insufficient for the requested operation.

NV_ENC_ERR_INVALID_VERSION

This indicates that an invalid struct version was used by the client.

NV_ENC_ERR_MAP_FAILED

This indicates that NvEncMapInputResource() API failed to map the client provided input resource.

NV_ENC_ERR_NEED_MORE_INPUT

This indicates encode driver requires more input buffers to produce an output bitstream. If this error is returned from NvEncEncodePicture() API, this is not a fatal error. If the client is encoding with B frames then, NvEncEncodePicture() API might be buffering the input frame for re-ordering.

A client operating in synchronous mode cannot call NvEncLockBitstream() API on the output bitstream buffer if NvEncEncodePicture() returned the NV_ENC_ERR_NEED_MORE_INPUT error code. The client must continue providing input frames until encode driver returns NV_ENC_SUCCESS. After receiving NV_ENC_SUCCESS status the client can call NvEncLockBitstream() API on the output buffers in the same order in which it has called NvEncEncodePicture().

NV_ENC_ERR_ENCODER_BUSY

This indicates that the HW encoder is busy encoding and is unable to encode the input. The client should call NvEncEncodePicture() again after few milliseconds.

NV_ENC_ERR_EVENT_NOT_REGISTERD

This indicates that the completion event passed in NvEncEncodePicture() API has not been registered with encoder driver using NvEncRegisterAsyncEvent().

NV_ENC_ERR_GENERIC

This indicates that an unknown internal error has occurred.

NV_ENC_ERR_INCOMPATIBLE_CLIENT_KEY

This indicates that the client is attempting to use a feature that is not available for the license type for the current system.

NV_ENC_ERR_UNIMPLEMENTED

This indicates that the client is attempting to use a feature that is not implemented for the current version.

NV_ENC_ERR_RESOURCE_REGISTER_FAILED

This indicates that the NvEncRegisterResource API failed to register the resource.

NV_ENC_ERR_RESOURCE_NOT_REGISTERED

This indicates that the client is attempting to unregister a resource that has not been successfuly registered.

NV_ENC_ERR_RESOURCE_NOT_MAPPED

This indicates that the client is attempting to unmap a resource that has not been successfuly mapped.


Functions
NvEncodeAPI Functions

Functions

NVENCSTATUS NVENCAPI | NvEncCreateBitstreamBuffer (void *encoder, NV_ENC_CREATE_BITSTREAM_BUFFER *createBitstreamBufferParams)
Allocates an output bitstream buffer.
NVENCSTATUS NVENCAPI | NvEncCreateInputBuffer (void *encoder, NV_ENC_CREATE_INPUT_BUFFER *createInputBufferParams)
Allocates Input buffer.
NVENCSTATUS NVENCAPI | NvEncDestroyBitstreamBuffer (void *encoder, NV_ENC_OUTPUT_PTR bitstreamBuffer)
Release a bitstream buffer.
NVENCSTATUS NVENCAPI | NvEncDestroyEncoder (void *encoder)
Destroy Encoding Session.
NVENCSTATUS NVENCAPI | NvEncDestroyInputBuffer (void *encoder, NV_ENC_INPUT_PTR inputBuffer)
Release an input buffers.
NVENCSTATUS NVENCAPI | NvEncEncodePicture (void *encoder, NV_ENC_PIC_PARAMS *encodePicParams)
Submit an input picture for encoding.
NVENCSTATUS NVENCAPI | NvEncGetEncodeCaps (void *encoder, GUID encodeGUID, NV_ENC_CAPS_PARAM *capsParam, int *capsVal)
Retrieves the capability value for a specified encoder attribute.
NVENCSTATUS NVENCAPI | NvEncGetEncodeGUIDCount (void *encoder, uint32_t *encodeGUIDCount)
Retrieves the number of supported encode GUIDs.
NVENCSTATUS NVENCAPI | NvEncGetEncodeGUIDs (void *encoder, GUID *GUIDs, uint32_t guidArraySize, uint32_t *GUIDCount)
Retrieves an array of supported encoder codec GUIDs.
NVENCSTATUS NVENCAPI | NvEncGetEncodePresetConfig (void *encoder, GUID encodeGUID, GUID presetGUID, NV_ENC_PRESET_CONFIG *presetConfig)
Returns a preset config structure supported for given preset GUID.
NVENCSTATUS NVENCAPI | NvEncGetEncodePresetCount (void *encoder, GUID encodeGUID, uint32_t *encodePresetGUIDCount)
Retrieves the number of supported preset GUIDs.
NVENCSTATUS NVENCAPI | NvEncGetEncodePresetGUIDs (void *encoder, GUID encodeGUID, GUID *presetGUIDs, uint32_t guidArraySize, uint32_t *encodePresetGUIDCount)
Receives an array of supported encoder preset GUIDs.
NVENCSTATUS NVENCAPI | NvEncGetEncodeProfileGUIDCount (void *encoder, GUID encodeGUID, uint32_t *encodeProfileGUIDCount)
Retrieves the number of supported profile GUIDs.
NVENCSTATUS NVENCAPI | NvEncGetEncodeProfileGUIDs (void *encoder, GUID encodeGUID, GUID *profileGUIDs, uint32_t guidArraySize, uint32_t *GUIDCount)
Retrieves an array of supported encode profile GUIDs.
NVENCSTATUS NVENCAPI | NvEncGetEncodeStats (void *encoder, NV_ENC_STAT *encodeStats)
Get encoding statistics.
NVENCSTATUS NVENCAPI | NvEncGetInputFormatCount (void *encoder, GUID encodeGUID, uint32_t *inputFmtCount)
Retrieve the number of supported Input formats.
NVENCSTATUS NVENCAPI | NvEncGetInputFormats (void *encoder, GUID encodeGUID, NV_ENC_BUFFER_FORMAT *inputFmts, uint32_t inputFmtArraySize, uint32_t *inputFmtCount)
Retrieves an array of supported Input formats.
NVENCSTATUS NVENCAPI | NvEncGetSequenceParams (void *encoder, NV_ENC_SEQUENCE_PARAM_PAYLOAD *sequenceParamPayload)
Get encoded sequence and picture header.
NVENCSTATUS NVENCAPI | NvEncInitializeEncoder (void *encoder, NV_ENC_INITIALIZE_PARAMS *createEncodeParams)
Initialize the encoder.
NVENCSTATUS NVENCAPI | NvEncInvalidateRefFrames (void *encoder, uint64_t invalidRefFrameTimeStamp)
Invalidate reference frames.
NVENCSTATUS NVENCAPI | NvEncLockBitstream (void *encoder, NV_ENC_LOCK_BITSTREAM *lockBitstreamBufferParams)
Lock output bitstream buffer.
NVENCSTATUS NVENCAPI | NvEncLockInputBuffer (void *encoder, NV_ENC_LOCK_INPUT_BUFFER *lockInputBufferParams)
Locks an input buffer.
NVENCSTATUS NVENCAPI | NvEncMapInputResource (void *encoder, NV_ENC_MAP_INPUT_RESOURCE *mapInputResParams)
Map an externally created input resource pointer for encoding.
NVENCSTATUS NVENCAPI | NvEncodeAPICreateInstance (NV_ENCODE_API_FUNCTION_LIST *functionList)
NVENCSTATUS NVENCAPI | NvEncOpenEncodeSession (void *device, uint32_t deviceType, void **encoder)
Opens an encoding session.
NVENCSTATUS NVENCAPI | NvEncOpenEncodeSessionEx (NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS *openSessionExParams, void **encoder)
Opens an encoding session.
NVENCSTATUS NVENCAPI | NvEncReconfigureEncoder (void *encoder, NV_ENC_RECONFIGURE_PARAMS *reInitEncodeParams)
Reconfigure an existing encoding session.
NVENCSTATUS NVENCAPI | NvEncRegisterAsyncEvent (void *encoder, NV_ENC_EVENT_PARAMS *eventParams)
Register event for notification to encoding completion.
NVENCSTATUS NVENCAPI | NvEncRegisterResource (void *encoder, NV_ENC_REGISTER_RESOURCE *registerResParams)
Registers a resource with the Nvidia Video Encoder Interface.
NVENCSTATUS NVENCAPI | NvEncUnlockBitstream (void *encoder, NV_ENC_OUTPUT_PTR bitstreamBuffer)
Unlock the output bitstream buffer.
NVENCSTATUS NVENCAPI | NvEncUnlockInputBuffer (void *encoder, NV_ENC_INPUT_PTR inputBuffer)
Unlocks the input buffer.
NVENCSTATUS NVENCAPI | NvEncUnmapInputResource (void *encoder, NV_ENC_INPUT_PTR mappedInputBuffer)
UnMaps a NV_ENC_INPUT_PTR which was mapped for encoding.
NVENCSTATUS NVENCAPI | NvEncUnregisterAsyncEvent (void *encoder, NV_ENC_EVENT_PARAMS *eventParams)
Unregister completion event.
NVENCSTATUS NVENCAPI | NvEncUnregisterResource (void *encoder, NV_ENC_REGISTERED_PTR registeredResource)
Unregisters a resource previously registered with the Nvidia Video Encoder Interface.


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncCreateBitstreamBuffer | ( | void * | encoder,
 |  | NV_ENC_CREATE_BITSTREAM_BUFFER * | createBitstreamBufferParams
 | ) |  |

Allocates an output bitstream buffer.

This function is used to allocate an output bitstream buffer and returns a NV_ENC_OUTPUT_PTR to bitstream buffer to the client in the NV_ENC_CREATE_BITSTREAM_BUFFER::bitstreamBuffer field. The client can only call this function after the encoder session has been initialized using NvEncInitializeEncoder() API. The minimum number of output buffers allocated by the client must be at least 4 more than the number of B B frames being used for encoding. The client can only access the output bitsteam data by locking the bitstreamBuffer using the NvEncLockBitstream() function.

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in,out] | createBitstreamBufferParams | Pointer NV_ENC_CREATE_BITSTREAM_BUFFER for details.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_INVALID_VERSION
NV_ENC_ERR_ENCODER_NOT_INITIALIZED
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncCreateInputBuffer | ( | void * | encoder,
 |  | NV_ENC_CREATE_INPUT_BUFFER * | createInputBufferParams
 | ) |  |

Allocates Input buffer.

This function is used to allocate an input buffer. The client must enumerate the input buffer format before allocating the input buffer resources. The NV_ENC_INPUT_PTR returned by the NvEncodeAPI interface in the NV_ENC_CREATE_INPUT_BUFFER::inputBuffer field can be directly used in NvEncEncodePicture() API. The number of input buffers to be allocated by the client must be at least 4 more than the number of B frames being used for encoding.

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in,out] | createInputBufferParams | Pointer to the NV_ENC_CREATE_INPUT_BUFFER structure.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_INVALID_VERSION
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncDestroyBitstreamBuffer | ( | void * | encoder,
 |  | NV_ENC_OUTPUT_PTR | bitstreamBuffer
 | ) |  |

Release a bitstream buffer.

This function is used to release the output bitstream buffer allocated using the NvEncCreateBitstreamBuffer() function. The client must release the output bitstreamBuffer using this function before destroying the encoder session.

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in] | bitstreamBuffer | Pointer to the bitstream buffer being released.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_INVALID_VERSION
NV_ENC_ERR_ENCODER_NOT_INITIALIZED
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncDestroyEncoder ( void * encoder )

Destroy Encoding Session.

Destroys the encoder session previously created using NvEncOpenEncodeSession() function. The client must flush the encoder before freeing any resources. In order to flush the encoder the client must pass a NULL encode picture packet and either wait for the NvEncEncodePicture() function to return in synchronous mode or wait for the flush event to be signaled by the encoder in asynchronous mode. The client must free all the input and output resources created using the NvEncodeAPI interface before destroying the encoder. If the client is operating in asynchronous mode, it must also unregister the completion events previously registered.

Parameters:
[in] encoder Pointer to the NvEncodeAPI interface.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncDestroyInputBuffer | ( | void * | encoder,
 |  | NV_ENC_INPUT_PTR | inputBuffer
 | ) |  |

Release an input buffers.

This function is used to free an input buffer. If the client has allocated any input buffer using NvEncCreateInputBuffer() API, it must free those input buffers by calling this function. The client must release the input buffers before destroying the encoder using NvEncDestroyEncoder() API.

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in] | inputBuffer | Pointer to the input buffer to be released.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_INVALID_VERSION
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncEncodePicture | ( | void * | encoder,
 |  | NV_ENC_PIC_PARAMS * | encodePicParams
 | ) |  |

Submit an input picture for encoding.

This function is used to submit an input picture buffer for encoding. The encoding parameters are passed using *encodePicParams which is a pointer to the _NV_ENC_PIC_PARAMS structure.

If the client has set NV_ENC_INITIALIZE_PARAMS::enablePTD to 0, then it must send a valid value for the following fields.

  • NV_ENC_PIC_PARAMS::pictureType
  • NV_ENC_PIC_PARAMS_H264::displayPOCSyntax (H264 only)
  • NV_ENC_PIC_PARAMS_H264::frameNumSyntax(H264 only)
  • NV_ENC_PIC_PARAMS_H264::refPicFlag(H264 only)
Asynchronous Encoding
If the client has enabled asynchronous mode of encoding by setting NV_ENC_INITIALIZE_PARAMS::enableEncodeAsync to 1 in the NvEncInitializeEncoder() API ,then the client must send a valid NV_ENC_PIC_PARAMS::completionEvent. Incase of asynchronous mode of operation, client can queue the NvEncEncodePicture() API commands from the main thread and then queue output buffers to be processed to a secondary worker thread. Before the locking the output buffers in the secondary thread , the client must wait on NV_ENC_PIC_PARAMS::completionEvent it has queued in NvEncEncodePicture() API call. The client must always process completion event and the output buffer in the same order in which they have been submitted for encoding. The NvEncodeAPI interface is responsible for any re-ordering required for B frames and will always ensure that encoded bitstream data is written in the same order in which output buffer is submitted.
  The below example shows how  asynchronous encoding in case of 1 B frames
  ------------------------------------------------------------------------
  Suppose the client allocated 4 input buffers(I1,I2..), 4 output buffers(O1,O2..)
  and 4 completion events(E1, E2, ...). The NvEncodeAPI interface will need to
  keep a copy of the input buffers for re-ordering and it allocates following
  internal buffers (NvI1, NvI2...). These internal buffers are managed by NvEncodeAPI
  and the client is not responsible for the allocating or freeing the memory of
  the internal buffers.

  a) The client main thread will queue the following encode frame calls.
  Note the picture type is unknown to the client, the decision is being taken by
  NvEncodeAPI interface. The client should pass ::_NV_ENC_PIC_PARAMS parameter
  consisting of allocated input buffer, output buffer and output events in successive
  ::NvEncEncodePicture() API calls along with other required encode picture params.
  For example:
  1st EncodePicture parameters - (I1, O1, E1)
  2nd EncodePicture parameters - (I2, O2, E2)
  3rd EncodePicture parameters - (I3, O3, E3)

  b) NvEncodeAPI SW will receive the following encode Commands from the client.
  The left side shows input from client in the form (Input buffer, Output Buffer,
  Output Event). The right hand side shows a possible picture type decision take by
  the NvEncodeAPI interface.
  (I1, O1, E1)    ---P1 Frame
  (I2, O2, E2)    ---B2 Frame
  (I3, O3, E3)    ---P3 Frame

  c) NvEncodeAPI interface will make a copy of the input buffers to its internal
   buffersfor re-ordering. These copies are done as part of nvEncEncodePicture
   function call from the client and NvEncodeAPI interface is responsible for
   synchronization of copy operation with the actual encoding operation.
   I1 --> NvI1
   I2 --> NvI2
   I3 --> NvI3

  d) After returning from ::NvEncEncodePicture() call , the client must queue the output
   bitstream  processing work to the secondary thread. The output bitstream processing
   for asynchronous mode consist of first waiting on completion event(E1, E2..)
   and then locking the output bitstream buffer(O1, O2..) for reading the encoded
   data. The work queued to the secondary thread by the client is in the following order
   (I1, O1, E1)
   (I2, O2, E2)
   (I3, O3, E3)
   Note they are in the same order in which client calls ::NvEncEncodePicture() API
   in \p step a).

  e) NvEncodeAPI interface  will do the re-ordering such that Encoder HW will receive
  the following encode commands:
  (NvI1, O1, E1)   ---P1 Frame
  (NvI3, O2, E2)   ---P3 Frame
  (NvI2, O3, E3)   ---B2 frame

  f) After the encoding operations are completed, the events will be signalled
  by NvEncodeAPI interface in the following order :
  (O1, E1) ---P1 Frame ,output bitstream copied to O1 and event E1 signalled.
  (O2, E2) ---P3 Frame ,output bitstream copied to O2 and event E2 signalled.
  (O3, E3) ---B2 Frame ,output bitstream copied to O3 and event E3 signalled.

  g) The client must lock the bitstream data using ::NvEncLockBitstream() API in
   the order O1,O2,O3  to read the encoded data, after waiting for the events
   to be signalled in the same order i.e E1, E2 and E3.The output processing is
   done in the secondary thread in the following order:
   Waits on E1, copies encoded bitstream from O1
   Waits on E2, copies encoded bitstream from O2
   Waits on E3, copies encoded bitstream from O3

  -Note the client will receive the events signalling and output buffer in the
   same order in which they have submitted for encoding.
  -Note the LockBitstream will have picture type field which will notify the
   output picture type to the clients.
  -Note the input, output buffer and the output completion eventare free to be
   reused once NvEncodeAPI interfaced has signalled the event and the client has
   copied the data from the output buffer.
Synchronous Encoding
The client can enable synchronous mode of encoding by setting NV_ENC_INITIALIZE_PARAMS::enableEncodeAsync to 0 in NvEncInitializeEncoder() API. The NvEncodeAPI interface may return NV_ENC_ERR_NEED_MORE_INPUT error code for some NvEncEncodePicture() API calls when NV_ENC_INITIALIZE_PARAMS::enablePTD is set to 1, but the client must not treat it as a fatal error. The NvEncodeAPI interface might not be able to submit an input picture buffer for encoding immediately due to re-ordering for B frames. The NvEncodeAPI interface cannot submit the input picture which is decided to be encoded as B frame as it waits for backward reference from temporally subsequent frames. This input picture is buffered internally and waits for more input picture to arrive. The client must not call NvEncLockBitstream() API on the output buffers whose NvEncEncodePicture() API returns NV_ENC_ERR_NEED_MORE_INPUT. The client must wait for the NvEncodeAPI interface to return NV_ENC_SUCCESS before locking the output bitstreams to read the encoded bitstream data. The following example explains the scenario with synchronous encoding with 2 B frames.
 The below example shows how  synchronous encoding works in case of 1 B frames
 -----------------------------------------------------------------------------
 Suppose the client allocated 4 input buffers(I1,I2..), 4 output buffers(O1,O2..)
 and 4 completion events(E1, E2, ...). The NvEncodeAPI interface will need to
 keep a copy of the input buffers for re-ordering and it allocates following
 internal buffers (NvI1, NvI2...). These internal buffers are managed by NvEncodeAPI
 and the client is not responsible for the allocating or freeing the memory of
 the internal buffers.

 The client calls ::NvEncEncodePicture() API with input buffer I1 and output buffer O1.
 The NvEncodeAPI decides to encode I1 as P frame and submits it to encoder
 HW and returns ::NV_ENC_SUCCESS.
 The client can now read the encoded data by locking the output O1 by calling
 NvEncLockBitstream API.

 The client calls ::NvEncEncodePicture() API with input buffer I2 and output buffer O2.
 The NvEncodeAPI decides to encode I2 as B frame and buffers I2 by copying it
 to internal buffer and returns ::NV_ENC_ERR_NEED_MORE_INPUT.
 The error is not fatal and it notifies client that it cannot read the encoded
 data by locking the output O2 by calling ::NvEncLockBitstream() API without submitting
 more work to the NvEncodeAPI interface.

 The client calls ::NvEncEncodePicture() with input buffer I3 and output buffer O3.
 The NvEncodeAPI decides to encode I3 as P frame and it first submits I3 for
 encoding which will be used as backward reference frame for I2.
 The NvEncodeAPI then submits I2 for encoding and returns ::NV_ENC_SUCESS. Both
 the submission are part of the same ::NvEncEncodePicture() function call.
 The client can now read the encoded data for both the frames by locking the output
 O2 followed by  O3 ,by calling ::NvEncLockBitstream() API.

 The client must always lock the output in the same order in which it has submitted
 to receive the encoded bitstream in correct encoding order.
Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in,out] | encodePicParams | Pointer to the _NV_ENC_PIC_PARAMS structure.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_INVALID_VERSION
NV_ENC_ERR_ENCODER_BUSY
NV_ENC_ERR_NEED_MORE_INPUT
NV_ENC_ERR_ENCODER_NOT_INITIALIZED
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncGetEncodeCaps | ( | void * | encoder,
 |  | GUID | encodeGUID,
 |  | NV_ENC_CAPS_PARAM * | capsParam,
 |  | int * | capsVal
 | ) |  |

Retrieves the capability value for a specified encoder attribute.

The function returns the capability value for a given encoder attribute. The client must validate the encodeGUID using NvEncGetEncodeGUIDs() API before calling this function. The encoder attribute being querried are enumerated in NV_ENC_CAPS_PARAM enum.

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in] | encodeGUID | Encode GUID, corresponding to which the capability attribute is to be retrieved.
[in] | capsParam | Used to specify attribute being queried. Refer NV_ENC_CAPS_PARAM for more details.
[out] | capsVal | The value corresponding to the capability attribute being queried.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncGetEncodeGUIDCount | ( | void * | encoder,
 |  | uint32_t * | encodeGUIDCount
 | ) |  |

Retrieves the number of supported encode GUIDs.

The function returns the number of codec guids supported by the NvEncodeAPI interface.

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[out] | encodeGUIDCount | Number of supported encode GUIDs.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncGetEncodeGUIDs | ( | void * | encoder,
 |  | GUID * | GUIDs,
 |  | uint32_t | guidArraySize,
 |  | uint32_t * | GUIDCount
 | ) |  |

Retrieves an array of supported encoder codec GUIDs.

The function returns an array of codec guids supported by the NvEncodeAPI interface. The client must allocate an array where the NvEncodeAPI interface can fill the supported guids and pass the pointer in *GUIDs parameter. The size of the array can be determined by using NvEncGetEncodeGUIDCount() API. The Nvidia Encoding interface returns the number of codec guids it has actually filled in the guid array in the GUIDCount parameter.

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in] | guidArraySize | Number of GUIDs to retrieved. Should be set to the number retrieved using NvEncGetEncodeGUIDCount.
[out] | GUIDs | Array of supported Encode GUIDs.
[out] | GUIDCount | Number of supported Encode GUIDs.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncGetEncodePresetConfig | ( | void * | encoder,
 |  | GUID | encodeGUID,
 |  | GUID | presetGUID,
 |  | NV_ENC_PRESET_CONFIG * | presetConfig
 | ) |  |

Returns a preset config structure supported for given preset GUID.

The function returns a preset config structure for a given preset guid. Before using this function the client must enumerate the preset guids available for a given codec. The preset config structure can be modified by the client depending upon its use case and can be then used to initialize the encoder using NvEncInitializeEncoder() API. The client can use this function only if it wants to modify the NvEncodeAPI preset configuration, otherwise it can directly use the preset guid.

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in] | encodeGUID | Encode GUID, corresponding to which the list of supported presets is to be retrieved.
[in] | presetGUID | Preset GUID, corresponding to which the Encoding configurations is to be retrieved.
[out] | presetConfig | The requested Preset Encoder Attribute set. Refer _NV_ENC_CONFIG for more details.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_INVALID_VERSION
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncGetEncodePresetCount | ( | void * | encoder,
 |  | GUID | encodeGUID,
 |  | uint32_t * | encodePresetGUIDCount
 | ) |  |

Retrieves the number of supported preset GUIDs.

The function returns the number of preset GUIDs available for a given codec. The client must validate the codec guid using NvEncGetEncodeGUIDs() API before calling this function.

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in] | encodeGUID | Encode GUID, corresponding to which the number of supported presets is to be retrieved.
[out] | encodePresetGUIDCount | Receives the number of supported preset GUIDs.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncGetEncodePresetGUIDs | ( | void * | encoder,
 |  | GUID | encodeGUID,
 |  | GUID * | presetGUIDs,
 |  | uint32_t | guidArraySize,
 |  | uint32_t * | encodePresetGUIDCount
 | ) |  |

Receives an array of supported encoder preset GUIDs.

The function returns an array of encode preset guids available for a given codec. The client can directly use one of the preset guids based upon the use case or target device. The preset guid chosen can be directly used in NV_ENC_INITIALIZE_PARAMS::presetGUID parameter to NvEncEncodePicture() API. Alternately client can also use the preset guid to retrieve the encoding config parameters being used by NvEncodeAPI interface for that given preset, using NvEncGetEncodePresetConfig() API. It can then modify preset config parameters as per its use case and send it to NvEncodeAPI interface as part of NV_ENC_INITIALIZE_PARAMS::encodeConfig parameter for NvEncInitializeEncoder() API.

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in] | encodeGUID | Encode GUID, corresponding to which the list of supported presets is to be retrieved.
[in] | guidArraySize | Size of array of preset guids passed in preset GUIDs
[out] | presetGUIDs | Array of supported Encode preset GUIDs from the NvEncodeAPI interface to client.
[out] | encodePresetGUIDCount | Receives the number of preset GUIDs returned by the NvEncodeAPI interface.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncGetEncodeProfileGUIDCount | ( | void * | encoder,
 |  | GUID | encodeGUID,
 |  | uint32_t * | encodeProfileGUIDCount
 | ) |  |

Retrieves the number of supported profile GUIDs.

The function returns the number of profile GUIDs supported for a given codec. The client must first enumerate the codec guids supported by the NvEncodeAPI interface. After determining the codec guid, it can query the NvEncodeAPI interface to determine the number of profile guids supported for a particular codec guid.

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in] | encodeGUID | The codec guid for which the profile guids are being enumerated.
[out] | encodeProfileGUIDCount | Number of encode profiles supported for the given encodeGUID.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncGetEncodeProfileGUIDs | ( | void * | encoder,
 |  | GUID | encodeGUID,
 |  | GUID * | profileGUIDs,
 |  | uint32_t | guidArraySize,
 |  | uint32_t * | GUIDCount
 | ) |  |

Retrieves an array of supported encode profile GUIDs.

The function returns an array of supported profile guids for a particular codec guid. The client must allocate an array where the NvEncodeAPI interface can populate the profile guids. The client can determine the array size using NvEncGetEncodeProfileGUIDCount() API. The client must also validiate that the NvEncodeAPI interface supports the GUID the client wants to pass as encodeGUID parameter.

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in] | encodeGUID | The encode guid whose profile guids are being enumerated.
[in] | guidArraySize | Number of GUIDs to be retrieved. Should be set to the number retrieved using NvEncGetEncodeProfileGUIDCount.
[out] | profileGUIDs | Array of supported Encode Profile GUIDs
[out] | GUIDCount | Number of valid encode profile GUIDs in profileGUIDs array.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncGetEncodeStats | ( | void * | encoder,
 |  | NV_ENC_STAT * | encodeStats
 | ) |  |

Get encoding statistics.

This function is used to retrieve the encoding statistics. This API is not supported when encode device type is CUDA.

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in,out] | encodeStats | Pointer to the _NV_ENC_STAT structure.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_ENCODER_NOT_INITIALIZED
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncGetInputFormatCount | ( | void * | encoder,
 |  | GUID | encodeGUID,
 |  | uint32_t * | inputFmtCount
 | ) |  |

Retrieve the number of supported Input formats.

The function returns the number of supported input formats. The client must query the NvEncodeAPI interface to determine the supported input formats before creating the input surfaces.

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in] | encodeGUID | Encode GUID, corresponding to which the number of supported input formats is to be retrieved.
[out] | inputFmtCount | Number of input formats supported for specified Encode GUID.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncGetInputFormats | ( | void * | encoder,
 |  | GUID | encodeGUID,
 |  | NV_ENC_BUFFER_FORMAT * | inputFmts,
 |  | uint32_t | inputFmtArraySize,
 |  | uint32_t * | inputFmtCount
 | ) |  |

Retrieves an array of supported Input formats.

Returns an array of supported input formats The client must use the input format to create input surface using NvEncCreateInputBuffer() API.

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in] | encodeGUID | Encode GUID, corresponding to which the number of supported input formats is to be retrieved.
[in] | inputFmtArraySize | Size input format count array passed in inputFmts.
[out] | inputFmts | Array of input formats supported for this Encode GUID.
[out] | inputFmtCount | The number of valid input format types returned by the NvEncodeAPI interface in inputFmts array.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncGetSequenceParams | ( | void * | encoder,
 |  | NV_ENC_SEQUENCE_PARAM_PAYLOAD * | sequenceParamPayload
 | ) |  |

Get encoded sequence and picture header.

This function can be used to retrieve the sequence and picture header out of band. The client must call this function only after the encoder has been initialized using NvEncInitializeEncoder() function. The client must allocate the memory where the NvEncodeAPI interface can copy the bitstream header and pass the pointer to the memory in NV_ENC_SEQUENCE_PARAM_PAYLOAD::spsppsBuffer. The size of buffer is passed in the field NV_ENC_SEQUENCE_PARAM_PAYLOAD::inBufferSize. The NvEncodeAPI interface will copy the bitstream header payload and returns the actual size of the bitstream header in the field NV_ENC_SEQUENCE_PARAM_PAYLOAD::outSPSPPSPayloadSize. The client must call NvEncGetSequenceParams() function from the same thread which is being used to call NvEncEncodePicture() function.

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in,out] | sequenceParamPayload | Pointer to the _NV_ENC_SEQUENCE_PARAM_PAYLOAD structure.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_VERSION
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_ENCODER_NOT_INITIALIZED
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncInitializeEncoder | ( | void * | encoder,
 |  | NV_ENC_INITIALIZE_PARAMS * | createEncodeParams
 | ) |  |

Initialize the encoder.

This API must be used to initialize the encoder. The initialization parameter is passed using *createEncodeParams The client must send the following fields of the _NV_ENC_INITIALIZE_PARAMS structure with a valid value.

  • NV_ENC_INITIALIZE_PARAMS::encodeGUID
  • NV_ENC_INITIALIZE_PARAMS::encodeWidth
  • NV_ENC_INITIALIZE_PARAMS::encodeHeight

The client can pass a preset guid directly to the NvEncodeAPI interface using NV_ENC_INITIALIZE_PARAMS::presetGUID field. If the client doesn't pass NV_ENC_INITIALIZE_PARAMS::encodeConfig structure, the codec specific parameters will be selected based on the preset guid. The preset guid must have been validated by the client using NvEncGetEncodePresetGUIDs() API. If the client passes a custom _NV_ENC_CONFIG structure through NV_ENC_INITIALIZE_PARAMS::encodeConfig , it will override the codec specific parameters based on the preset guid. It is recommended that even if the client passes a custom config, it should also send a preset guid. In this case, the preset guid passed by the client will not override any of the custom config parameters programmed by the client, it is only used as a hint by the NvEncodeAPI interface to determine certain encoder parameters which are not exposed to the client.

There are two modes of operation for the encoder namely:

  • Asynchronous mode
  • Synchronous mode

The client can select asynchronous or synchronous mode by setting the enableEncodeAsync field in _NV_ENC_INITIALIZE_PARAMS to 1 or 0 respectively.

Asynchronous mode of operation:
The Asynchronous mode can be enabled by setting NV_ENC_INITIALIZE_PARAMS::enableEncodeAsync to 1. The client operating in asynchronous mode must allocate completion event object for each output buffer and pass the completion event object in the NvEncEncodePicture() API. The client can create another thread and wait on the event object to be signalled by NvEncodeAPI interface on completion of the encoding process for the output frame. This should unblock the main thread from submitting work to the encoder. When the event is signalled the client can call NvEncodeAPI interfaces to copy the bitstream data using NvEncLockBitstream() API. This is the preferred mode of operation.

NOTE: Asynchronous mode is not supported on Linux.

Synchronous mode of operation:
The client can select synchronous mode by setting NV_ENC_INITIALIZE_PARAMS::enableEncodeAsync to 0. The client working in synchronous mode can work in a single threaded or multi threaded mode. The client need not allocate any event objects. The client can only lock the bitstream data after NvEncodeAPI interface has returned NV_ENC_SUCCESS from encode picture. The NvEncodeAPI interface can return NV_ENC_ERR_NEED_MORE_INPUT error code from NvEncEncodePicture() API. The client must not lock the output buffer in such case but should send the next frame for encoding. The client must keep on calling NvEncEncodePicture() API until it returns NV_ENC_SUCCESS.
The client must always lock the bitstream data in order in which it has submitted. This is true for both asynchronous and synchronous mode.
Picture type decision:
If the client is taking the picture type decision and it must disable the picture type decision module in NvEncodeAPI by setting NV_ENC_INITIALIZE_PARAMS::enablePTD to 0. In this case the client is required to send the picture in encoding order to NvEncodeAPI by doing the re-ordering for B frames.
If the client doesn't want to take the picture type decision it can enable picture type decision module in the NvEncodeAPI interface by setting NV_ENC_INITIALIZE_PARAMS::enablePTD to 1 and send the input pictures in display order.
Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in] | createEncodeParams | Refer _NV_ENC_INITIALIZE_PARAMS for details.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_INVALID_VERSION
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncInvalidateRefFrames | ( | void * | encoder,
 |  | uint64_t | invalidRefFrameTimeStamp
 | ) |  |

Invalidate reference frames.

Invalidates reference frame based on the time stamp provided by the client. The encoder marks any reference frames or any frames which havev been reconstructed using the corrupt frame as invalid for motion estimation and uses older reference frames for motion estimation. The encoded forces the current frame to be encoded as an intra frame if no reference frames are left after invalidation process. This is usefull for low latency application for error resiliency. The client is recommended to set NV_ENC_CONFIG_H264::maxNumRefFrames to a large value so that encoder can keep a backup of older reference frames in the DPB and can use them for motion estimation when the newer reference frames have been invalidated. This API can be called multiple times.

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in] | invalidRefFrameTimeStamp | Timestamp of the invalid reference frames which needs to be invalidated.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncLockBitstream | ( | void * | encoder,
 |  | NV_ENC_LOCK_BITSTREAM * | lockBitstreamBufferParams
 | ) |  |

Lock output bitstream buffer.

This function is used to lock the bitstream buffer to read the encoded data. The client can only access the encoded data by calling this function. The pointer to client accessible encoded data is returned in the NV_ENC_LOCK_BITSTREAM::bitstreamBufferPtr field. The size of the encoded data in the output buffer is returned in the NV_ENC_LOCK_BITSTREAM::bitstreamSizeInBytes The NvEncodeAPI interface also returns the output picture type and picture structure of the encoded frame in NV_ENC_LOCK_BITSTREAM::pictureType and NV_ENC_LOCK_BITSTREAM::pictureStruct fields respectively. If the client has set NV_ENC_LOCK_BITSTREAM::doNotWait to 1, the function might return NV_ENC_ERR_LOCK_BUSY if client is operating in synchronous mode. This is not a fatal failure if NV_ENC_LOCK_BITSTREAM::doNotWait is set to 1. In the above case the client can retry the function after few milliseconds.

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in,out] | lockBitstreamBufferParams | Pointer to the _NV_ENC_LOCK_BITSTREAM structure.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_INVALID_VERSION
NV_ENC_ERR_LOCK_BUSY
NV_ENC_ERR_ENCODER_NOT_INITIALIZED
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncLockInputBuffer | ( | void * | encoder,
 |  | NV_ENC_LOCK_INPUT_BUFFER * | lockInputBufferParams
 | ) |  |

Locks an input buffer.

This function is used to lock the input buffer to load the uncompressed YUV pixel data into input buffer memory. The client must pass the NV_ENC_INPUT_PTR it had previously allocated using NvEncCreateInputBuffer()in the NV_ENC_LOCK_INPUT_BUFFER::inputBuffer field. The NvEncodeAPI interface returns pointer to client accessible input buffer memory in NV_ENC_LOCK_INPUT_BUFFER::bufferDataPtr field.

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in,out] | lockInputBufferParams | Pointer to the _NV_ENC_LOCK_INPUT_BUFFER structure
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_INVALID_VERSION
NV_ENC_ERR_LOCK_BUSY
NV_ENC_ERR_ENCODER_NOT_INITIALIZED
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncMapInputResource | ( | void * | encoder,
 |  | NV_ENC_MAP_INPUT_RESOURCE * | mapInputResParams
 | ) |  |

Map an externally created input resource pointer for encoding.

Maps an externally allocated input resource [using and returns a NV_ENC_INPUT_PTR which can be used for encoding in the NvEncEncodePicture() function. The mapped resource is returned in the field NV_ENC_MAP_INPUT_RESOURCE::outputResourcePtr. The NvEncodeAPI interface also returns the buffer format of the mapped resource in the field NV_ENC_MAP_INPUT_RESOURCE::outbufferFmt.

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in,out] | mapInputResParams | Pointer to the _NV_ENC_MAP_INPUT_RESOURCE structure.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_VERSION
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_ENCODER_NOT_INITIALIZED
NV_ENC_ERR_RESOURCE_NOT_REGISTERED
NV_ENC_ERR_MAP_FAILED
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncodeAPICreateInstance ( NV_ENCODE_API_FUNCTION_LIST * functionList )

Entry Point to the NvEncodeAPI interface.

Creates an instance of the NvEncodeAPI interface, and populates the pFunctionList with function pointers to the API routines implemented by the NvEncodeAPI interface.

Parameters:
[out] functionList
Returns:
NV_ENC_SUCCESS NV_ENC_ERR_INVALID_PTR


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncOpenEncodeSession | ( | void * | device,
 |  | uint32_t | deviceType,
 |  | void ** | encoder
 | ) |  |

Opens an encoding session.

Deprecated.

Returns:
NV_ENC_ERR_INVALID_CALL


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncOpenEncodeSessionEx | ( | NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS * | openSessionExParams,
 |  | void ** | encoder
 | ) |  |

Opens an encoding session.

Opens an encoding session and returns a pointer to the encoder interface in the **encoder parameter. The client should start encoding process by calling this API first. The client must pass a pointer to IDirect3DDevice9 interface *device parameter. If the Encoder session fails, the client must call NvEncDestroyEncoder API before exiting.

Parameters:
[in] | openSessionExParams | Pointer to a NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS structure.
[out] | encoder | Encode Session pointer to the NvEncodeAPI interface.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_NO_ENCODE_DEVICE
NV_ENC_ERR_UNSUPPORTED_DEVICE
NV_ENC_ERR_INVALID_DEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncReconfigureEncoder | ( | void * | encoder,
 |  | NV_ENC_RECONFIGURE_PARAMS * | reInitEncodeParams
 | ) |  |

Reconfigure an existing encoding session.

Reconfigure an existing encoding session. The client should call this API to change/reconfigure the parameter passed during NvEncInitializeEncoder API call. Currently Reconfiguration of following are not supported. Change in GOP structure. Change in sync-Async mode. Change in MaxWidth & MaxHeight. Change in PTDmode.

Resolution change is possible only if maxEncodeWidth & maxEncodeHeight of NV_ENC_INITIALIZE_PARAMS is set while creating encoder session.

Parameters:
[in] | encoder | Pointer to the NVEncodeAPI interface.
[in] | reInitEncodeParams | Pointer to a ::NV_ENC_RECONFIGURE_PARAMS structure.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_NO_ENCODE_DEVICE
NV_ENC_ERR_UNSUPPORTED_DEVICE
NV_ENC_ERR_INVALID_DEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncRegisterAsyncEvent | ( | void * | encoder,
 |  | NV_ENC_EVENT_PARAMS * | eventParams
 | ) |  |

Register event for notification to encoding completion.

This function is used to register the completion event with NvEncodeAPI interface. The event is required when the client has configured the encoder to work in asynchronous mode. In this mode the client needs to send a completion event with every output buffer. The NvEncodeAPI interface will signal the completion of the encoding process using this event. Only after the event is signalled the client can get the encoded data using NvEncLockBitstream() function.

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in] | eventParams | Pointer to the _NV_ENC_EVENT_PARAMS structure.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_VERSION
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_ENCODER_NOT_INITIALIZED
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncRegisterResource | ( | void * | encoder,
 |  | NV_ENC_REGISTER_RESOURCE * | registerResParams
 | ) |  |

Registers a resource with the Nvidia Video Encoder Interface.

Registers a resource with the Nvidia Video Encoder Interface for book keeping. The client is expected to pass the registered resource handle as well, while calling NvEncMapInputResource API. This API is not implemented for the DirectX Interface. DirectX based clients need not change their implementation.

Parameters:
[in] | encoder | Pointer to the NVEncodeAPI interface.
[in] | registerResParams | Pointer to a _NV_ENC_REGISTER_RESOURCE structure
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_VERSION
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_ENCODER_NOT_INITIALIZED
NV_ENC_ERR_RESOURCE_REGISTER_FAILED
NV_ENC_ERR_GENERIC
NV_ENC_ERR_UNIMPLEMENTED


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncUnlockBitstream | ( | void * | encoder,
 |  | NV_ENC_OUTPUT_PTR | bitstreamBuffer
 | ) |  |

Unlock the output bitstream buffer.

This function is used to unlock the output bitstream buffer after the client has read the encoded data from output buffer. The client must call this function to unlock the output buffer which it has previously locked using NvEncLockBitstream() function. Using a locked bitstream buffer in NvEncEncodePicture() API will cause the function to fail.

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in,out] | bitstreamBuffer | bitstream buffer pointer being unlocked
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_ENCODER_NOT_INITIALIZED
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncUnlockInputBuffer | ( | void * | encoder,
 |  | NV_ENC_INPUT_PTR | inputBuffer
 | ) |  |

Unlocks the input buffer.

This function is used to unlock the input buffer memory previously locked for uploading YUV pixel data. The input buffer must be unlocked before being used again for encoding, otherwise NvEncodeAPI will fail the NvEncEncodePicture()

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in] | inputBuffer | Pointer to the input buffer that is being unlocked.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_VERSION
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_ENCODER_NOT_INITIALIZED
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncUnmapInputResource | ( | void * | encoder,
 |  | NV_ENC_INPUT_PTR | mappedInputBuffer
 | ) |  |

UnMaps a NV_ENC_INPUT_PTR which was mapped for encoding.

UnMaps an input buffer which was previously mapped using NvEncMapInputResource() API. The mapping created using NvEncMapInputResource() should be invalidated using this API before the external resource is destroyed by the client.

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in] | mappedInputBuffer | Pointer to the NV_ENC_INPUT_PTR
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_VERSION
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_ENCODER_NOT_INITIALIZED
NV_ENC_ERR_RESOURCE_NOT_REGISTERED
NV_ENC_ERR_RESOURCE_NOT_MAPPED
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncUnregisterAsyncEvent | ( | void * | encoder,
 |  | NV_ENC_EVENT_PARAMS * | eventParams
 | ) |  |

Unregister completion event.

This function is used to unregister completion event which has been previously registered using NvEncRegisterAsyncEvent() function. The client must unregister all events before destroying the encoder using NvEncDestroyEncoder() function.

Parameters:
[in] | encoder | Pointer to the NvEncodeAPI interface.
[in] | eventParams | Pointer to the _NV_ENC_EVENT_PARAMS structure.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_VERSION
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_ENCODER_NOT_INITIALIZED
NV_ENC_ERR_GENERIC


  • NvEncodeAPI Functions
NvEncCreateBitstreamBuffer
NvEncCreateInputBuffer
NvEncDestroyBitstreamBuffer
NvEncDestroyEncoder
NvEncDestroyInputBuffer
NvEncEncodePicture
NvEncGetEncodeCaps
NvEncGetEncodeGUIDCount
NvEncGetEncodeGUIDs
NvEncGetEncodePresetConfig
NvEncGetEncodePresetCount
NvEncGetEncodePresetGUIDs
NvEncGetEncodeProfileGUIDCount
NvEncGetEncodeProfileGUIDs
NvEncGetEncodeStats
NvEncGetInputFormatCount
NvEncGetInputFormats
NvEncGetSequenceParams
NvEncInitializeEncoder
NvEncInvalidateRefFrames
NvEncLockBitstream
NvEncLockInputBuffer
NvEncMapInputResource
NvEncodeAPICreateInstance
NvEncOpenEncodeSession
NvEncOpenEncodeSessionEx
NvEncReconfigureEncoder
NvEncRegisterAsyncEvent
NvEncRegisterResource
NvEncUnlockBitstream
NvEncUnlockInputBuffer
NvEncUnmapInputResource
NvEncUnregisterAsyncEvent
NvEncUnregisterResource
NVENCSTATUS NVENCAPI NvEncUnregisterResource | ( | void * | encoder,
 |  | NV_ENC_REGISTERED_PTR | registeredResource
 | ) |  |

Unregisters a resource previously registered with the Nvidia Video Encoder Interface.

Unregisters a resource previously registered with the Nvidia Video Encoder Interface. The client is expected to unregister any resource that it has registered with the Nvidia Video Encoder Interface before destroying the resource. This API is not implemented for the DirectX Interface. DirectX based clients need not change their implementation.

Parameters:
[in] | encoder | Pointer to the NVEncodeAPI interface.
[in] | registeredResource | The registered resource pointer that was returned in NvEncRegisterResource.
Returns:
NV_ENC_SUCCESS
NV_ENC_ERR_INVALID_PTR
NV_ENC_ERR_INVALID_ENCODERDEVICE
NV_ENC_ERR_DEVICE_NOT_EXIST
NV_ENC_ERR_UNSUPPORTED_PARAM
NV_ENC_ERR_OUT_OF_MEMORY
NV_ENC_ERR_INVALID_VERSION
NV_ENC_ERR_INVALID_PARAM
NV_ENC_ERR_ENCODER_NOT_INITIALIZED
NV_ENC_ERR_RESOURCE_NOT_REGISTERED
NV_ENC_ERR_GENERIC
NV_ENC_ERR_UNIMPLEMENTED


  • Data Structure Index
  • Data Fields
Data Structures
Here are the data structures with brief descriptions:
_NV_ENC_CAPS_PARAM
_NV_ENC_CODEC_CONFIG
_NV_ENC_CODEC_PIC_PARAMS
_NV_ENC_CONFIG
_NV_ENC_CONFIG_H264
_NV_ENC_CONFIG_H264_VUI_PARAMETERS
_NV_ENC_CONFIG_HEVC
_NV_ENC_CREATE_BITSTREAM_BUFFER
_NV_ENC_CREATE_INPUT_BUFFER
_NV_ENC_EVENT_PARAMS
_NV_ENC_H264_SEI_PAYLOAD
_NV_ENC_INITIALIZE_PARAMS
_NV_ENC_LOCK_BITSTREAM
_NV_ENC_LOCK_INPUT_BUFFER
_NV_ENC_MAP_INPUT_RESOURCE
_NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS
_NV_ENC_PIC_PARAMS
_NV_ENC_PIC_PARAMS_H264
_NV_ENC_PIC_PARAMS_HEVC
_NV_ENC_PRESET_CONFIG
_NV_ENC_QP
_NV_ENC_RC_PARAMS
_NV_ENC_RECONFIGURE_PARAMS
_NV_ENC_REGISTER_RESOURCE
_NV_ENC_SEQUENCE_PARAM_PAYLOAD
_NV_ENC_STAT
_NV_ENCODE_API_FUNCTION_LIST
_NVENC_EXTERNAL_ME_HINT
_NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE
_NVENC_RECT
GUID


  • _NV_ENC_CAPS_PARAM
capsToQuery
reserved
version
NV_ENC_CAPS capsToQuery

[in]: Specifies the encode capability to be queried. Client should pass a member for NV_ENC_CAPS enum.


  • _NV_ENC_CAPS_PARAM
capsToQuery
reserved
version
uint32_t reserved[62]

[in]: Reserved and must be set to 0


  • _NV_ENC_CAPS_PARAM
capsToQuery
reserved
version
uint32_t version

[in]: Struct version. Must be set to NV_ENC_CAPS_PARAM_VER


  • _NV_ENC_CODEC_CONFIG
h264Config
hevcConfig
reserved
NV_ENC_CONFIG_H264 h264Config

[in]: Specifies the H.264-specific encoder configuration


  • _NV_ENC_CODEC_CONFIG
h264Config
hevcConfig
reserved
NV_ENC_CONFIG_HEVC hevcConfig

[in]: Specifies the HEVC-specific encoder configuration. Currently unsupported and must not to be used.


  • _NV_ENC_CODEC_CONFIG
h264Config
hevcConfig
reserved
uint32_t reserved[256]

[in]: Reserved and must be set to 0


  • _NV_ENC_CODEC_PIC_PARAMS
h264PicParams
hevcPicParams
reserved
NV_ENC_PIC_PARAMS_H264 h264PicParams

[in]: H264 encode picture params.


  • _NV_ENC_CODEC_PIC_PARAMS
h264PicParams
hevcPicParams
reserved
NV_ENC_PIC_PARAMS_HEVC hevcPicParams

[in]: HEVC encode picture params. Currently unsupported and must not to be used.


  • _NV_ENC_CODEC_PIC_PARAMS
h264PicParams
hevcPicParams
reserved
uint32_t reserved[256]

[in]: Reserved and must be set to 0.


  • _NV_ENC_CONFIG
encodeCodecConfig
frameFieldMode
frameIntervalP
gopLength
monoChromeEncoding
mvPrecision
profileGUID
rcParams
reserved
reserved2
version
NV_ENC_CODEC_CONFIG encodeCodecConfig

[in]: Specifies the codec specific config parameters through this union.


  • _NV_ENC_CONFIG
encodeCodecConfig
frameFieldMode
frameIntervalP
gopLength
monoChromeEncoding
mvPrecision
profileGUID
rcParams
reserved
reserved2
version
NV_ENC_PARAMS_FRAME_FIELD_MODE frameFieldMode

[in]: Specifies the frame/field mode. Check support for field encoding using NV_ENC_CAPS_SUPPORT_FIELD_ENCODING caps.


  • _NV_ENC_CONFIG
encodeCodecConfig
frameFieldMode
frameIntervalP
gopLength
monoChromeEncoding
mvPrecision
profileGUID
rcParams
reserved
reserved2
version
int32_t frameIntervalP

[in]: Specifies the GOP pattern as follows: frameIntervalP = 0: I, 1: IPP, 2: IBP, 3: IBBP If goplength is set to NVENC_INFINITE_GOPLENGTH frameIntervalP should be set to 1.


  • _NV_ENC_CONFIG
encodeCodecConfig
frameFieldMode
frameIntervalP
gopLength
monoChromeEncoding
mvPrecision
profileGUID
rcParams
reserved
reserved2
version
uint32_t gopLength

[in]: Specifies the number of pictures in one GOP. Low latency application client can set goplength to NVENC_INFINITE_GOPLENGTH so that keyframes are not inserted automatically.


  • _NV_ENC_CONFIG
encodeCodecConfig
frameFieldMode
frameIntervalP
gopLength
monoChromeEncoding
mvPrecision
profileGUID
rcParams
reserved
reserved2
version
uint32_t monoChromeEncoding

[in]: Set this to 1 to enable monochrome encoding for this session.


  • _NV_ENC_CONFIG
encodeCodecConfig
frameFieldMode
frameIntervalP
gopLength
monoChromeEncoding
mvPrecision
profileGUID
rcParams
reserved
reserved2
version
NV_ENC_MV_PRECISION mvPrecision

[in]: Specifies the desired motion vector prediction precision.


  • _NV_ENC_CONFIG
encodeCodecConfig
frameFieldMode
frameIntervalP
gopLength
monoChromeEncoding
mvPrecision
profileGUID
rcParams
reserved
reserved2
version
GUID profileGUID

[in]: Specifies the codec profile guid. If client specifies NV_ENC_CODEC_PROFILE_AUTOSELECT_GUID the NvEncodeAPI interface will select the appropriate codec profile.


  • _NV_ENC_CONFIG
encodeCodecConfig
frameFieldMode
frameIntervalP
gopLength
monoChromeEncoding
mvPrecision
profileGUID
rcParams
reserved
reserved2
version
NV_ENC_RC_PARAMS rcParams

[in]: Specifies the rate control parameters for the current encoding session.


  • _NV_ENC_CONFIG
encodeCodecConfig
frameFieldMode
frameIntervalP
gopLength
monoChromeEncoding
mvPrecision
profileGUID
rcParams
reserved
reserved2
version
uint32_t reserved[278]

[in]: Reserved and must be set to 0


  • _NV_ENC_CONFIG
encodeCodecConfig
frameFieldMode
frameIntervalP
gopLength
monoChromeEncoding
mvPrecision
profileGUID
rcParams
reserved
reserved2
version
void* reserved2[64]

[in]: Reserved and must be set to NULL


  • _NV_ENC_CONFIG
encodeCodecConfig
frameFieldMode
frameIntervalP
gopLength
monoChromeEncoding
mvPrecision
profileGUID
rcParams
reserved
reserved2
version
uint32_t version

[in]: Struct version. Must be set to NV_ENC_CONFIG_VER.


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
NV_ENC_H264_ADAPTIVE_TRANSFORM_MODE adaptiveTransformMode

[in]: Specifies the AdaptiveTransform Mode. Check support for AdaptiveTransform mode using NV_ENC_CAPS_SUPPORT_ADAPTIVE_TRANSFORM caps.


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
NV_ENC_H264_BDIRECT_MODE bdirectMode

[in]: Specifies the BDirect mode. Check support for BDirect mode using NV_ENC_CAPS_SUPPORT_BDIRECT_MODE caps.


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t chromaFormatIDC

[in]: Specifies the chroma format. Should be set to 1 for yuv420 input, 3 for yuv444 input. Check support for YUV444 encoding using NV_ENC_CAPS_SUPPORT_YUV444_ENCODE caps.


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t disableDeblockingFilterIDC

[in]: Specifies the deblocking filter mode. Permissible value range: [0,2]


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t disableSPSPPS

[in]: Set to 1 to disable writing of Sequence and Picture parameter info in bitstream


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t enableConstrainedEncoding

[in]: Set this to 1 to enable constrainedFrame encoding where each slice in the constarined picture is independent of other slices Check support for constrained encoding using NV_ENC_CAPS_SUPPORT_CONSTRAINED_ENCODING caps.


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t enableIntraRefresh

[in]: Set to 1 to enable gradual decoder refresh or intra refresh. If the GOP structure uses B frames this will be ignored


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t enableLTR

[in]: Currently this feature is not available and must be set to 0. Set to 1 to enable LTR support and auto-mark the first


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t enableStereoMVC

[in]: Set to 1 to enable stereo MVC


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t enableTemporalSVC

[in]: Set to 1 to enable SVC temporal


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t enableVFR

[in]: Set to 1 to enable variable frame rate.


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
NV_ENC_H264_ENTROPY_CODING_MODE entropyCodingMode

[in]: Specifies the entropy coding mode. Check support for CABAC mode using NV_ENC_CAPS_SUPPORT_CABAC caps.


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
NV_ENC_H264_FMO_MODE fmoMode

[in]: Specified the FMO Mode. Check support for FMO using NV_ENC_CAPS_SUPPORT_FMO caps.


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
NV_ENC_CONFIG_H264_VUI_PARAMETERS h264VUIParameters

[in]: Specifies the H264 video usability info pamameters


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t hierarchicalBFrames

[in]: Set to 1 to enable hierarchical BFrames


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t hierarchicalPFrames

[in]: Set to 1 to enable hierarchical PFrames


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t idrPeriod

[in]: Specifies the IDR interval. If not set, this is made equal to gopLength in NV_ENC_CONFIG.Low latency application client can set IDR interval to NVENC_INFINITE_GOPLENGTH so that IDR frames are not inserted automatically.


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t intraRefreshCnt

[in]: Specifies the length of intra refresh in number of frames for periodic intra refresh. This value should be smaller than intraRefreshPeriod


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t intraRefreshPeriod

[in]: Specifies the interval between successive intra refresh if enableIntrarefresh is set. Requires enableIntraRefresh to be set. Will be disabled if NV_ENC_CONFIG::gopLength is not set to NVENC_INFINITE_GOPLENGTH.


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t level

[in]: Specifies the encoding level. Client is recommended to set this to NV_ENC_LEVEL_AUTOSELECT in order to enable the NvEncodeAPI interface to select the correct level.


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t ltrNumFrames

[in]: Specifies the number of LTR frames used. Additionally, encoder will mark the first numLTRFrames base layer reference frames within each IDR interval as LTR


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t ltrTrustMode

[in]: Specifies the LTR operating mode. Set to 0 to disallow encoding using LTR frames until later specified. Set to 1 to allow encoding using LTR frames unless later invalidated.


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t maxNumRefFrames

[in]: Specifies the DPB size used for encoding. Setting it to 0 will let driver use the default dpb size. The low latency application which wants to invalidate reference frame as an error resilience tool is recommended to use a large DPB size so that the encoder can keep old reference frames which can be used if recent frames are invalidated.


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t numTemporalLayers

[in]: Specifies max temporal layers to be used for hierarchical coding. Valid value range is [1,NV_ENC_CAPS_NUM_MAX_TEMPORAL_LAYERS]


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t outputAUD

[in]: Set to 1 to write access unit delimiter syntax in bitstream


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t outputBufferingPeriodSEI

[in]: Set to 1 to write SEI buffering period syntax in the bitstream


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t outputFramePackingSEI

[in]: Set to 1 to enable writing of frame packing arrangement SEI messages to bitstream


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t outputPictureTimingSEI

[in]: Set to 1 to write SEI picture timing syntax in the bitstream


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t outputRecoveryPointSEI

[in]: Set to 1 to enable writing of recovery point SEI message


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t ppsId

[in]: Specifies the PPS id of the picture header. Currently reserved and must be set to 0.


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t qpPrimeYZeroTransformBypassFlag

[in]: To enable lossless encode set this to 1, set QP to 0 and RC_mode to NV_ENC_PARAMS_RC_CONSTQP and profile to HIGH_444_PREDICTIVE_PROFILE. Check support for lossless encoding using NV_ENC_CAPS_SUPPORT_LOSSLESS_ENCODE caps.


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t repeatSPSPPS

[in]: Set to 1 to enable writing of Sequence and Picture parameter for every IDR frame


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t reserved1[271]

[in]: Reserved and must be set to 0


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
void* reserved2[64]

[in]: Reserved and must be set to NULL


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t reservedBitFields

[in]: Reserved bitfields and must be set to 0


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t separateColourPlaneFlag

[in]: Set to 1 to enable 4:4:4 separate colour planes


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t sliceMode

[in]: This parameter in conjunction with sliceModeData specifies the way in which the picture is divided into slices sliceMode = 0 MB based slices, sliceMode = 1 Byte based slices, sliceMode = 2 MB row based slices, sliceMode = 3, numSlices in Picture When forceIntraRefreshWithFrameCnt is set it will have priority over sliceMode setting When sliceMode == 0 and sliceModeData == 0 whole picture will be coded with one slice


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t sliceModeData

[in]: Specifies the parameter needed for sliceMode. For: sliceMode = 0, sliceModeData specifies # of MBs in each slice (except last slice) sliceMode = 1, sliceModeData specifies maximum # of bytes in each slice (except last slice) sliceMode = 2, sliceModeData specifies # of MB rows in each slice (except last slice) sliceMode = 3, sliceModeData specifies number of slices in the picture. Driver will divide picture into slices optimally


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
uint32_t spsId

[in]: Specifies the SPS id of the sequence header. Currently reserved and must be set to 0.


  • _NV_ENC_CONFIG_H264
adaptiveTransformMode
bdirectMode
chromaFormatIDC
disableDeblockingFilterIDC
disableSPSPPS
enableConstrainedEncoding
enableIntraRefresh
enableLTR
enableStereoMVC
enableTemporalSVC
enableVFR
entropyCodingMode
fmoMode
h264VUIParameters
hierarchicalBFrames
hierarchicalPFrames
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
ltrTrustMode
maxNumRefFrames
numTemporalLayers
outputAUD
outputBufferingPeriodSEI
outputFramePackingSEI
outputPictureTimingSEI
outputRecoveryPointSEI
ppsId
qpPrimeYZeroTransformBypassFlag
repeatSPSPPS
reserved1
reserved2
reservedBitFields
separateColourPlaneFlag
sliceMode
sliceModeData
spsId
stereoMode
NV_ENC_STEREO_PACKING_MODE stereoMode

[in]: Specifies the stereo frame packing mode which is to be signalled in frame packing arrangement SEI


  • _NV_ENC_CONFIG_H264_VUI_PARAMETERS
bitstreamRestrictionFlag
chromaSampleLocationBot
chromaSampleLocationFlag
chromaSampleLocationTop
colourDescriptionPresentFlag
colourMatrix
colourPrimaries
overscanInfo
overscanInfoPresentFlag
transferCharacteristics
videoFormat
videoFullRangeFlag
videoSignalTypePresentFlag
uint32_t bitstreamRestrictionFlag

[in]: if set to 1, it speficies the bitstream restriction parameters are present in the bitstream.


  • _NV_ENC_CONFIG_H264_VUI_PARAMETERS
bitstreamRestrictionFlag
chromaSampleLocationBot
chromaSampleLocationFlag
chromaSampleLocationTop
colourDescriptionPresentFlag
colourMatrix
colourPrimaries
overscanInfo
overscanInfoPresentFlag
transferCharacteristics
videoFormat
videoFullRangeFlag
videoSignalTypePresentFlag
uint32_t chromaSampleLocationBot

[in]: Specifies the chroma sample location for bottom field(as defined in Annex E of the ITU-T Specification)


  • _NV_ENC_CONFIG_H264_VUI_PARAMETERS
bitstreamRestrictionFlag
chromaSampleLocationBot
chromaSampleLocationFlag
chromaSampleLocationTop
colourDescriptionPresentFlag
colourMatrix
colourPrimaries
overscanInfo
overscanInfoPresentFlag
transferCharacteristics
videoFormat
videoFullRangeFlag
videoSignalTypePresentFlag
uint32_t chromaSampleLocationFlag

[in]: if set to 1 , it specifies that thechromaSampleLocationTop and chromaSampleLocationBot are present.


  • _NV_ENC_CONFIG_H264_VUI_PARAMETERS
bitstreamRestrictionFlag
chromaSampleLocationBot
chromaSampleLocationFlag
chromaSampleLocationTop
colourDescriptionPresentFlag
colourMatrix
colourPrimaries
overscanInfo
overscanInfoPresentFlag
transferCharacteristics
videoFormat
videoFullRangeFlag
videoSignalTypePresentFlag
uint32_t chromaSampleLocationTop

[in]: Specifies the chroma sample location for top field(as defined in Annex E of the ITU-T Specification)


  • _NV_ENC_CONFIG_H264_VUI_PARAMETERS
bitstreamRestrictionFlag
chromaSampleLocationBot
chromaSampleLocationFlag
chromaSampleLocationTop
colourDescriptionPresentFlag
colourMatrix
colourPrimaries
overscanInfo
overscanInfoPresentFlag
transferCharacteristics
videoFormat
videoFullRangeFlag
videoSignalTypePresentFlag
uint32_t colourDescriptionPresentFlag

[in]: If set to 1, it specifies that the colourPrimaries, transferCharacteristics and colourMatrix are present.


  • _NV_ENC_CONFIG_H264_VUI_PARAMETERS
bitstreamRestrictionFlag
chromaSampleLocationBot
chromaSampleLocationFlag
chromaSampleLocationTop
colourDescriptionPresentFlag
colourMatrix
colourPrimaries
overscanInfo
overscanInfoPresentFlag
transferCharacteristics
videoFormat
videoFullRangeFlag
videoSignalTypePresentFlag
uint32_t colourMatrix

[in]: Specifies the matrix coefficients used in deriving the luma and chroma from the RGB primaries (as defined in Annex E of the ITU-T Specification).


  • _NV_ENC_CONFIG_H264_VUI_PARAMETERS
bitstreamRestrictionFlag
chromaSampleLocationBot
chromaSampleLocationFlag
chromaSampleLocationTop
colourDescriptionPresentFlag
colourMatrix
colourPrimaries
overscanInfo
overscanInfoPresentFlag
transferCharacteristics
videoFormat
videoFullRangeFlag
videoSignalTypePresentFlag
uint32_t colourPrimaries

[in]: Specifies color primaries for converting to RGB(as defined in Annex E of the ITU-T Specification)


  • _NV_ENC_CONFIG_H264_VUI_PARAMETERS
bitstreamRestrictionFlag
chromaSampleLocationBot
chromaSampleLocationFlag
chromaSampleLocationTop
colourDescriptionPresentFlag
colourMatrix
colourPrimaries
overscanInfo
overscanInfoPresentFlag
transferCharacteristics
videoFormat
videoFullRangeFlag
videoSignalTypePresentFlag
uint32_t overscanInfo

[in]: Specifies the overscan info(as defined in Annex E of the ITU-T Specification).


  • _NV_ENC_CONFIG_H264_VUI_PARAMETERS
bitstreamRestrictionFlag
chromaSampleLocationBot
chromaSampleLocationFlag
chromaSampleLocationTop
colourDescriptionPresentFlag
colourMatrix
colourPrimaries
overscanInfo
overscanInfoPresentFlag
transferCharacteristics
videoFormat
videoFullRangeFlag
videoSignalTypePresentFlag
uint32_t overscanInfoPresentFlag

[in]: if set to 1 , it specifies that the overscanInfo is present


  • _NV_ENC_CONFIG_H264_VUI_PARAMETERS
bitstreamRestrictionFlag
chromaSampleLocationBot
chromaSampleLocationFlag
chromaSampleLocationTop
colourDescriptionPresentFlag
colourMatrix
colourPrimaries
overscanInfo
overscanInfoPresentFlag
transferCharacteristics
videoFormat
videoFullRangeFlag
videoSignalTypePresentFlag


  • _NV_ENC_CONFIG_H264_VUI_PARAMETERS
bitstreamRestrictionFlag
chromaSampleLocationBot
chromaSampleLocationFlag
chromaSampleLocationTop
colourDescriptionPresentFlag
colourMatrix
colourPrimaries
overscanInfo
overscanInfoPresentFlag
transferCharacteristics
videoFormat
videoFullRangeFlag
videoSignalTypePresentFlag
uint32_t transferCharacteristics

[in]: Specifies the opto-electronic transfer characteristics to use (as defined in Annex E of the ITU-T Specification)


  • _NV_ENC_CONFIG_H264_VUI_PARAMETERS
bitstreamRestrictionFlag
chromaSampleLocationBot
chromaSampleLocationFlag
chromaSampleLocationTop
colourDescriptionPresentFlag
colourMatrix
colourPrimaries
overscanInfo
overscanInfoPresentFlag
transferCharacteristics
videoFormat
videoFullRangeFlag
videoSignalTypePresentFlag
uint32_t videoFormat

[in]: Specifies the source video format(as defined in Annex E of the ITU-T Specification).


  • _NV_ENC_CONFIG_H264_VUI_PARAMETERS
bitstreamRestrictionFlag
chromaSampleLocationBot
chromaSampleLocationFlag
chromaSampleLocationTop
colourDescriptionPresentFlag
colourMatrix
colourPrimaries
overscanInfo
overscanInfoPresentFlag
transferCharacteristics
videoFormat
videoFullRangeFlag
videoSignalTypePresentFlag
uint32_t videoFullRangeFlag

[in]: Specifies the output range of the luma and chroma samples(as defined in Annex E of the ITU-T Specification).


  • _NV_ENC_CONFIG_H264_VUI_PARAMETERS
bitstreamRestrictionFlag
chromaSampleLocationBot
chromaSampleLocationFlag
chromaSampleLocationTop
colourDescriptionPresentFlag
colourMatrix
colourPrimaries
overscanInfo
overscanInfoPresentFlag
transferCharacteristics
videoFormat
videoFullRangeFlag
videoSignalTypePresentFlag
uint32_t videoSignalTypePresentFlag

[in]: If set to 1, it specifies that the videoFormat, videoFullRangeFlag and colourDescriptionPresentFlag are present.


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
uint32_t disableDeblockAcrossSliceBoundary

[in]: Set 1 to disable in loop filtering across slice boundary.


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
uint32_t disableSPSPPS

[in]: Set 1 to disable VPS,SPS and PPS signalling in the bitstream.


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
uint32_t enableIntraRefresh

[in]: Set 1 to enable gradual decoder refresh or intra refresh. If the GOP structure uses B frames this will be ignored


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
uint32_t enableLTR

[in]: Set 1 to enable use of long term reference pictures for inter prediction.


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
uint32_t idrPeriod

[in]: Specifies the IDR interval. If not set, this is made equal to gopLength in NV_ENC_CONFIG.Low latency application client can set IDR interval to NVENC_INFINITE_GOPLENGTH so that IDR frames are not inserted automatically.


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
uint32_t intraRefreshCnt

[in]: Specifies the length of intra refresh in number of frames for periodic intra refresh. This value should be smaller than intraRefreshPeriod


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
uint32_t intraRefreshPeriod

[in]: Specifies the interval between successive intra refresh if enableIntrarefresh is set. Requires enableIntraRefresh to be set. Will be disabled if NV_ENC_CONFIG::gopLength is not set to NVENC_INFINITE_GOPLENGTH.


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
uint32_t level

[in]: Specifies the level of the encoded bitstream.


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
uint32_t ltrNumFrames

[in]: Specifies the maximum number of long term references can be used for prediction


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
NV_ENC_HEVC_CUSIZE maxCUSize

[in]: Specifies the maximum size of luma coding unit. Currently NVENC SDK only supports maxCUSize equal to NV_ENC_HEVC_CUSIZE_32x32.


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
uint32_t maxNumRefFramesInDPB

[in]: Specifies the maximum number of references frames in the DPB.


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
uint32_t maxTemporalLayersMinus1

[in]: Specifies the max temporal layer used for hierarchical coding.


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
NV_ENC_HEVC_CUSIZE minCUSize

[in]: Specifies the minimum size of luma coding unit.


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
uint32_t outputAUD

[in]: Set 1 to write Access Unit Delimiter syntax.


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
uint32_t outputBufferingPeriodSEI

[in]: Set 1 to write SEI buffering period syntax in the bitstream


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
uint32_t outputPictureTimingSEI

[in]: Set 1 to write SEI picture timing syntax in the bitstream


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
uint32_t ppsId

[in]: Specifies the PPS id of the picture header. Currently reserved and must be set to 0.


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
uint32_t repeatSPSPPS

[in]: Set 1 to output VPS,SPS and PPS for every IDR frame.


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
uint32_t reserved

[in]: Reserved bitfields.


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
uint32_t reserved1[246]

[in]: Reserved and must be set to 0.


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
void* reserved2[64]

[in]: Reserved and must be set to NULL


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
uint32_t sliceMode

[in]: This parameter in conjunction with sliceModeData specifies the way in which the picture is divided into slices sliceMode = 0 CTU based slices, sliceMode = 1 Byte based slices, sliceMode = 2 CTU row based slices, sliceMode = 3, numSlices in Picture When sliceMode == 0 and sliceModeData == 0 whole picture will be coded with one slice


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
uint32_t sliceModeData

[in]: Specifies the parameter needed for sliceMode. For: sliceMode = 0, sliceModeData specifies # of CTUs in each slice (except last slice) sliceMode = 1, sliceModeData specifies maximum # of bytes in each slice (except last slice) sliceMode = 2, sliceModeData specifies # of CTU rows in each slice (except last slice) sliceMode = 3, sliceModeData specifies number of slices in the picture. Driver will divide picture into slices optimally


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
uint32_t spsId

[in]: Specifies the SPS id of the sequence header. Currently reserved and must be set to 0.


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
uint32_t tier

[in]: Specifies the level tier of the encoded bitstream.


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
uint32_t useConstrainedIntraPred

[in]: Set 1 to enable constrained intra prediction.


  • _NV_ENC_CONFIG_HEVC
disableDeblockAcrossSliceBoundary
disableSPSPPS
enableIntraRefresh
enableLTR
idrPeriod
intraRefreshCnt
intraRefreshPeriod
level
ltrNumFrames
maxCUSize
maxNumRefFramesInDPB
maxTemporalLayersMinus1
minCUSize
outputAUD
outputBufferingPeriodSEI
outputPictureTimingSEI
ppsId
repeatSPSPPS
reserved
reserved1
reserved2
sliceMode
sliceModeData
spsId
tier
useConstrainedIntraPred
vpsId
uint32_t vpsId

[in]: Specifies the VPS id of the video parameter set. Currently reserved and must be set to 0.


  • _NV_ENC_CREATE_BITSTREAM_BUFFER
bitstreamBuffer
bitstreamBufferPtr
memoryHeap
reserved
reserved1
reserved2
size
version
NV_ENC_OUTPUT_PTR bitstreamBuffer

[out]: Pointer to the output bitstream buffer


  • _NV_ENC_CREATE_BITSTREAM_BUFFER
bitstreamBuffer
bitstreamBufferPtr
memoryHeap
reserved
reserved1
reserved2
size
version
void* bitstreamBufferPtr

[out]: Reserved and should not be used


  • _NV_ENC_CREATE_BITSTREAM_BUFFER
bitstreamBuffer
bitstreamBufferPtr
memoryHeap
reserved
reserved1
reserved2
size
version
NV_ENC_MEMORY_HEAP memoryHeap

[in]: Output buffer memory heap


  • _NV_ENC_CREATE_BITSTREAM_BUFFER
bitstreamBuffer
bitstreamBufferPtr
memoryHeap
reserved
reserved1
reserved2
size
version
uint32_t reserved

[in]: Reserved and must be set to 0


  • _NV_ENC_CREATE_BITSTREAM_BUFFER
bitstreamBuffer
bitstreamBufferPtr
memoryHeap
reserved
reserved1
reserved2
size
version
uint32_t reserved1[58]

[in]: Reserved and should be set to 0


  • _NV_ENC_CREATE_BITSTREAM_BUFFER
bitstreamBuffer
bitstreamBufferPtr
memoryHeap
reserved
reserved1
reserved2
size
version
void* reserved2[64]

[in]: Reserved and should be set to NULL


  • _NV_ENC_CREATE_BITSTREAM_BUFFER
bitstreamBuffer
bitstreamBufferPtr
memoryHeap
reserved
reserved1
reserved2
size
version
uint32_t size

[in]: Size of the bitstream buffer to be created


  • _NV_ENC_CREATE_BITSTREAM_BUFFER
bitstreamBuffer
bitstreamBufferPtr
memoryHeap
reserved
reserved1
reserved2
size
version
uint32_t version

[in]: Struct version. Must be set to NV_ENC_CREATE_BITSTREAM_BUFFER_VER


  • _NV_ENC_CREATE_INPUT_BUFFER
bufferFmt
height
inputBuffer
memoryHeap
pSysMemBuffer
reserved
reserved1
reserved2
version
width
NV_ENC_BUFFER_FORMAT bufferFmt

[in]: Input buffer format


  • _NV_ENC_CREATE_INPUT_BUFFER
bufferFmt
height
inputBuffer
memoryHeap
pSysMemBuffer
reserved
reserved1
reserved2
version
width
uint32_t height

[in]: Input buffer width


  • _NV_ENC_CREATE_INPUT_BUFFER
bufferFmt
height
inputBuffer
memoryHeap
pSysMemBuffer
reserved
reserved1
reserved2
version
width
NV_ENC_INPUT_PTR inputBuffer

[out]: Pointer to input buffer


  • _NV_ENC_CREATE_INPUT_BUFFER
bufferFmt
height
inputBuffer
memoryHeap
pSysMemBuffer
reserved
reserved1
reserved2
version
width
NV_ENC_MEMORY_HEAP memoryHeap

[in]: Input buffer memory heap


  • _NV_ENC_CREATE_INPUT_BUFFER
bufferFmt
height
inputBuffer
memoryHeap
pSysMemBuffer
reserved
reserved1
reserved2
version
width
void* pSysMemBuffer

[in]: Pointer to existing sysmem buffer


  • _NV_ENC_CREATE_INPUT_BUFFER
bufferFmt
height
inputBuffer
memoryHeap
pSysMemBuffer
reserved
reserved1
reserved2
version
width
uint32_t reserved

[in]: Reserved and must be set to 0


  • _NV_ENC_CREATE_INPUT_BUFFER
bufferFmt
height
inputBuffer
memoryHeap
pSysMemBuffer
reserved
reserved1
reserved2
version
width
uint32_t reserved1[57]

[in]: Reserved and must be set to 0


  • _NV_ENC_CREATE_INPUT_BUFFER
bufferFmt
height
inputBuffer
memoryHeap
pSysMemBuffer
reserved
reserved1
reserved2
version
width
void* reserved2[63]

[in]: Reserved and must be set to NULL


  • _NV_ENC_CREATE_INPUT_BUFFER
bufferFmt
height
inputBuffer
memoryHeap
pSysMemBuffer
reserved
reserved1
reserved2
version
width
uint32_t version

[in]: Struct version. Must be set to NV_ENC_CREATE_INPUT_BUFFER_VER


  • _NV_ENC_CREATE_INPUT_BUFFER
bufferFmt
height
inputBuffer
memoryHeap
pSysMemBuffer
reserved
reserved1
reserved2
version
width
uint32_t width

[in]: Input buffer width


  • _NV_ENC_EVENT_PARAMS
completionEvent
reserved
reserved1
reserved2
version
void* completionEvent

[in]: Handle to event to be registered/unregistered with the NvEncodeAPI interface.


  • _NV_ENC_EVENT_PARAMS
completionEvent
reserved
reserved1
reserved2
version
uint32_t reserved

[in]: Reserved and must be set to 0


  • _NV_ENC_EVENT_PARAMS
completionEvent
reserved
reserved1
reserved2
version
uint32_t reserved1[253]

[in]: Reserved and must be set to 0


  • _NV_ENC_EVENT_PARAMS
completionEvent
reserved
reserved1
reserved2
version
void* reserved2[64]

[in]: Reserved and must be set to NULL


  • _NV_ENC_EVENT_PARAMS
completionEvent
reserved
reserved1
reserved2
version
uint32_t version

[in]: Struct version. Must be set to NV_ENC_EVENT_PARAMS_VER.


  • _NV_ENC_H264_SEI_PAYLOAD
payload
payloadSize
payloadType
uint8_t* payload

[in] pointer to user data


  • _NV_ENC_H264_SEI_PAYLOAD
payload
payloadSize
payloadType
uint32_t payloadSize

[in] SEI payload size in bytes. SEI payload must be byte aligned, as described in Annex D


  • _NV_ENC_H264_SEI_PAYLOAD
payload
payloadSize
payloadType
uint32_t payloadType

[in] SEI payload types and syntax can be found in Annex D of the H.264 Specification.


  • _NV_ENC_INITIALIZE_PARAMS
darHeight
darWidth
enableEncodeAsync
enableExternalMEHints
enablePTD
enableSubFrameWrite
encodeConfig
encodeGUID
encodeHeight
encodeWidth
frameRateDen
frameRateNum
maxEncodeHeight
maxEncodeWidth
maxMEHintCountsPerBlock
presetGUID
privData
privDataSize
reportSliceOffsets
reserved
reserved2
reservedBitFields
version
uint32_t darHeight

[in]: Specifies the display aspect ratio height.


  • _NV_ENC_INITIALIZE_PARAMS
darHeight
darWidth
enableEncodeAsync
enableExternalMEHints
enablePTD
enableSubFrameWrite
encodeConfig
encodeGUID
encodeHeight
encodeWidth
frameRateDen
frameRateNum
maxEncodeHeight
maxEncodeWidth
maxMEHintCountsPerBlock
presetGUID
privData
privDataSize
reportSliceOffsets
reserved
reserved2
reservedBitFields
version
uint32_t darWidth

[in]: Specifies the display aspect ratio Width.


  • _NV_ENC_INITIALIZE_PARAMS
darHeight
darWidth
enableEncodeAsync
enableExternalMEHints
enablePTD
enableSubFrameWrite
encodeConfig
encodeGUID
encodeHeight
encodeWidth
frameRateDen
frameRateNum
maxEncodeHeight
maxEncodeWidth
maxMEHintCountsPerBlock
presetGUID
privData
privDataSize
reportSliceOffsets
reserved
reserved2
reservedBitFields
version
uint32_t enableEncodeAsync

[in]: Set this to 1 to enable asynchronous mode and is expected to use events to get picture completion notification.


  • _NV_ENC_INITIALIZE_PARAMS
darHeight
darWidth
enableEncodeAsync
enableExternalMEHints
enablePTD
enableSubFrameWrite
encodeConfig
encodeGUID
encodeHeight
encodeWidth
frameRateDen
frameRateNum
maxEncodeHeight
maxEncodeWidth
maxMEHintCountsPerBlock
presetGUID
privData
privDataSize
reportSliceOffsets
reserved
reserved2
reservedBitFields
version
uint32_t enableExternalMEHints

[in]: Set to 1 to enable external ME hints for the current frame. Currently this feature is supported only if NV_ENC_INITIALIZE_PARAMS::enablePTD to 0 orframeIntervalP = 1 (i.e no B frames).


  • _NV_ENC_INITIALIZE_PARAMS
darHeight
darWidth
enableEncodeAsync
enableExternalMEHints
enablePTD
enableSubFrameWrite
encodeConfig
encodeGUID
encodeHeight
encodeWidth
frameRateDen
frameRateNum
maxEncodeHeight
maxEncodeWidth
maxMEHintCountsPerBlock
presetGUID
privData
privDataSize
reportSliceOffsets
reserved
reserved2
reservedBitFields
version
uint32_t enablePTD

[in]: Set this to 1 to enable the Picture Type Decision is be taken by the NvEncodeAPI interface.


  • _NV_ENC_INITIALIZE_PARAMS
darHeight
darWidth
enableEncodeAsync
enableExternalMEHints
enablePTD
enableSubFrameWrite
encodeConfig
encodeGUID
encodeHeight
encodeWidth
frameRateDen
frameRateNum
maxEncodeHeight
maxEncodeWidth
maxMEHintCountsPerBlock
presetGUID
privData
privDataSize
reportSliceOffsets
reserved
reserved2
reservedBitFields
version
uint32_t enableSubFrameWrite

[in]: Set this to 1 to write out available bitstream to memory at subframe intervals


  • _NV_ENC_INITIALIZE_PARAMS
darHeight
darWidth
enableEncodeAsync
enableExternalMEHints
enablePTD
enableSubFrameWrite
encodeConfig
encodeGUID
encodeHeight
encodeWidth
frameRateDen
frameRateNum
maxEncodeHeight
maxEncodeWidth
maxMEHintCountsPerBlock
presetGUID
privData
privDataSize
reportSliceOffsets
reserved
reserved2
reservedBitFields
version
NV_ENC_CONFIG* encodeConfig

[in]: Specifies the advanced codec specific structure. If client has sent a valid codec config structure, it will override parameters set by the NV_ENC_INITIALIZE_PARAMS::presetGUID parameter. If set to NULL the NvEncodeAPI interface will use the NV_ENC_INITIALIZE_PARAMS::presetGUID to set the codec specific parameters. Client can also optionally query the NvEncodeAPI interface to get codec specific parameters for a presetGUID using NvEncGetEncodePresetConfig() API. It can then modify (if required) some of the codec config parameters and send down a custom config structure as part of _NV_ENC_INITIALIZE_PARAMS. Even in this case client is recommended to pass the same preset guid it has used in NvEncGetEncodePresetConfig() API to query the config structure; as NV_ENC_INITIALIZE_PARAMS::presetGUID. This will not override the custom config structure but will be used to determine other Encoder HW specific parameters not exposed in the API.


  • _NV_ENC_INITIALIZE_PARAMS
darHeight
darWidth
enableEncodeAsync
enableExternalMEHints
enablePTD
enableSubFrameWrite
encodeConfig
encodeGUID
encodeHeight
encodeWidth
frameRateDen
frameRateNum
maxEncodeHeight
maxEncodeWidth
maxMEHintCountsPerBlock
presetGUID
privData
privDataSize
reportSliceOffsets
reserved
reserved2
reservedBitFields
version
GUID encodeGUID

[in]: Specifies the Encode GUID for which the encoder is being created. NvEncInitializeEncoder() API will fail if this is not set, or set to unsupported value.


  • _NV_ENC_INITIALIZE_PARAMS
darHeight
darWidth
enableEncodeAsync
enableExternalMEHints
enablePTD
enableSubFrameWrite
encodeConfig
encodeGUID
encodeHeight
encodeWidth
frameRateDen
frameRateNum
maxEncodeHeight
maxEncodeWidth
maxMEHintCountsPerBlock
presetGUID
privData
privDataSize
reportSliceOffsets
reserved
reserved2
reservedBitFields
version
uint32_t encodeHeight

[in]: Specifies the encode height. If not set NvEncInitializeEncoder() API will fail.


  • _NV_ENC_INITIALIZE_PARAMS
darHeight
darWidth
enableEncodeAsync
enableExternalMEHints
enablePTD
enableSubFrameWrite
encodeConfig
encodeGUID
encodeHeight
encodeWidth
frameRateDen
frameRateNum
maxEncodeHeight
maxEncodeWidth
maxMEHintCountsPerBlock
presetGUID
privData
privDataSize
reportSliceOffsets
reserved
reserved2
reservedBitFields
version
uint32_t encodeWidth

[in]: Specifies the encode width. If not set NvEncInitializeEncoder() API will fail.


  • _NV_ENC_INITIALIZE_PARAMS
darHeight
darWidth
enableEncodeAsync
enableExternalMEHints
enablePTD
enableSubFrameWrite
encodeConfig
encodeGUID
encodeHeight
encodeWidth
frameRateDen
frameRateNum
maxEncodeHeight
maxEncodeWidth
maxMEHintCountsPerBlock
presetGUID
privData
privDataSize
reportSliceOffsets
reserved
reserved2
reservedBitFields
version
uint32_t frameRateDen

[in]: Specifies the denominator for frame rate used for encoding in frames per second ( Frame rate = frameRateNum / frameRateDen ).


  • _NV_ENC_INITIALIZE_PARAMS
darHeight
darWidth
enableEncodeAsync
enableExternalMEHints
enablePTD
enableSubFrameWrite
encodeConfig
encodeGUID
encodeHeight
encodeWidth
frameRateDen
frameRateNum
maxEncodeHeight
maxEncodeWidth
maxMEHintCountsPerBlock
presetGUID
privData
privDataSize
reportSliceOffsets
reserved
reserved2
reservedBitFields
version
uint32_t frameRateNum

[in]: Specifies the numerator for frame rate used for encoding in frames per second ( Frame rate = frameRateNum / frameRateDen ).


  • _NV_ENC_INITIALIZE_PARAMS
darHeight
darWidth
enableEncodeAsync
enableExternalMEHints
enablePTD
enableSubFrameWrite
encodeConfig
encodeGUID
encodeHeight
encodeWidth
frameRateDen
frameRateNum
maxEncodeHeight
maxEncodeWidth
maxMEHintCountsPerBlock
presetGUID
privData
privDataSize
reportSliceOffsets
reserved
reserved2
reservedBitFields
version
uint32_t maxEncodeHeight

[in]: Maximum encode height to be allowed for current Encode session. Client should allocate output buffers according to this dimension for dynamic resolution change. If set to 0, Encode will not allow dynamic resolution change.


  • _NV_ENC_INITIALIZE_PARAMS
darHeight
darWidth
enableEncodeAsync
enableExternalMEHints
enablePTD
enableSubFrameWrite
encodeConfig
encodeGUID
encodeHeight
encodeWidth
frameRateDen
frameRateNum
maxEncodeHeight
maxEncodeWidth
maxMEHintCountsPerBlock
presetGUID
privData
privDataSize
reportSliceOffsets
reserved
reserved2
reservedBitFields
version
uint32_t maxEncodeWidth

[in]: Maximum encode width to be used for current Encode session. Client should allocate output buffers according to this dimension for dynamic resolution change. If set to 0, Encoder will not allow dynamic resolution change.


  • _NV_ENC_INITIALIZE_PARAMS
darHeight
darWidth
enableEncodeAsync
enableExternalMEHints
enablePTD
enableSubFrameWrite
encodeConfig
encodeGUID
encodeHeight
encodeWidth
frameRateDen
frameRateNum
maxEncodeHeight
maxEncodeWidth
maxMEHintCountsPerBlock
presetGUID
privData
privDataSize
reportSliceOffsets
reserved
reserved2
reservedBitFields
version
NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE maxMEHintCountsPerBlock[2]

[in]: If Client wants to pass external motion vectors in NV_ENC_PIC_PARAMS::meExternalHints buffer it must specify the maximum number of hint candidates per block per direction for the encode session. The NV_ENC_INITIALIZE_PARAMS::maxMEHintCountsPerBlock[0] is for L0 predictors and NV_ENC_INITIALIZE_PARAMS::maxMEHintCountsPerBlock[1] is for L1 predictors. This client must also set NV_ENC_INITIALIZE_PARAMS::enableExternalMEHints to 1.


  • _NV_ENC_INITIALIZE_PARAMS
darHeight
darWidth
enableEncodeAsync
enableExternalMEHints
enablePTD
enableSubFrameWrite
encodeConfig
encodeGUID
encodeHeight
encodeWidth
frameRateDen
frameRateNum
maxEncodeHeight
maxEncodeWidth
maxMEHintCountsPerBlock
presetGUID
privData
privDataSize
reportSliceOffsets
reserved
reserved2
reservedBitFields
version
GUID presetGUID

[in]: Specifies the preset for encoding. If the preset GUID is set then , the preset configuration will be applied before any other parameter.


  • _NV_ENC_INITIALIZE_PARAMS
darHeight
darWidth
enableEncodeAsync
enableExternalMEHints
enablePTD
enableSubFrameWrite
encodeConfig
encodeGUID
encodeHeight
encodeWidth
frameRateDen
frameRateNum
maxEncodeHeight
maxEncodeWidth
maxMEHintCountsPerBlock
presetGUID
privData
privDataSize
reportSliceOffsets
reserved
reserved2
reservedBitFields
version
void* privData

[in]: Reserved private data buffer and must be set to NULL


  • _NV_ENC_INITIALIZE_PARAMS
darHeight
darWidth
enableEncodeAsync
enableExternalMEHints
enablePTD
enableSubFrameWrite
encodeConfig
encodeGUID
encodeHeight
encodeWidth
frameRateDen
frameRateNum
maxEncodeHeight
maxEncodeWidth
maxMEHintCountsPerBlock
presetGUID
privData
privDataSize
reportSliceOffsets
reserved
reserved2
reservedBitFields
version
uint32_t privDataSize

[in]: Reserved private data buffer size and must be set to 0


  • _NV_ENC_INITIALIZE_PARAMS
darHeight
darWidth
enableEncodeAsync
enableExternalMEHints
enablePTD
enableSubFrameWrite
encodeConfig
encodeGUID
encodeHeight
encodeWidth
frameRateDen
frameRateNum
maxEncodeHeight
maxEncodeWidth
maxMEHintCountsPerBlock
presetGUID
privData
privDataSize
reportSliceOffsets
reserved
reserved2
reservedBitFields
version
uint32_t reportSliceOffsets

[in]: Set this to 1 to enable reporting slice offsets in _NV_ENC_LOCK_BITSTREAM. NV_ENC_INITIALIZE_PARAMS::enableEncodeAsync must be set to 0 to use this feature. Client must set this to 0 if NV_ENC_CONFIG_H264::sliceMode is 1 on Kepler GPUs


  • _NV_ENC_INITIALIZE_PARAMS
darHeight
darWidth
enableEncodeAsync
enableExternalMEHints
enablePTD
enableSubFrameWrite
encodeConfig
encodeGUID
encodeHeight
encodeWidth
frameRateDen
frameRateNum
maxEncodeHeight
maxEncodeWidth
maxMEHintCountsPerBlock
presetGUID
privData
privDataSize
reportSliceOffsets
reserved
reserved2
reservedBitFields
version
uint32_t reserved[289]

[in]: Reserved and must be set to 0


  • _NV_ENC_INITIALIZE_PARAMS
darHeight
darWidth
enableEncodeAsync
enableExternalMEHints
enablePTD
enableSubFrameWrite
encodeConfig
encodeGUID
encodeHeight
encodeWidth
frameRateDen
frameRateNum
maxEncodeHeight
maxEncodeWidth
maxMEHintCountsPerBlock
presetGUID
privData
privDataSize
reportSliceOffsets
reserved
reserved2
reservedBitFields
version
void* reserved2[64]

[in]: Reserved and must be set to NULL


  • _NV_ENC_INITIALIZE_PARAMS
darHeight
darWidth
enableEncodeAsync
enableExternalMEHints
enablePTD
enableSubFrameWrite
encodeConfig
encodeGUID
encodeHeight
encodeWidth
frameRateDen
frameRateNum
maxEncodeHeight
maxEncodeWidth
maxMEHintCountsPerBlock
presetGUID
privData
privDataSize
reportSliceOffsets
reserved
reserved2
reservedBitFields
version
uint32_t reservedBitFields

[in]: Reserved bitfields and must be set to 0


  • _NV_ENC_INITIALIZE_PARAMS
darHeight
darWidth
enableEncodeAsync
enableExternalMEHints
enablePTD
enableSubFrameWrite
encodeConfig
encodeGUID
encodeHeight
encodeWidth
frameRateDen
frameRateNum
maxEncodeHeight
maxEncodeWidth
maxMEHintCountsPerBlock
presetGUID
privData
privDataSize
reportSliceOffsets
reserved
reserved2
reservedBitFields
version
uint32_t version

[in]: Struct version. Must be set to NV_ENC_INITIALIZE_PARAMS_VER.


  • _NV_ENC_LOCK_BITSTREAM
bitstreamBufferPtr
bitstreamSizeInBytes
doNotWait
frameAvgQP
frameIdx
frameSatd
hwEncodeStatus
ltrFrame
ltrFrameBitmap
ltrFrameIdx
numSlices
outputBitstream
outputDuration
outputTimeStamp
pictureStruct
pictureType
reserved
reserved2
reservedBitFields
sliceOffsets
version
void* bitstreamBufferPtr

[out]: Pointer to the generated output bitstream. Client should allocate sufficiently large buffer to hold the encoded output. Client is responsible for managing this memory.


  • _NV_ENC_LOCK_BITSTREAM
bitstreamBufferPtr
bitstreamSizeInBytes
doNotWait
frameAvgQP
frameIdx
frameSatd
hwEncodeStatus
ltrFrame
ltrFrameBitmap
ltrFrameIdx
numSlices
outputBitstream
outputDuration
outputTimeStamp
pictureStruct
pictureType
reserved
reserved2
reservedBitFields
sliceOffsets
version
uint32_t bitstreamSizeInBytes

[out]: Actual number of bytes generated and copied to the memory pointed by bitstreamBufferPtr.


  • _NV_ENC_LOCK_BITSTREAM
bitstreamBufferPtr
bitstreamSizeInBytes
doNotWait
frameAvgQP
frameIdx
frameSatd
hwEncodeStatus
ltrFrame
ltrFrameBitmap
ltrFrameIdx
numSlices
outputBitstream
outputDuration
outputTimeStamp
pictureStruct
pictureType
reserved
reserved2
reservedBitFields
sliceOffsets
version
uint32_t doNotWait

[in]: If this flag is set, the NvEncodeAPI interface will return buffer pointer even if operation is not completed. If not set, the call will block until operation completes.


  • _NV_ENC_LOCK_BITSTREAM
bitstreamBufferPtr
bitstreamSizeInBytes
doNotWait
frameAvgQP
frameIdx
frameSatd
hwEncodeStatus
ltrFrame
ltrFrameBitmap
ltrFrameIdx
numSlices
outputBitstream
outputDuration
outputTimeStamp
pictureStruct
pictureType
reserved
reserved2
reservedBitFields
sliceOffsets
version
uint32_t frameAvgQP

[out]: Average QP of the frame.


  • _NV_ENC_LOCK_BITSTREAM
bitstreamBufferPtr
bitstreamSizeInBytes
doNotWait
frameAvgQP
frameIdx
frameSatd
hwEncodeStatus
ltrFrame
ltrFrameBitmap
ltrFrameIdx
numSlices
outputBitstream
outputDuration
outputTimeStamp
pictureStruct
pictureType
reserved
reserved2
reservedBitFields
sliceOffsets
version
uint32_t frameIdx

[out]: Frame no. for which the bitstream is being retrieved.


  • _NV_ENC_LOCK_BITSTREAM
bitstreamBufferPtr
bitstreamSizeInBytes
doNotWait
frameAvgQP
frameIdx
frameSatd
hwEncodeStatus
ltrFrame
ltrFrameBitmap
ltrFrameIdx
numSlices
outputBitstream
outputDuration
outputTimeStamp
pictureStruct
pictureType
reserved
reserved2
reservedBitFields
sliceOffsets
version
uint32_t frameSatd

[out]: Total SATD cost for whole frame.


  • _NV_ENC_LOCK_BITSTREAM
bitstreamBufferPtr
bitstreamSizeInBytes
doNotWait
frameAvgQP
frameIdx
frameSatd
hwEncodeStatus
ltrFrame
ltrFrameBitmap
ltrFrameIdx
numSlices
outputBitstream
outputDuration
outputTimeStamp
pictureStruct
pictureType
reserved
reserved2
reservedBitFields
sliceOffsets
version
uint32_t hwEncodeStatus

[out]: The NvEncodeAPI interface status for the locked picture.


  • _NV_ENC_LOCK_BITSTREAM
bitstreamBufferPtr
bitstreamSizeInBytes
doNotWait
frameAvgQP
frameIdx
frameSatd
hwEncodeStatus
ltrFrame
ltrFrameBitmap
ltrFrameIdx
numSlices
outputBitstream
outputDuration
outputTimeStamp
pictureStruct
pictureType
reserved
reserved2
reservedBitFields
sliceOffsets
version
uint32_t ltrFrame

[out]: Flag indicating this frame is marked as LTR frame


  • _NV_ENC_LOCK_BITSTREAM
bitstreamBufferPtr
bitstreamSizeInBytes
doNotWait
frameAvgQP
frameIdx
frameSatd
hwEncodeStatus
ltrFrame
ltrFrameBitmap
ltrFrameIdx
numSlices
outputBitstream
outputDuration
outputTimeStamp
pictureStruct
pictureType
reserved
reserved2
reservedBitFields
sliceOffsets
version
uint32_t ltrFrameBitmap

[out]: Bitmap of LTR frames indices which were used for encoding this frame. Value of 0 if no LTR frames were used.


  • _NV_ENC_LOCK_BITSTREAM
bitstreamBufferPtr
bitstreamSizeInBytes
doNotWait
frameAvgQP
frameIdx
frameSatd
hwEncodeStatus
ltrFrame
ltrFrameBitmap
ltrFrameIdx
numSlices
outputBitstream
outputDuration
outputTimeStamp
pictureStruct
pictureType
reserved
reserved2
reservedBitFields
sliceOffsets
version
uint32_t ltrFrameIdx

[out]: Frame index associated with this LTR frame.


  • _NV_ENC_LOCK_BITSTREAM
bitstreamBufferPtr
bitstreamSizeInBytes
doNotWait
frameAvgQP
frameIdx
frameSatd
hwEncodeStatus
ltrFrame
ltrFrameBitmap
ltrFrameIdx
numSlices
outputBitstream
outputDuration
outputTimeStamp
pictureStruct
pictureType
reserved
reserved2
reservedBitFields
sliceOffsets
version
uint32_t numSlices

[out]: Number of slices in the encoded picture. Will be reported only if NV_ENC_INITIALIZE_PARAMS::reportSliceOffsets set to 1.


  • _NV_ENC_LOCK_BITSTREAM
bitstreamBufferPtr
bitstreamSizeInBytes
doNotWait
frameAvgQP
frameIdx
frameSatd
hwEncodeStatus
ltrFrame
ltrFrameBitmap
ltrFrameIdx
numSlices
outputBitstream
outputDuration
outputTimeStamp
pictureStruct
pictureType
reserved
reserved2
reservedBitFields
sliceOffsets
version
void* outputBitstream

[in]: Pointer to the bitstream buffer being locked.


  • _NV_ENC_LOCK_BITSTREAM
bitstreamBufferPtr
bitstreamSizeInBytes
doNotWait
frameAvgQP
frameIdx
frameSatd
hwEncodeStatus
ltrFrame
ltrFrameBitmap
ltrFrameIdx
numSlices
outputBitstream
outputDuration
outputTimeStamp
pictureStruct
pictureType
reserved
reserved2
reservedBitFields
sliceOffsets
version
uint64_t outputDuration

[out]: Presentation duration associates with the encoded output.


  • _NV_ENC_LOCK_BITSTREAM
bitstreamBufferPtr
bitstreamSizeInBytes
doNotWait
frameAvgQP
frameIdx
frameSatd
hwEncodeStatus
ltrFrame
ltrFrameBitmap
ltrFrameIdx
numSlices
outputBitstream
outputDuration
outputTimeStamp
pictureStruct
pictureType
reserved
reserved2
reservedBitFields
sliceOffsets
version
uint64_t outputTimeStamp

[out]: Presentation timestamp associated with the encoded output.


  • _NV_ENC_LOCK_BITSTREAM
bitstreamBufferPtr
bitstreamSizeInBytes
doNotWait
frameAvgQP
frameIdx
frameSatd
hwEncodeStatus
ltrFrame
ltrFrameBitmap
ltrFrameIdx
numSlices
outputBitstream
outputDuration
outputTimeStamp
pictureStruct
pictureType
reserved
reserved2
reservedBitFields
sliceOffsets
version
NV_ENC_PIC_STRUCT pictureStruct

[out]: Structure of the generated output picture.


  • _NV_ENC_LOCK_BITSTREAM
bitstreamBufferPtr
bitstreamSizeInBytes
doNotWait
frameAvgQP
frameIdx
frameSatd
hwEncodeStatus
ltrFrame
ltrFrameBitmap
ltrFrameIdx
numSlices
outputBitstream
outputDuration
outputTimeStamp
pictureStruct
pictureType
reserved
reserved2
reservedBitFields
sliceOffsets
version
NV_ENC_PIC_TYPE pictureType

[out]: Picture type of the encoded picture.


  • _NV_ENC_LOCK_BITSTREAM
bitstreamBufferPtr
bitstreamSizeInBytes
doNotWait
frameAvgQP
frameIdx
frameSatd
hwEncodeStatus
ltrFrame
ltrFrameBitmap
ltrFrameIdx
numSlices
outputBitstream
outputDuration
outputTimeStamp
pictureStruct
pictureType
reserved
reserved2
reservedBitFields
sliceOffsets
version
uint32_t reserved[236]

[in]: Reserved and must be set to 0


  • _NV_ENC_LOCK_BITSTREAM
bitstreamBufferPtr
bitstreamSizeInBytes
doNotWait
frameAvgQP
frameIdx
frameSatd
hwEncodeStatus
ltrFrame
ltrFrameBitmap
ltrFrameIdx
numSlices
outputBitstream
outputDuration
outputTimeStamp
pictureStruct
pictureType
reserved
reserved2
reservedBitFields
sliceOffsets
version
void* reserved2[64]

[in]: Reserved and must be set to NULL


  • _NV_ENC_LOCK_BITSTREAM
bitstreamBufferPtr
bitstreamSizeInBytes
doNotWait
frameAvgQP
frameIdx
frameSatd
hwEncodeStatus
ltrFrame
ltrFrameBitmap
ltrFrameIdx
numSlices
outputBitstream
outputDuration
outputTimeStamp
pictureStruct
pictureType
reserved
reserved2
reservedBitFields
sliceOffsets
version
uint32_t reservedBitFields

[in]: Reserved bit fields and must be set to 0


  • _NV_ENC_LOCK_BITSTREAM
bitstreamBufferPtr
bitstreamSizeInBytes
doNotWait
frameAvgQP
frameIdx
frameSatd
hwEncodeStatus
ltrFrame
ltrFrameBitmap
ltrFrameIdx
numSlices
outputBitstream
outputDuration
outputTimeStamp
pictureStruct
pictureType
reserved
reserved2
reservedBitFields
sliceOffsets
version
uint32_t* sliceOffsets

[in,out]: Array which receives the slice offsets. This is not supported if NV_ENC_CONFIG_H264::sliceMode is 1 on Kepler GPUs. Array size must be equal to size of frame in MBs.


  • _NV_ENC_LOCK_BITSTREAM
bitstreamBufferPtr
bitstreamSizeInBytes
doNotWait
frameAvgQP
frameIdx
frameSatd
hwEncodeStatus
ltrFrame
ltrFrameBitmap
ltrFrameIdx
numSlices
outputBitstream
outputDuration
outputTimeStamp
pictureStruct
pictureType
reserved
reserved2
reservedBitFields
sliceOffsets
version
uint32_t version

[in]: Struct version. Must be set to NV_ENC_LOCK_BITSTREAM_VER.


  • _NV_ENC_LOCK_INPUT_BUFFER
bufferDataPtr
doNotWait
inputBuffer
pitch
reserved1
reserved2
reservedBitFields
version
void* bufferDataPtr

[out]: Pointed to the locked input buffer data. Client can only access input buffer using the bufferDataPtr.


  • _NV_ENC_LOCK_INPUT_BUFFER
bufferDataPtr
doNotWait
inputBuffer
pitch
reserved1
reserved2
reservedBitFields
version
uint32_t doNotWait

[in]: Set to 1 to make NvEncLockInputBuffer() a unblocking call. If the encoding is not completed, driver will return NV_ENC_ERR_ENCODER_BUSY error code.


  • _NV_ENC_LOCK_INPUT_BUFFER
bufferDataPtr
doNotWait
inputBuffer
pitch
reserved1
reserved2
reservedBitFields
version
NV_ENC_INPUT_PTR inputBuffer

[in]: Pointer to the input buffer to be locked, client should pass the pointer obtained from NvEncCreateInputBuffer() or NvEncMapInputResource API.


  • _NV_ENC_LOCK_INPUT_BUFFER
bufferDataPtr
doNotWait
inputBuffer
pitch
reserved1
reserved2
reservedBitFields
version
uint32_t pitch

[out]: Pitch of the locked input buffer.


  • _NV_ENC_LOCK_INPUT_BUFFER
bufferDataPtr
doNotWait
inputBuffer
pitch
reserved1
reserved2
reservedBitFields
version
uint32_t reserved1[251]

[in]: Reserved and must be set to 0


  • _NV_ENC_LOCK_INPUT_BUFFER
bufferDataPtr
doNotWait
inputBuffer
pitch
reserved1
reserved2
reservedBitFields
version
void* reserved2[64]

[in]: Reserved and must be set to NULL


  • _NV_ENC_LOCK_INPUT_BUFFER
bufferDataPtr
doNotWait
inputBuffer
pitch
reserved1
reserved2
reservedBitFields
version
uint32_t reservedBitFields

[in]: Reserved bitfields and must be set to 0


  • _NV_ENC_LOCK_INPUT_BUFFER
bufferDataPtr
doNotWait
inputBuffer
pitch
reserved1
reserved2
reservedBitFields
version
uint32_t version

[in]: Struct version. Must be set to NV_ENC_LOCK_INPUT_BUFFER_VER.


  • _NV_ENC_MAP_INPUT_RESOURCE
inputResource
mappedBufferFmt
mappedResource
registeredResource
reserved1
reserved2
subResourceIndex
version
void* inputResource

[in]: Deprecated. Do not use.


  • _NV_ENC_MAP_INPUT_RESOURCE
inputResource
mappedBufferFmt
mappedResource
registeredResource
reserved1
reserved2
subResourceIndex
version
NV_ENC_BUFFER_FORMAT mappedBufferFmt

[out]: Buffer format of the outputResource. This buffer format must be used in NV_ENC_PIC_PARAMS::bufferFmt if client using the above mapped resource pointer.


  • _NV_ENC_MAP_INPUT_RESOURCE
inputResource
mappedBufferFmt
mappedResource
registeredResource
reserved1
reserved2
subResourceIndex
version
NV_ENC_INPUT_PTR mappedResource

[out]: Mapped pointer corresponding to the registeredResource. This pointer must be used in NV_ENC_PIC_PARAMS::inputBuffer parameter in NvEncEncodePicture() API.


  • _NV_ENC_MAP_INPUT_RESOURCE
inputResource
mappedBufferFmt
mappedResource
registeredResource
reserved1
reserved2
subResourceIndex
version
NV_ENC_REGISTERED_PTR registeredResource

[in]: The Registered resource handle obtained by calling NvEncRegisterInputResource.


  • _NV_ENC_MAP_INPUT_RESOURCE
inputResource
mappedBufferFmt
mappedResource
registeredResource
reserved1
reserved2
subResourceIndex
version
uint32_t reserved1[251]

[in]: Reserved and must be set to 0.


  • _NV_ENC_MAP_INPUT_RESOURCE
inputResource
mappedBufferFmt
mappedResource
registeredResource
reserved1
reserved2
subResourceIndex
version
void* reserved2[63]

[in]: Reserved and must be set to NULL


  • _NV_ENC_MAP_INPUT_RESOURCE
inputResource
mappedBufferFmt
mappedResource
registeredResource
reserved1
reserved2
subResourceIndex
version
uint32_t subResourceIndex

[in]: Deprecated. Do not use.


  • _NV_ENC_MAP_INPUT_RESOURCE
inputResource
mappedBufferFmt
mappedResource
registeredResource
reserved1
reserved2
subResourceIndex
version
uint32_t version

[in]: Struct version. Must be set to NV_ENC_MAP_INPUT_RESOURCE_VER.


  • _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS
apiVersion
device
deviceType
reserved
reserved1
reserved2
version
uint32_t apiVersion

[in]: API version. Should be set to NVENCAPI_VERSION.


  • _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS
apiVersion
device
deviceType
reserved
reserved1
reserved2
version
void* device

[in]: Pointer to client device.


  • _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS
apiVersion
device
deviceType
reserved
reserved1
reserved2
version
NV_ENC_DEVICE_TYPE deviceType

[in]: Specified the device Type


  • _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS
apiVersion
device
deviceType
reserved
reserved1
reserved2
version
void* reserved

[in]: Reserved and must be set to 0.


  • _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS
apiVersion
device
deviceType
reserved
reserved1
reserved2
version
uint32_t reserved1[253]

[in]: Reserved and must be set to 0


  • _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS
apiVersion
device
deviceType
reserved
reserved1
reserved2
version
void* reserved2[64]

[in]: Reserved and must be set to NULL


  • _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS
apiVersion
device
deviceType
reserved
reserved1
reserved2
version
uint32_t version

[in]: Struct version. Must be set to NV_ENC_OPEN_ENCODE_SESSION_EX_PARAMS_VER.


  • _NV_ENC_PIC_PARAMS
bufferFmt
codecPicParams
completionEvent
encodePicFlags
frameIdx
inputBuffer
inputDuration
inputHeight
inputPitch
inputTimeStamp
inputWidth
meExternalHints
meHintCountsPerBlock
outputBitstream
pictureStruct
pictureType
qpDeltaMap
qpDeltaMapSize
reserved1
reserved2
reserved3
reserved4
reservedBitFields
version
NV_ENC_BUFFER_FORMAT bufferFmt

[in]: Specifies the input buffer format.


  • _NV_ENC_PIC_PARAMS
bufferFmt
codecPicParams
completionEvent
encodePicFlags
frameIdx
inputBuffer
inputDuration
inputHeight
inputPitch
inputTimeStamp
inputWidth
meExternalHints
meHintCountsPerBlock
outputBitstream
pictureStruct
pictureType
qpDeltaMap
qpDeltaMapSize
reserved1
reserved2
reserved3
reserved4
reservedBitFields
version
NV_ENC_CODEC_PIC_PARAMS codecPicParams

[in]: Specifies the codec specific per-picture encoding parameters.


  • _NV_ENC_PIC_PARAMS
bufferFmt
codecPicParams
completionEvent
encodePicFlags
frameIdx
inputBuffer
inputDuration
inputHeight
inputPitch
inputTimeStamp
inputWidth
meExternalHints
meHintCountsPerBlock
outputBitstream
pictureStruct
pictureType
qpDeltaMap
qpDeltaMapSize
reserved1
reserved2
reserved3
reserved4
reservedBitFields
version
void* completionEvent

[in]: Specifies an event to be signalled on completion of encoding of this Frame [only if operating in Asynchronous mode]. Each output buffer should be associated with a distinct event pointer.


  • _NV_ENC_PIC_PARAMS
bufferFmt
codecPicParams
completionEvent
encodePicFlags
frameIdx
inputBuffer
inputDuration
inputHeight
inputPitch
inputTimeStamp
inputWidth
meExternalHints
meHintCountsPerBlock
outputBitstream
pictureStruct
pictureType
qpDeltaMap
qpDeltaMapSize
reserved1
reserved2
reserved3
reserved4
reservedBitFields
version
uint32_t encodePicFlags

[in]: Specifies bit-wise OR`ed encode pic flags. See NV_ENC_PIC_FLAGS enum.


  • _NV_ENC_PIC_PARAMS
bufferFmt
codecPicParams
completionEvent
encodePicFlags
frameIdx
inputBuffer
inputDuration
inputHeight
inputPitch
inputTimeStamp
inputWidth
meExternalHints
meHintCountsPerBlock
outputBitstream
pictureStruct
pictureType
qpDeltaMap
qpDeltaMapSize
reserved1
reserved2
reserved3
reserved4
reservedBitFields
version
uint32_t frameIdx

[in]: Specifies the frame index associated with the input frame [optional].


  • _NV_ENC_PIC_PARAMS
bufferFmt
codecPicParams
completionEvent
encodePicFlags
frameIdx
inputBuffer
inputDuration
inputHeight
inputPitch
inputTimeStamp
inputWidth
meExternalHints
meHintCountsPerBlock
outputBitstream
pictureStruct
pictureType
qpDeltaMap
qpDeltaMapSize
reserved1
reserved2
reserved3
reserved4
reservedBitFields
version
NV_ENC_INPUT_PTR inputBuffer

[in]: Specifies the input buffer pointer. Client must use a pointer obtained from NvEncCreateInputBuffer() or NvEncMapInputResource() APIs.


  • _NV_ENC_PIC_PARAMS
bufferFmt
codecPicParams
completionEvent
encodePicFlags
frameIdx
inputBuffer
inputDuration
inputHeight
inputPitch
inputTimeStamp
inputWidth
meExternalHints
meHintCountsPerBlock
outputBitstream
pictureStruct
pictureType
qpDeltaMap
qpDeltaMapSize
reserved1
reserved2
reserved3
reserved4
reservedBitFields
version
uint64_t inputDuration

[in]: Specifies duration of the input picture


  • _NV_ENC_PIC_PARAMS
bufferFmt
codecPicParams
completionEvent
encodePicFlags
frameIdx
inputBuffer
inputDuration
inputHeight
inputPitch
inputTimeStamp
inputWidth
meExternalHints
meHintCountsPerBlock
outputBitstream
pictureStruct
pictureType
qpDeltaMap
qpDeltaMapSize
reserved1
reserved2
reserved3
reserved4
reservedBitFields
version
uint32_t inputHeight

[in]: Specifies the input buffer height


  • _NV_ENC_PIC_PARAMS
bufferFmt
codecPicParams
completionEvent
encodePicFlags
frameIdx
inputBuffer
inputDuration
inputHeight
inputPitch
inputTimeStamp
inputWidth
meExternalHints
meHintCountsPerBlock
outputBitstream
pictureStruct
pictureType
qpDeltaMap
qpDeltaMapSize
reserved1
reserved2
reserved3
reserved4
reservedBitFields
version
uint32_t inputPitch

[in]: Specifies the input buffer pitch. If pitch value is not known, set this to inputWidth.


  • _NV_ENC_PIC_PARAMS
bufferFmt
codecPicParams
completionEvent
encodePicFlags
frameIdx
inputBuffer
inputDuration
inputHeight
inputPitch
inputTimeStamp
inputWidth
meExternalHints
meHintCountsPerBlock
outputBitstream
pictureStruct
pictureType
qpDeltaMap
qpDeltaMapSize
reserved1
reserved2
reserved3
reserved4
reservedBitFields
version
uint64_t inputTimeStamp

[in]: Specifies presentation timestamp associated with the input picture.


  • _NV_ENC_PIC_PARAMS
bufferFmt
codecPicParams
completionEvent
encodePicFlags
frameIdx
inputBuffer
inputDuration
inputHeight
inputPitch
inputTimeStamp
inputWidth
meExternalHints
meHintCountsPerBlock
outputBitstream
pictureStruct
pictureType
qpDeltaMap
qpDeltaMapSize
reserved1
reserved2
reserved3
reserved4
reservedBitFields
version
uint32_t inputWidth

[in]: Specifies the input buffer width


  • _NV_ENC_PIC_PARAMS
bufferFmt
codecPicParams
completionEvent
encodePicFlags
frameIdx
inputBuffer
inputDuration
inputHeight
inputPitch
inputTimeStamp
inputWidth
meExternalHints
meHintCountsPerBlock
outputBitstream
pictureStruct
pictureType
qpDeltaMap
qpDeltaMapSize
reserved1
reserved2
reserved3
reserved4
reservedBitFields
version
NVENC_EXTERNAL_ME_HINT* meExternalHints

[in]: Specifies the pointer to ME external hints for the current frame. The size of ME hint buffer should be equal to number of macroblocks multiplied by the total number of candidates per macroblock. The total number of candidates per MB per direction = 1*meHintCountsPerBlock[Lx].numCandsPerBlk16x16 + 2*meHintCountsPerBlock[Lx].numCandsPerBlk16x8 + 2*meHintCountsPerBlock[Lx].numCandsPerBlk8x8

  • 4*meHintCountsPerBlock[Lx].numCandsPerBlk8x8. For frames using bidirectional ME , the total number of candidates for single macroblock is sum of total number of candidates per MB for each direction (L0 and L1)


  • _NV_ENC_PIC_PARAMS
bufferFmt
codecPicParams
completionEvent
encodePicFlags
frameIdx
inputBuffer
inputDuration
inputHeight
inputPitch
inputTimeStamp
inputWidth
meExternalHints
meHintCountsPerBlock
outputBitstream
pictureStruct
pictureType
qpDeltaMap
qpDeltaMapSize
reserved1
reserved2
reserved3
reserved4
reservedBitFields
version
NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE meHintCountsPerBlock[2]

[in]: Specifies the number of hint candidates per block per direction for the current frame. meHintCountsPerBlock[0] is for L0 predictors and meHintCountsPerBlock[1] is for L1 predictors. The candidate count in NV_ENC_PIC_PARAMS::meHintCountsPerBlock[lx] must never exceed NV_ENC_INITIALIZE_PARAMS::maxMEHintCountsPerBlock[lx] provided during encoder intialization.


  • _NV_ENC_PIC_PARAMS
bufferFmt
codecPicParams
completionEvent
encodePicFlags
frameIdx
inputBuffer
inputDuration
inputHeight
inputPitch
inputTimeStamp
inputWidth
meExternalHints
meHintCountsPerBlock
outputBitstream
pictureStruct
pictureType
qpDeltaMap
qpDeltaMapSize
reserved1
reserved2
reserved3
reserved4
reservedBitFields
version
NV_ENC_OUTPUT_PTR outputBitstream

[in]: Specifies the pointer to output buffer. Client should use a pointer obtained from NvEncCreateBitstreamBuffer() API.


  • _NV_ENC_PIC_PARAMS
bufferFmt
codecPicParams
completionEvent
encodePicFlags
frameIdx
inputBuffer
inputDuration
inputHeight
inputPitch
inputTimeStamp
inputWidth
meExternalHints
meHintCountsPerBlock
outputBitstream
pictureStruct
pictureType
qpDeltaMap
qpDeltaMapSize
reserved1
reserved2
reserved3
reserved4
reservedBitFields
version
NV_ENC_PIC_STRUCT pictureStruct

[in]: Specifies structure of the input picture.


  • _NV_ENC_PIC_PARAMS
bufferFmt
codecPicParams
completionEvent
encodePicFlags
frameIdx
inputBuffer
inputDuration
inputHeight
inputPitch
inputTimeStamp
inputWidth
meExternalHints
meHintCountsPerBlock
outputBitstream
pictureStruct
pictureType
qpDeltaMap
qpDeltaMapSize
reserved1
reserved2
reserved3
reserved4
reservedBitFields
version
NV_ENC_PIC_TYPE pictureType

[in]: Specifies input picture type. Client required to be set explicitly by the client if the client has not set NV_ENC_INITALIZE_PARAMS::enablePTD to 1 while calling NvInitializeEncoder.


  • _NV_ENC_PIC_PARAMS
bufferFmt
codecPicParams
completionEvent
encodePicFlags
frameIdx
inputBuffer
inputDuration
inputHeight
inputPitch
inputTimeStamp
inputWidth
meExternalHints
meHintCountsPerBlock
outputBitstream
pictureStruct
pictureType
qpDeltaMap
qpDeltaMapSize
reserved1
reserved2
reserved3
reserved4
reservedBitFields
version
int8_t* qpDeltaMap

[in]: Specifies the pointer to signed byte array containing QP delta value per MB in raster scan order in the current picture. This QP modifier is applied on top of the QP chosen by rate control.


  • _NV_ENC_PIC_PARAMS
bufferFmt
codecPicParams
completionEvent
encodePicFlags
frameIdx
inputBuffer
inputDuration
inputHeight
inputPitch
inputTimeStamp
inputWidth
meExternalHints
meHintCountsPerBlock
outputBitstream
pictureStruct
pictureType
qpDeltaMap
qpDeltaMapSize
reserved1
reserved2
reserved3
reserved4
reservedBitFields
version
uint32_t qpDeltaMapSize

[in]: Specifies the size in bytes of qpDeltaMap surface allocated by client and pointed to by NV_ENC_PIC_PARAMS::qpDeltaMap. Surface (array) should be picWidthInMbs * picHeightInMbs


  • _NV_ENC_PIC_PARAMS
bufferFmt
codecPicParams
completionEvent
encodePicFlags
frameIdx
inputBuffer
inputDuration
inputHeight
inputPitch
inputTimeStamp
inputWidth
meExternalHints
meHintCountsPerBlock
outputBitstream
pictureStruct
pictureType
qpDeltaMap
qpDeltaMapSize
reserved1
reserved2
reserved3
reserved4
reservedBitFields
version
uint32_t reserved1[6]

[in]: Reserved and must be set to 0


  • _NV_ENC_PIC_PARAMS
bufferFmt
codecPicParams
completionEvent
encodePicFlags
frameIdx
inputBuffer
inputDuration
inputHeight
inputPitch
inputTimeStamp
inputWidth
meExternalHints
meHintCountsPerBlock
outputBitstream
pictureStruct
pictureType
qpDeltaMap
qpDeltaMapSize
reserved1
reserved2
reserved3
reserved4
reservedBitFields
version
void* reserved2[2]

[in]: Reserved and must be set to NULL


  • _NV_ENC_PIC_PARAMS
bufferFmt
codecPicParams
completionEvent
encodePicFlags
frameIdx
inputBuffer
inputDuration
inputHeight
inputPitch
inputTimeStamp
inputWidth
meExternalHints
meHintCountsPerBlock
outputBitstream
pictureStruct
pictureType
qpDeltaMap
qpDeltaMapSize
reserved1
reserved2
reserved3
reserved4
reservedBitFields
version
uint32_t reserved3[287]

[in]: Reserved and must be set to 0


  • _NV_ENC_PIC_PARAMS
bufferFmt
codecPicParams
completionEvent
encodePicFlags
frameIdx
inputBuffer
inputDuration
inputHeight
inputPitch
inputTimeStamp
inputWidth
meExternalHints
meHintCountsPerBlock
outputBitstream
pictureStruct
pictureType
qpDeltaMap
qpDeltaMapSize
reserved1
reserved2
reserved3
reserved4
reservedBitFields
version
void* reserved4[60]

[in]: Reserved and must be set to NULL


  • _NV_ENC_PIC_PARAMS
bufferFmt
codecPicParams
completionEvent
encodePicFlags
frameIdx
inputBuffer
inputDuration
inputHeight
inputPitch
inputTimeStamp
inputWidth
meExternalHints
meHintCountsPerBlock
outputBitstream
pictureStruct
pictureType
qpDeltaMap
qpDeltaMapSize
reserved1
reserved2
reserved3
reserved4
reservedBitFields
version
uint32_t reservedBitFields

[in]: Reserved bitfields and must be set to 0


  • _NV_ENC_PIC_PARAMS
bufferFmt
codecPicParams
completionEvent
encodePicFlags
frameIdx
inputBuffer
inputDuration
inputHeight
inputPitch
inputTimeStamp
inputWidth
meExternalHints
meHintCountsPerBlock
outputBitstream
pictureStruct
pictureType
qpDeltaMap
qpDeltaMapSize
reserved1
reserved2
reserved3
reserved4
reservedBitFields
version
uint32_t version

[in]: Struct version. Must be set to NV_ENC_PIC_PARAMS_VER.


  • _NV_ENC_PIC_PARAMS_H264
colourPlaneId
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reserved3
reservedBitFields
seiPayloadArray
seiPayloadArrayCnt
sliceMode
sliceModeData
sliceModeDataUpdate
uint32_t colourPlaneId

[in]: Specifies the colour plane ID associated with the current input.


  • _NV_ENC_PIC_PARAMS_H264
colourPlaneId
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reserved3
reservedBitFields
seiPayloadArray
seiPayloadArrayCnt
sliceMode
sliceModeData
sliceModeDataUpdate
uint32_t constrainedFrame

[in]: Set to 1 if client wants to encode this frame with each slice completely independent of other slices in the frame. NV_ENC_INITIALIZE_PARAMS::enableConstrainedEncoding should be set to 1


  • _NV_ENC_PIC_PARAMS_H264
colourPlaneId
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reserved3
reservedBitFields
seiPayloadArray
seiPayloadArrayCnt
sliceMode
sliceModeData
sliceModeDataUpdate
uint32_t displayPOCSyntax

[in]: Specifies the display POC syntax This is required to be set if client is handling the picture type decision.


  • _NV_ENC_PIC_PARAMS_H264
colourPlaneId
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reserved3
reservedBitFields
seiPayloadArray
seiPayloadArrayCnt
sliceMode
sliceModeData
sliceModeDataUpdate
uint32_t forceIntraRefreshWithFrameCnt

[in]: Forces an intra refresh with duration equal to intraRefreshFrameCnt. When outputRecoveryPointSEI is set this is value is used for recovery_frame_cnt in recovery point SEI message forceIntraRefreshWithFrameCnt cannot be used if B frames are used in the GOP structure specified


  • _NV_ENC_PIC_PARAMS_H264
colourPlaneId
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reserved3
reservedBitFields
seiPayloadArray
seiPayloadArrayCnt
sliceMode
sliceModeData
sliceModeDataUpdate
uint32_t ltrMarkFrame

[in]: Set to 1 if client wants to mark this frame as LTR


  • _NV_ENC_PIC_PARAMS_H264
colourPlaneId
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reserved3
reservedBitFields
seiPayloadArray
seiPayloadArrayCnt
sliceMode
sliceModeData
sliceModeDataUpdate
uint32_t ltrMarkFrameIdx

[in]: Specifies the long term referenceframe index to use for marking this frame as LTR.


  • _NV_ENC_PIC_PARAMS_H264
colourPlaneId
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reserved3
reservedBitFields
seiPayloadArray
seiPayloadArrayCnt
sliceMode
sliceModeData
sliceModeDataUpdate
uint32_t ltrUsageMode

[in]: Specifies additional usage constraints for encoding using LTR frames from this point further. 0: no constraints, 1: no short term refs older than current, no previous LTR frames.


  • _NV_ENC_PIC_PARAMS_H264
colourPlaneId
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reserved3
reservedBitFields
seiPayloadArray
seiPayloadArrayCnt
sliceMode
sliceModeData
sliceModeDataUpdate
uint32_t ltrUseFrameBitmap

[in]: Specifies the the associated bitmap of LTR frame indices when encoding this frame.


  • _NV_ENC_PIC_PARAMS_H264
colourPlaneId
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reserved3
reservedBitFields
seiPayloadArray
seiPayloadArrayCnt
sliceMode
sliceModeData
sliceModeDataUpdate
uint32_t ltrUseFrames

[in]: Set to 1 if client allows encoding this frame using the LTR frames specified in ltrFrameBitmap


  • _NV_ENC_PIC_PARAMS_H264
colourPlaneId
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reserved3
reservedBitFields
seiPayloadArray
seiPayloadArrayCnt
sliceMode
sliceModeData
sliceModeDataUpdate
uint32_t refPicFlag

[in]: Set to 1 for a reference picture. This is ignored if NV_ENC_INITIALIZE_PARAMS::enablePTD is set to 1.


  • _NV_ENC_PIC_PARAMS_H264
colourPlaneId
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reserved3
reservedBitFields
seiPayloadArray
seiPayloadArrayCnt
sliceMode
sliceModeData
sliceModeDataUpdate
uint32_t reserved[243]

[in]: Reserved and must be set to 0.


  • _NV_ENC_PIC_PARAMS_H264
colourPlaneId
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reserved3
reservedBitFields
seiPayloadArray
seiPayloadArrayCnt
sliceMode
sliceModeData
sliceModeDataUpdate
void* reserved2[62]

[in]: Reserved and must be set to NULL.


  • _NV_ENC_PIC_PARAMS_H264
colourPlaneId
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reserved3
reservedBitFields
seiPayloadArray
seiPayloadArrayCnt
sliceMode
sliceModeData
sliceModeDataUpdate
uint32_t reserved3

[in]: Reserved and must be set to 0


  • _NV_ENC_PIC_PARAMS_H264
colourPlaneId
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reserved3
reservedBitFields
seiPayloadArray
seiPayloadArrayCnt
sliceMode
sliceModeData
sliceModeDataUpdate
uint32_t reservedBitFields

[in]: Reserved bit fields and must be set to 0


  • _NV_ENC_PIC_PARAMS_H264
colourPlaneId
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reserved3
reservedBitFields
seiPayloadArray
seiPayloadArrayCnt
sliceMode
sliceModeData
sliceModeDataUpdate
NV_ENC_H264_SEI_PAYLOAD* seiPayloadArray

[in]: Array of SEI payloads which will be inserted for this frame.


  • _NV_ENC_PIC_PARAMS_H264
colourPlaneId
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reserved3
reservedBitFields
seiPayloadArray
seiPayloadArrayCnt
sliceMode
sliceModeData
sliceModeDataUpdate
uint32_t seiPayloadArrayCnt

[in]: Specifies the number of elements allocated in seiPayloadArray array.


  • _NV_ENC_PIC_PARAMS_H264
colourPlaneId
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reserved3
reservedBitFields
seiPayloadArray
seiPayloadArrayCnt
sliceMode
sliceModeData
sliceModeDataUpdate
uint32_t sliceMode

[in]: This parameter in conjunction with sliceModeData specifies the way in which the picture is divided into slices sliceMode = 0 MB based slices, sliceMode = 1 Byte based slices, sliceMode = 2 MB row based slices, sliceMode = 3, numSlices in Picture When forceIntraRefreshWithFrameCnt is set it will have priority over sliceMode setting When sliceMode == 0 and sliceModeData == 0 whole picture will be coded with one slice


  • _NV_ENC_PIC_PARAMS_H264
colourPlaneId
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reserved3
reservedBitFields
seiPayloadArray
seiPayloadArrayCnt
sliceMode
sliceModeData
sliceModeDataUpdate
uint32_t sliceModeData

[in]: Specifies the parameter needed for sliceMode. For: sliceMode = 0, sliceModeData specifies # of MBs in each slice (except last slice) sliceMode = 1, sliceModeData specifies maximum # of bytes in each slice (except last slice) sliceMode = 2, sliceModeData specifies # of MB rows in each slice (except last slice) sliceMode = 3, sliceModeData specifies number of slices in the picture. Driver will divide picture into slices optimally


  • _NV_ENC_PIC_PARAMS_H264
colourPlaneId
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reserved3
reservedBitFields
seiPayloadArray
seiPayloadArrayCnt
sliceMode
sliceModeData
sliceModeDataUpdate
uint32_t sliceModeDataUpdate

[in]: Set to 1 if client wants to change the sliceModeData field to specify new sliceSize Parameter When forceIntraRefreshWithFrameCnt is set it will have priority over sliceMode setting


  • _NV_ENC_PIC_PARAMS_H264
colourPlaneId
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reserved3
reservedBitFields
seiPayloadArray
seiPayloadArrayCnt
sliceMode
sliceModeData
sliceModeDataUpdate


  • _NV_ENC_PIC_PARAMS_HEVC
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reservedBitFields
sliceMode
sliceModeData
sliceModeDataUpdate
sliceTypeArrayCnt
sliceTypeData
temporalId
uint32_t constrainedFrame

[in]: Set to 1 if client wants to encode this frame with each slice completely independent of other slices in the frame. NV_ENC_INITIALIZE_PARAMS::enableConstrainedEncoding should be set to 1


  • _NV_ENC_PIC_PARAMS_HEVC
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reservedBitFields
sliceMode
sliceModeData
sliceModeDataUpdate
sliceTypeArrayCnt
sliceTypeData
temporalId
uint32_t displayPOCSyntax

[in]: Specifies the display POC syntax This is required to be set if client is handling the picture type decision.


  • _NV_ENC_PIC_PARAMS_HEVC
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reservedBitFields
sliceMode
sliceModeData
sliceModeDataUpdate
sliceTypeArrayCnt
sliceTypeData
temporalId
uint32_t forceIntraRefreshWithFrameCnt

[in]: Forces an intra refresh with duration equal to intraRefreshFrameCnt. When outputRecoveryPointSEI is set this is value is used for recovery_frame_cnt in recovery point SEI message forceIntraRefreshWithFrameCnt cannot be used if B frames are used in the GOP structure specified


  • _NV_ENC_PIC_PARAMS_HEVC
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reservedBitFields
sliceMode
sliceModeData
sliceModeDataUpdate
sliceTypeArrayCnt
sliceTypeData
temporalId
uint32_t ltrMarkFrame

[in]: Set to 1 if client wants to mark this frame as LTR


  • _NV_ENC_PIC_PARAMS_HEVC
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reservedBitFields
sliceMode
sliceModeData
sliceModeDataUpdate
sliceTypeArrayCnt
sliceTypeData
temporalId
uint32_t ltrMarkFrameIdx

[in]: Specifies the long term referenceframe index to use for marking this frame as LTR.


  • _NV_ENC_PIC_PARAMS_HEVC
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reservedBitFields
sliceMode
sliceModeData
sliceModeDataUpdate
sliceTypeArrayCnt
sliceTypeData
temporalId
uint32_t ltrUsageMode

[in]: Specifies additional usage constraints for encoding using LTR frames from this point further. 0: no constraints, 1: no short term refs older than current, no previous LTR frames.


  • _NV_ENC_PIC_PARAMS_HEVC
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reservedBitFields
sliceMode
sliceModeData
sliceModeDataUpdate
sliceTypeArrayCnt
sliceTypeData
temporalId
uint32_t ltrUseFrameBitmap

[in]: Specifies the the associated bitmap of LTR frame indices when encoding this frame.


  • _NV_ENC_PIC_PARAMS_HEVC
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reservedBitFields
sliceMode
sliceModeData
sliceModeDataUpdate
sliceTypeArrayCnt
sliceTypeData
temporalId
uint32_t ltrUseFrames

[in]: Set to 1 if client allows encoding this frame using the LTR frames specified in ltrFrameBitmap


  • _NV_ENC_PIC_PARAMS_HEVC
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reservedBitFields
sliceMode
sliceModeData
sliceModeDataUpdate
sliceTypeArrayCnt
sliceTypeData
temporalId
uint32_t refPicFlag

[in]: Set to 1 for a reference picture. This is ignored if NV_ENC_INITIALIZE_PARAMS::enablePTD is set to 1.


  • _NV_ENC_PIC_PARAMS_HEVC
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reservedBitFields
sliceMode
sliceModeData
sliceModeDataUpdate
sliceTypeArrayCnt
sliceTypeData
temporalId
uint32_t reserved[246]

[in]: Reserved and must be set to 0.


  • _NV_ENC_PIC_PARAMS_HEVC
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reservedBitFields
sliceMode
sliceModeData
sliceModeDataUpdate
sliceTypeArrayCnt
sliceTypeData
temporalId
void* reserved2[62]

[in]: Reserved and must be set to NULL.


  • _NV_ENC_PIC_PARAMS_HEVC
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reservedBitFields
sliceMode
sliceModeData
sliceModeDataUpdate
sliceTypeArrayCnt
sliceTypeData
temporalId
uint32_t reservedBitFields

[in]: Reserved bit fields and must be set to 0


  • _NV_ENC_PIC_PARAMS_HEVC
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reservedBitFields
sliceMode
sliceModeData
sliceModeDataUpdate
sliceTypeArrayCnt
sliceTypeData
temporalId
uint32_t sliceMode

[in]: This parameter in conjunction with sliceModeData specifies the way in which the picture is divided into slices sliceMode = 0 CTU based slices, sliceMode = 1 Byte based slices, sliceMode = 2 CTU row based slices, sliceMode = 3, numSlices in Picture When forceIntraRefreshWithFrameCnt is set it will have priority over sliceMode setting When sliceMode == 0 and sliceModeData == 0 whole picture will be coded with one slice


  • _NV_ENC_PIC_PARAMS_HEVC
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reservedBitFields
sliceMode
sliceModeData
sliceModeDataUpdate
sliceTypeArrayCnt
sliceTypeData
temporalId
uint32_t sliceModeData

[in]: Specifies the parameter needed for sliceMode. For: sliceMode = 0, sliceModeData specifies # of CTUs in each slice (except last slice) sliceMode = 1, sliceModeData specifies maximum # of bytes in each slice (except last slice) sliceMode = 2, sliceModeData specifies # of CTU rows in each slice (except last slice) sliceMode = 3, sliceModeData specifies number of slices in the picture. Driver will divide picture into slices optimally


  • _NV_ENC_PIC_PARAMS_HEVC
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reservedBitFields
sliceMode
sliceModeData
sliceModeDataUpdate
sliceTypeArrayCnt
sliceTypeData
temporalId
uint32_t sliceModeDataUpdate

[in]: Set to 1 if client wants to change the sliceModeData field to specify new sliceSize Parameter When forceIntraRefreshWithFrameCnt is set it will have priority over sliceMode setting


  • _NV_ENC_PIC_PARAMS_HEVC
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reservedBitFields
sliceMode
sliceModeData
sliceModeDataUpdate
sliceTypeArrayCnt
sliceTypeData
temporalId
uint32_t sliceTypeArrayCnt

[in]: Client should set this to the number of elements allocated in sliceTypeData array. If sliceTypeData is NULL then this should be set to 0


  • _NV_ENC_PIC_PARAMS_HEVC
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reservedBitFields
sliceMode
sliceModeData
sliceModeDataUpdate
sliceTypeArrayCnt
sliceTypeData
temporalId
uint8_t* sliceTypeData

[in]: Array which specifies the slice type used to force intra slice for a particular slice. Currently supported only for NV_ENC_CONFIG_H264::sliceMode == 3. Client should allocate array of size sliceModeData where sliceModeData is specified in field of _NV_ENC_CONFIG_H264 Array element with index n corresponds to nth slice. To force a particular slice to intra client should set corresponding array element to NV_ENC_SLICE_TYPE_I all other array elements should be set to NV_ENC_SLICE_TYPE_DEFAULT


  • _NV_ENC_PIC_PARAMS_HEVC
constrainedFrame
displayPOCSyntax
forceIntraRefreshWithFrameCnt
ltrMarkFrame
ltrMarkFrameIdx
ltrUsageMode
ltrUseFrameBitmap
ltrUseFrames
refPicFlag
reserved
reserved2
reservedBitFields
sliceMode
sliceModeData
sliceModeDataUpdate
sliceTypeArrayCnt
sliceTypeData
temporalId
uint32_t temporalId

[in]: Specifies the temporal id of the picture


  • _NV_ENC_PRESET_CONFIG
presetCfg
reserved1
reserved2
version
NV_ENC_CONFIG presetCfg

[out]: preset config returned by the Nvidia Video Encoder interface.


  • _NV_ENC_PRESET_CONFIG
presetCfg
reserved1
reserved2
version
uint32_t reserved1[255]

[in]: Reserved and must be set to 0


  • _NV_ENC_PRESET_CONFIG
presetCfg
reserved1
reserved2
version
void* reserved2[64]

[in]: Reserved and must be set to NULL


  • _NV_ENC_PRESET_CONFIG
presetCfg
reserved1
reserved2
version
uint32_t version

[in]: Struct version. Must be set to NV_ENC_PRESET_CONFIG_VER.


  • _NV_ENC_QP


  • _NV_ENC_RC_PARAMS
averageBitRate
constQP
enableAQ
enableExtQPDeltaMap
enableInitialRCQP
enableMaxQP
enableMinQP
initialRCQP
maxBitRate
maxQP
minQP
rateControlMode
reservedBitFields
temporallayerIdxMask
temporalLayerQP
vbvBufferSize
vbvInitialDelay
uint32_t averageBitRate

[in]: Specifies the average bitrate(in bits/sec) used for encoding.


  • _NV_ENC_RC_PARAMS
averageBitRate
constQP
enableAQ
enableExtQPDeltaMap
enableInitialRCQP
enableMaxQP
enableMinQP
initialRCQP
maxBitRate
maxQP
minQP
rateControlMode
reservedBitFields
temporallayerIdxMask
temporalLayerQP
vbvBufferSize
vbvInitialDelay
NV_ENC_QP constQP

[in]: Specifies the initial QP to be used for encoding, these values would be used for all frames if in Constant QP mode.


  • _NV_ENC_RC_PARAMS
averageBitRate
constQP
enableAQ
enableExtQPDeltaMap
enableInitialRCQP
enableMaxQP
enableMinQP
initialRCQP
maxBitRate
maxQP
minQP
rateControlMode
reservedBitFields
temporallayerIdxMask
temporalLayerQP
vbvBufferSize
vbvInitialDelay
uint32_t enableAQ

[in]: Set this to 1 to enable adaptive quantization.


  • _NV_ENC_RC_PARAMS
averageBitRate
constQP
enableAQ
enableExtQPDeltaMap
enableInitialRCQP
enableMaxQP
enableMinQP
initialRCQP
maxBitRate
maxQP
minQP
rateControlMode
reservedBitFields
temporallayerIdxMask
temporalLayerQP
vbvBufferSize
vbvInitialDelay
uint32_t enableExtQPDeltaMap

[in]: Set this to 1 to enable additional QP modifier for each MB supplied by client though signed byte array pointed to by NV_ENC_PIC_PARAMS::qpDeltaMap


  • _NV_ENC_RC_PARAMS
averageBitRate
constQP
enableAQ
enableExtQPDeltaMap
enableInitialRCQP
enableMaxQP
enableMinQP
initialRCQP
maxBitRate
maxQP
minQP
rateControlMode
reservedBitFields
temporallayerIdxMask
temporalLayerQP
vbvBufferSize
vbvInitialDelay
uint32_t enableInitialRCQP

[in]: Set this to 1 if user suppplied initial QP is used for rate control.


  • _NV_ENC_RC_PARAMS
averageBitRate
constQP
enableAQ
enableExtQPDeltaMap
enableInitialRCQP
enableMaxQP
enableMinQP
initialRCQP
maxBitRate
maxQP
minQP
rateControlMode
reservedBitFields
temporallayerIdxMask
temporalLayerQP
vbvBufferSize
vbvInitialDelay
uint32_t enableMaxQP

[in]: Set this to 1 if maximum QP used for rate control.


  • _NV_ENC_RC_PARAMS
averageBitRate
constQP
enableAQ
enableExtQPDeltaMap
enableInitialRCQP
enableMaxQP
enableMinQP
initialRCQP
maxBitRate
maxQP
minQP
rateControlMode
reservedBitFields
temporallayerIdxMask
temporalLayerQP
vbvBufferSize
vbvInitialDelay
uint32_t enableMinQP

[in]: Set this to 1 if minimum QP used for rate control.


  • _NV_ENC_RC_PARAMS
averageBitRate
constQP
enableAQ
enableExtQPDeltaMap
enableInitialRCQP
enableMaxQP
enableMinQP
initialRCQP
maxBitRate
maxQP
minQP
rateControlMode
reservedBitFields
temporallayerIdxMask
temporalLayerQP
vbvBufferSize
vbvInitialDelay
NV_ENC_QP initialRCQP

[in]: Specifies the initial QP used for rate control. Client must set NV_ENC_CONFIG::enableInitialRCQP to 1.


  • _NV_ENC_RC_PARAMS
averageBitRate
constQP
enableAQ
enableExtQPDeltaMap
enableInitialRCQP
enableMaxQP
enableMinQP
initialRCQP
maxBitRate
maxQP
minQP
rateControlMode
reservedBitFields
temporallayerIdxMask
temporalLayerQP
vbvBufferSize
vbvInitialDelay
uint32_t maxBitRate

[in]: Specifies the maximum bitrate for the encoded output. This is used for VBR and ignored for CBR mode.


  • _NV_ENC_RC_PARAMS
averageBitRate
constQP
enableAQ
enableExtQPDeltaMap
enableInitialRCQP
enableMaxQP
enableMinQP
initialRCQP
maxBitRate
maxQP
minQP
rateControlMode
reservedBitFields
temporallayerIdxMask
temporalLayerQP
vbvBufferSize
vbvInitialDelay
NV_ENC_QP maxQP

[in]: Specifies the maximum QP used for rate control. Client must set NV_ENC_CONFIG::enableMaxQP to 1.


  • _NV_ENC_RC_PARAMS
averageBitRate
constQP
enableAQ
enableExtQPDeltaMap
enableInitialRCQP
enableMaxQP
enableMinQP
initialRCQP
maxBitRate
maxQP
minQP
rateControlMode
reservedBitFields
temporallayerIdxMask
temporalLayerQP
vbvBufferSize
vbvInitialDelay
NV_ENC_QP minQP

[in]: Specifies the minimum QP used for rate control. Client must set NV_ENC_CONFIG::enableMinQP to 1.


  • _NV_ENC_RC_PARAMS
averageBitRate
constQP
enableAQ
enableExtQPDeltaMap
enableInitialRCQP
enableMaxQP
enableMinQP
initialRCQP
maxBitRate
maxQP
minQP
rateControlMode
reservedBitFields
temporallayerIdxMask
temporalLayerQP
vbvBufferSize
vbvInitialDelay
NV_ENC_PARAMS_RC_MODE rateControlMode

[in]: Specifies the rate control mode. Check support for various rate control modes using NV_ENC_CAPS_SUPPORTED_RATECONTROL_MODES caps.


  • _NV_ENC_RC_PARAMS
averageBitRate
constQP
enableAQ
enableExtQPDeltaMap
enableInitialRCQP
enableMaxQP
enableMinQP
initialRCQP
maxBitRate
maxQP
minQP
rateControlMode
reservedBitFields
temporallayerIdxMask
temporalLayerQP
vbvBufferSize
vbvInitialDelay


  • _NV_ENC_RC_PARAMS
averageBitRate
constQP
enableAQ
enableExtQPDeltaMap
enableInitialRCQP
enableMaxQP
enableMinQP
initialRCQP
maxBitRate
maxQP
minQP
rateControlMode
reservedBitFields
temporallayerIdxMask
temporalLayerQP
vbvBufferSize
vbvInitialDelay
uint32_t reservedBitFields

[in]: Reserved bitfields and must be set to 0


  • _NV_ENC_RC_PARAMS
averageBitRate
constQP
enableAQ
enableExtQPDeltaMap
enableInitialRCQP
enableMaxQP
enableMinQP
initialRCQP
maxBitRate
maxQP
minQP
rateControlMode
reservedBitFields
temporallayerIdxMask
temporalLayerQP
vbvBufferSize
vbvInitialDelay
uint32_t temporallayerIdxMask

[in]: Specifies the temporal layers (as a bitmask) whose QPs have changed. Valid max bitmask is [2^NV_ENC_CAPS_NUM_MAX_TEMPORAL_LAYERS - 1]


  • _NV_ENC_RC_PARAMS
averageBitRate
constQP
enableAQ
enableExtQPDeltaMap
enableInitialRCQP
enableMaxQP
enableMinQP
initialRCQP
maxBitRate
maxQP
minQP
rateControlMode
reservedBitFields
temporallayerIdxMask
temporalLayerQP
vbvBufferSize
vbvInitialDelay
uint8_t temporalLayerQP[8]

[in]: Specifies the temporal layer QPs used for rate control. Temporal layer index is used as as the array index


  • _NV_ENC_RC_PARAMS
averageBitRate
constQP
enableAQ
enableExtQPDeltaMap
enableInitialRCQP
enableMaxQP
enableMinQP
initialRCQP
maxBitRate
maxQP
minQP
rateControlMode
reservedBitFields
temporallayerIdxMask
temporalLayerQP
vbvBufferSize
vbvInitialDelay
uint32_t vbvBufferSize

[in]: Specifies the VBV(HRD) buffer size. in bits. Set 0 to use the default VBV buffer size.


  • _NV_ENC_RC_PARAMS
averageBitRate
constQP
enableAQ
enableExtQPDeltaMap
enableInitialRCQP
enableMaxQP
enableMinQP
initialRCQP
maxBitRate
maxQP
minQP
rateControlMode
reservedBitFields
temporallayerIdxMask
temporalLayerQP
vbvBufferSize
vbvInitialDelay
uint32_t vbvInitialDelay

[in]: Specifies the VBV(HRD) initial delay in bits. Set 0 to use the default VBV initial delay .


  • _NV_ENC_RECONFIGURE_PARAMS
forceIDR
reInitEncodeParams
resetEncoder
version
uint32_t forceIDR

[in]: Encode the current picture as an IDR picture. This flag is only valid when Picture type decision is taken by the Encoder [_NV_ENC_INITIALIZE_PARAMS::enablePTD == 1].


  • _NV_ENC_RECONFIGURE_PARAMS
forceIDR
reInitEncodeParams
resetEncoder
version
NV_ENC_INITIALIZE_PARAMS reInitEncodeParams

[in]: Encoder session re-initialization parameters.


  • _NV_ENC_RECONFIGURE_PARAMS
forceIDR
reInitEncodeParams
resetEncoder
version


  • _NV_ENC_RECONFIGURE_PARAMS
forceIDR
reInitEncodeParams
resetEncoder
version
uint32_t resetEncoder

[in]: This resets the rate control states and other internal encoder states. This should be used only with an IDR frame. If NV_ENC_INITIALIZE_PARAMS::enablePTD is set to 1, encoder will force the frame type to IDR


  • _NV_ENC_RECONFIGURE_PARAMS
forceIDR
reInitEncodeParams
resetEncoder
version
uint32_t version

[in]: Struct version. Must be set to NV_ENC_RECONFIGURE_PARAMS_VER.


  • _NV_ENC_REGISTER_RESOURCE
bufferFormat
height
pitch
registeredResource
reserved1
reserved2
resourceToRegister
resourceType
subResourceIndex
version
width
NV_ENC_BUFFER_FORMAT bufferFormat

[in]: Buffer format of resource to be registered.


  • _NV_ENC_REGISTER_RESOURCE
bufferFormat
height
pitch
registeredResource
reserved1
reserved2
resourceToRegister
resourceType
subResourceIndex
version
width
uint32_t height

[in]: Input buffer Height.


  • _NV_ENC_REGISTER_RESOURCE
bufferFormat
height
pitch
registeredResource
reserved1
reserved2
resourceToRegister
resourceType
subResourceIndex
version
width
uint32_t pitch

[in]: Input buffer Pitch.


  • _NV_ENC_REGISTER_RESOURCE
bufferFormat
height
pitch
registeredResource
reserved1
reserved2
resourceToRegister
resourceType
subResourceIndex
version
width
NV_ENC_REGISTERED_PTR registeredResource

[out]: Registered resource handle. This should be used in future interactions with the Nvidia Video Encoder Interface.


  • _NV_ENC_REGISTER_RESOURCE
bufferFormat
height
pitch
registeredResource
reserved1
reserved2
resourceToRegister
resourceType
subResourceIndex
version
width
uint32_t reserved1[248]

[in]: Reserved and must be set to 0.


  • _NV_ENC_REGISTER_RESOURCE
bufferFormat
height
pitch
registeredResource
reserved1
reserved2
resourceToRegister
resourceType
subResourceIndex
version
width
void* reserved2[62]

[in]: Reserved and must be set to NULL.


  • _NV_ENC_REGISTER_RESOURCE
bufferFormat
height
pitch
registeredResource
reserved1
reserved2
resourceToRegister
resourceType
subResourceIndex
version
width
void* resourceToRegister

[in]: Handle to the resource that is being registered.


  • _NV_ENC_REGISTER_RESOURCE
bufferFormat
height
pitch
registeredResource
reserved1
reserved2
resourceToRegister
resourceType
subResourceIndex
version
width
NV_ENC_INPUT_RESOURCE_TYPE resourceType

[in]: Specifies the type of resource to be registered. Supported values are NV_ENC_INPUT_RESOURCE_TYPE_DIRECTX, NV_ENC_INPUT_RESOURCE_TYPE_CUDADEVICEPTR.


  • _NV_ENC_REGISTER_RESOURCE
bufferFormat
height
pitch
registeredResource
reserved1
reserved2
resourceToRegister
resourceType
subResourceIndex
version
width
uint32_t subResourceIndex

[in]: Subresource Index of the DirectX resource to be registered. Should eb set to 0 for other interfaces.


  • _NV_ENC_REGISTER_RESOURCE
bufferFormat
height
pitch
registeredResource
reserved1
reserved2
resourceToRegister
resourceType
subResourceIndex
version
width
uint32_t version

[in]: Struct version. Must be set to NV_ENC_REGISTER_RESOURCE_VER.


  • _NV_ENC_REGISTER_RESOURCE
bufferFormat
height
pitch
registeredResource
reserved1
reserved2
resourceToRegister
resourceType
subResourceIndex
version
width
uint32_t width

[in]: Input buffer Width.


  • _NV_ENC_SEQUENCE_PARAM_PAYLOAD
inBufferSize
outSPSPPSPayloadSize
ppsId
reserved
reserved2
spsId
spsppsBuffer
version
uint32_t inBufferSize

[in]: Specifies the size of the spsppsBuffer provied by the client


  • _NV_ENC_SEQUENCE_PARAM_PAYLOAD
inBufferSize
outSPSPPSPayloadSize
ppsId
reserved
reserved2
spsId
spsppsBuffer
version
uint32_t* outSPSPPSPayloadSize

[out]: Size of the sequence and picture header in bytes written by the NvEncodeAPI interface to the SPSPPSBuffer.


  • _NV_ENC_SEQUENCE_PARAM_PAYLOAD
inBufferSize
outSPSPPSPayloadSize
ppsId
reserved
reserved2
spsId
spsppsBuffer
version
uint32_t ppsId

[in]: Specifies the PPS id to be used in picture header. Default value is 0.


  • _NV_ENC_SEQUENCE_PARAM_PAYLOAD
inBufferSize
outSPSPPSPayloadSize
ppsId
reserved
reserved2
spsId
spsppsBuffer
version
uint32_t reserved[250]

[in]: Reserved and must be set to 0


  • _NV_ENC_SEQUENCE_PARAM_PAYLOAD
inBufferSize
outSPSPPSPayloadSize
ppsId
reserved
reserved2
spsId
spsppsBuffer
version
void* reserved2[64]

[in]: Reserved and must be set to NULL


  • _NV_ENC_SEQUENCE_PARAM_PAYLOAD
inBufferSize
outSPSPPSPayloadSize
ppsId
reserved
reserved2
spsId
spsppsBuffer
version
uint32_t spsId

[in]: Specifies the SPS id to be used in sequence header. Default value is 0.


  • _NV_ENC_SEQUENCE_PARAM_PAYLOAD
inBufferSize
outSPSPPSPayloadSize
ppsId
reserved
reserved2
spsId
spsppsBuffer
version
void* spsppsBuffer

[in]: Specifies bitstream header pointer of size NV_ENC_SEQUENCE_PARAM_PAYLOAD::inBufferSize. It is the client's responsibility to manage this memory.


  • _NV_ENC_SEQUENCE_PARAM_PAYLOAD
inBufferSize
outSPSPPSPayloadSize
ppsId
reserved
reserved2
spsId
spsppsBuffer
version
uint32_t version

[in]: Struct version. Must be set to NV_ENC_INITIALIZE_PARAMS_VER.


  • _NV_ENC_STAT
bitStreamSize
lastValidByteOffset
outputBitStream
picIdx
picType
reserved
reserved1
reserved2
sliceOffsets
version
uint32_t bitStreamSize

[out]: Size of generated bitstream in bytes.


  • _NV_ENC_STAT
bitStreamSize
lastValidByteOffset
outputBitStream
picIdx
picType
reserved
reserved1
reserved2
sliceOffsets
version
uint32_t lastValidByteOffset

[out]: Offset of last valid bytes of completed bitstream


  • _NV_ENC_STAT
bitStreamSize
lastValidByteOffset
outputBitStream
picIdx
picType
reserved
reserved1
reserved2
sliceOffsets
version
NV_ENC_OUTPUT_PTR outputBitStream

[out]: Specifies the pointer to output bitstream.


  • _NV_ENC_STAT
bitStreamSize
lastValidByteOffset
outputBitStream
picIdx
picType
reserved
reserved1
reserved2
sliceOffsets
version
uint32_t picIdx

[out]: Picture number


  • _NV_ENC_STAT
bitStreamSize
lastValidByteOffset
outputBitStream
picIdx
picType
reserved
reserved1
reserved2
sliceOffsets
version
uint32_t picType

[out]: Picture type of encoded picture. See NV_ENC_PIC_TYPE.


  • _NV_ENC_STAT
bitStreamSize
lastValidByteOffset
outputBitStream
picIdx
picType
reserved
reserved1
reserved2
sliceOffsets
version
uint32_t reserved

[in]: Reserved and must be set to 0


  • _NV_ENC_STAT
bitStreamSize
lastValidByteOffset
outputBitStream
picIdx
picType
reserved
reserved1
reserved2
sliceOffsets
version
uint32_t reserved1[233]

[in]: Reserved and must be set to 0


  • _NV_ENC_STAT
bitStreamSize
lastValidByteOffset
outputBitStream
picIdx
picType
reserved
reserved1
reserved2
sliceOffsets
version
void* reserved2[64]

[in]: Reserved and must be set to NULL


  • _NV_ENC_STAT
bitStreamSize
lastValidByteOffset
outputBitStream
picIdx
picType
reserved
reserved1
reserved2
sliceOffsets
version
uint32_t sliceOffsets[16]

[out]: Offsets of each slice


  • _NV_ENC_STAT
bitStreamSize
lastValidByteOffset
outputBitStream
picIdx
picType
reserved
reserved1
reserved2
sliceOffsets
version
uint32_t version

[in]: Struct version. Must be set to NV_ENC_STAT_VER.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCCREATEBITSTREAMBUFFER nvEncCreateBitstreamBuffer

[out]: Client should access NvEncCreateBitstreamBuffer() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCCREATEINPUTBUFFER nvEncCreateInputBuffer

[out]: Client should access NvEncCreateInputBuffer() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCDESTROYBITSTREAMBUFFER nvEncDestroyBitstreamBuffer

[out]: Client should access NvEncDestroyBitstreamBuffer() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCDESTROYENCODER nvEncDestroyEncoder

[out]: Client should access NvEncDestroyEncoder() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCDESTROYINPUTBUFFER nvEncDestroyInputBuffer

[out]: Client should access NvEncDestroyInputBuffer() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCENCODEPICTURE nvEncEncodePicture

[out]: Client should access NvEncEncodePicture() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCGETENCODECAPS nvEncGetEncodeCaps

[out]: Client should access NvEncGetEncodeCaps() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCGETENCODEGUIDCOUNT nvEncGetEncodeGUIDCount

[out]: Client should access NvEncGetEncodeGUIDCount() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCGETENCODEGUIDS nvEncGetEncodeGUIDs

[out]: Client should access NvEncGetEncodeGUIDs() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCGETENCODEPRESETCONFIG nvEncGetEncodePresetConfig

[out]: Client should access NvEncGetEncodePresetConfig() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCGETENCODEPRESETCOUNT nvEncGetEncodePresetCount

[out]: Client should access NvEncGetEncodePresetCount() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCGETENCODEPRESETGUIDS nvEncGetEncodePresetGUIDs

[out]: Client should access NvEncGetEncodePresetGUIDs() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCGETENCODEPRESETCOUNT nvEncGetEncodeProfileGUIDCount

[out]: Client should access NvEncGetEncodeProfileGUIDCount() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCGETENCODEPRESETGUIDS nvEncGetEncodeProfileGUIDs

[out]: Client should access NvEncGetEncodeProfileGUIDs() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCGETENCODESTATS nvEncGetEncodeStats

[out]: Client should access NvEncGetEncodeStats() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCGETINPUTFORMATCOUNT nvEncGetInputFormatCount

[out]: Client should access NvEncGetInputFormatCount() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCGETINPUTFORMATS nvEncGetInputFormats

[out]: Client should access NvEncGetInputFormats() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCGETSEQUENCEPARAMS nvEncGetSequenceParams

[out]: Client should access NvEncGetSequenceParams() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCINITIALIZEENCODER nvEncInitializeEncoder

[out]: Client should access NvEncInitializeEncoder() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCINVALIDATEREFFRAMES nvEncInvalidateRefFrames

[out]: Client should access NvEncInvalidateRefFrames() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCLOCKBITSTREAM nvEncLockBitstream

[out]: Client should access NvEncLockBitstream() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCLOCKINPUTBUFFER nvEncLockInputBuffer

[out]: Client should access NvEncLockInputBuffer() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCMAPINPUTRESOURCE nvEncMapInputResource

[out]: Client should access NvEncMapInputResource() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCOPENENCODESESSION nvEncOpenEncodeSession

[out]: Client should access NvEncOpenEncodeSession() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCOPENENCODESESSIONEX nvEncOpenEncodeSessionEx

[out]: Client should access NvEncOpenEncodeSession() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCRECONFIGUREENCODER nvEncReconfigureEncoder

[out]: Client should access NvEncReconfigureEncoder() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCREGISTERASYNCEVENT nvEncRegisterAsyncEvent

[out]: Client should access NvEncRegisterAsyncEvent() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCREGISTERRESOURCE nvEncRegisterResource

[out]: Client should access NvEncRegisterResource() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCUNLOCKBITSTREAM nvEncUnlockBitstream

[out]: Client should access NvEncUnlockBitstream() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCUNLOCKINPUTBUFFER nvEncUnlockInputBuffer

[out]: Client should access NvEncUnlockInputBuffer() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCUNMAPINPUTRESOURCE nvEncUnmapInputResource

[out]: Client should access NvEncUnmapInputResource() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCUNREGISTERASYNCEVENT nvEncUnregisterAsyncEvent

[out]: Client should access NvEncUnregisterAsyncEvent() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
PNVENCUNREGISTERRESOURCE nvEncUnregisterResource

[out]: Client should access NvEncUnregisterResource() API through this pointer.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
uint32_t reserved

[in]: Reserved and should be set to 0.


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
void* reserved2[285]

[in]: Reserved and must be set to NULL


  • _NV_ENCODE_API_FUNCTION_LIST
nvEncCreateBitstreamBuffer
nvEncCreateInputBuffer
nvEncDestroyBitstreamBuffer
nvEncDestroyEncoder
nvEncDestroyInputBuffer
nvEncEncodePicture
nvEncGetEncodeCaps
nvEncGetEncodeGUIDCount
nvEncGetEncodeGUIDs
nvEncGetEncodePresetConfig
nvEncGetEncodePresetCount
nvEncGetEncodePresetGUIDs
nvEncGetEncodeProfileGUIDCount
nvEncGetEncodeProfileGUIDs
nvEncGetEncodeStats
nvEncGetInputFormatCount
nvEncGetInputFormats
nvEncGetSequenceParams
nvEncInitializeEncoder
nvEncInvalidateRefFrames
nvEncLockBitstream
nvEncLockInputBuffer
nvEncMapInputResource
nvEncOpenEncodeSession
nvEncOpenEncodeSessionEx
nvEncReconfigureEncoder
nvEncRegisterAsyncEvent
nvEncRegisterResource
nvEncUnlockBitstream
nvEncUnlockInputBuffer
nvEncUnmapInputResource
nvEncUnregisterAsyncEvent
nvEncUnregisterResource
reserved
reserved2
version
uint32_t version

[in]: Client should pass NV_ENCODE_API_FUNCTION_LIST_VER.


  • _NVENC_EXTERNAL_ME_HINT
dir
lastOfMB
lastofPart
mvx
mvy
partType
refidx
int32_t dir

[in]: Specifies the direction of motion estimation . 0=L0 1=L1.


  • _NVENC_EXTERNAL_ME_HINT
dir
lastOfMB
lastofPart
mvx
mvy
partType
refidx
int32_t lastOfMB

[in]: Set to 1 for the last MV of macroblock.


  • _NVENC_EXTERNAL_ME_HINT
dir
lastOfMB
lastofPart
mvx
mvy
partType
refidx
int32_t lastofPart

[in]: Set to 1 for the last MV of (sub) partition


  • _NVENC_EXTERNAL_ME_HINT
dir
lastOfMB
lastofPart
mvx
mvy
partType
refidx
int32_t mvx

[in]: Specifies the x component of integer pixel MV (relative to current MB) S12.0.


  • _NVENC_EXTERNAL_ME_HINT
dir
lastOfMB
lastofPart
mvx
mvy
partType
refidx
int32_t mvy

[in]: Specifies the y component of integer pixel MV (relative to current MB) S10.0 .


  • _NVENC_EXTERNAL_ME_HINT
dir
lastOfMB
lastofPart
mvx
mvy
partType
refidx
int32_t partType

[in]: Specifies the bloack partition type.0=16x16 1=16x8 2=8x16 3=8x8 (blocks in partition must be consecutive).


  • _NVENC_EXTERNAL_ME_HINT
dir
lastOfMB
lastofPart
mvx
mvy
partType
refidx
int32_t refidx

[in]: Specifies the reference index (31=invalid). Current we support only 1 reference frame per direction for external hints, so refidx must be 0.


  • _NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE
numCandsPerBlk16x16
numCandsPerBlk16x8
numCandsPerBlk8x16
numCandsPerBlk8x8
reserved
reserved1
uint32_t numCandsPerBlk16x16

[in]: Specifies the number of candidates per 16x16 block.


  • _NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE
numCandsPerBlk16x16
numCandsPerBlk16x8
numCandsPerBlk8x16
numCandsPerBlk8x8
reserved
reserved1
uint32_t numCandsPerBlk16x8

[in]: Specifies the number of candidates per 16x8 block.


  • _NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE
numCandsPerBlk16x16
numCandsPerBlk16x8
numCandsPerBlk8x16
numCandsPerBlk8x8
reserved
reserved1
uint32_t numCandsPerBlk8x16

[in]: Specifies the number of candidates per 8x16 block.


  • _NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE
numCandsPerBlk16x16
numCandsPerBlk16x8
numCandsPerBlk8x16
numCandsPerBlk8x8
reserved
reserved1
uint32_t numCandsPerBlk8x8

[in]: Specifies the number of candidates per 8x8 block.


  • _NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE
numCandsPerBlk16x16
numCandsPerBlk16x8
numCandsPerBlk8x16
numCandsPerBlk8x8
reserved
reserved1
uint32_t reserved

[in]: Reserved for padding.


  • _NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE
numCandsPerBlk16x16
numCandsPerBlk16x8
numCandsPerBlk8x16
numCandsPerBlk8x8
reserved
reserved1
uint32_t reserved1[3]

[in]: Reserved for future use.


  • _NVENC_RECT
bottom
left
right
top
uint32_t bottom

[in]: Y coordinate of the bottom right corner of the rectangular area to be specified.


  • _NVENC_RECT
bottom
left
right
top
uint32_t left

[in]: X coordinate of the upper left corner of rectangular area to be specified.


  • _NVENC_RECT
bottom
left
right
top
uint32_t right

[in]: X coordinate of the bottom right corner of the rectangular area to be specified.


  • _NVENC_RECT
bottom
left
right
top
uint32_t top

[in]: Y coordinate of the upper left corner of the rectangular area to be specified.


  • GUID
Data1
Data2
Data3
Data4
uint32_t Data1

[in]: Specifies the first 8 hexadecimal digits of the GUID.


  • GUID
Data1
Data2
Data3
Data4
uint16_t Data2

[in]: Specifies the first group of 4 hexadecimal digits.


  • GUID
Data1
Data2
Data3
Data4
uint16_t Data3

[in]: Specifies the second group of 4 hexadecimal digits.


  • GUID
Data1
Data2
Data3
Data4
uint8_t Data4[8]

[in]: Array of 8 bytes. The first 2 bytes contain the third group of 4 hexadecimal digits. The remaining 6 bytes contain the final 12 hexadecimal digits.


  • Data Structure Index
  • Data Fields
Data Structure Index
G | _
G
_NV_ENC_CODEC_PIC_PARAMS _NV_ENC_EVENT_PARAMS _NV_ENC_PIC_PARAMS _NV_ENC_REGISTER_RESOURCE
_NV_ENC_CONFIG _NV_ENC_H264_SEI_PAYLOAD _NV_ENC_PIC_PARAMS_H264 _NV_ENC_SEQUENCE_PARAM_PAYLOAD
GUID _NV_ENC_CONFIG_H264 _NV_ENC_INITIALIZE_PARAMS _NV_ENC_PIC_PARAMS_HEVC _NV_ENC_STAT
_
_NV_ENC_CONFIG_H264_VUI_PARAMETERS _NV_ENC_LOCK_BITSTREAM _NV_ENC_PRESET_CONFIG _NV_ENCODE_API_FUNCTION_LIST
_NV_ENC_CONFIG_HEVC _NV_ENC_LOCK_INPUT_BUFFER _NV_ENC_QP _NVENC_EXTERNAL_ME_HINT
_NV_ENC_CAPS_PARAM _NV_ENC_CREATE_BITSTREAM_BUFFER _NV_ENC_MAP_INPUT_RESOURCE _NV_ENC_RC_PARAMS _NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE
_NV_ENC_CODEC_CONFIG _NV_ENC_CREATE_INPUT_BUFFER _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS _NV_ENC_RECONFIGURE_PARAMS _NVENC_RECT
G | _


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- a -

  • adaptiveTransformMode : _NV_ENC_CONFIG_H264
  • apiVersion : _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS
  • averageBitRate : _NV_ENC_RC_PARAMS


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- b -

  • bdirectMode : _NV_ENC_CONFIG_H264
  • bitstreamBuffer : _NV_ENC_CREATE_BITSTREAM_BUFFER
  • bitstreamBufferPtr : _NV_ENC_LOCK_BITSTREAM , _NV_ENC_CREATE_BITSTREAM_BUFFER
  • bitstreamRestrictionFlag : _NV_ENC_CONFIG_H264_VUI_PARAMETERS
  • bitStreamSize : _NV_ENC_STAT
  • bitstreamSizeInBytes : _NV_ENC_LOCK_BITSTREAM
  • bottom : _NVENC_RECT
  • bufferDataPtr : _NV_ENC_LOCK_INPUT_BUFFER
  • bufferFmt : _NV_ENC_PIC_PARAMS , _NV_ENC_CREATE_INPUT_BUFFER
  • bufferFormat : _NV_ENC_REGISTER_RESOURCE


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- c -

  • capsToQuery : _NV_ENC_CAPS_PARAM
  • chromaFormatIDC : _NV_ENC_CONFIG_H264
  • chromaSampleLocationBot : _NV_ENC_CONFIG_H264_VUI_PARAMETERS
  • chromaSampleLocationFlag : _NV_ENC_CONFIG_H264_VUI_PARAMETERS
  • chromaSampleLocationTop : _NV_ENC_CONFIG_H264_VUI_PARAMETERS
  • codecPicParams : _NV_ENC_PIC_PARAMS
  • colourDescriptionPresentFlag : _NV_ENC_CONFIG_H264_VUI_PARAMETERS
  • colourMatrix : _NV_ENC_CONFIG_H264_VUI_PARAMETERS
  • colourPlaneId : _NV_ENC_PIC_PARAMS_H264
  • colourPrimaries : _NV_ENC_CONFIG_H264_VUI_PARAMETERS
  • completionEvent : _NV_ENC_PIC_PARAMS , _NV_ENC_EVENT_PARAMS
  • constQP : _NV_ENC_RC_PARAMS
  • constrainedFrame : _NV_ENC_PIC_PARAMS_HEVC , _NV_ENC_PIC_PARAMS_H264


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- d -

  • darHeight : _NV_ENC_INITIALIZE_PARAMS
  • darWidth : _NV_ENC_INITIALIZE_PARAMS
  • Data1 : GUID
  • Data2 : GUID
  • Data3 : GUID
  • Data4 : GUID
  • device : _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS
  • deviceType : _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS
  • dir : _NVENC_EXTERNAL_ME_HINT
  • disableDeblockAcrossSliceBoundary : _NV_ENC_CONFIG_HEVC
  • disableDeblockingFilterIDC : _NV_ENC_CONFIG_H264
  • disableSPSPPS : _NV_ENC_CONFIG_HEVC , _NV_ENC_CONFIG_H264
  • displayPOCSyntax : _NV_ENC_PIC_PARAMS_HEVC , _NV_ENC_PIC_PARAMS_H264
  • doNotWait : _NV_ENC_LOCK_BITSTREAM , _NV_ENC_LOCK_INPUT_BUFFER


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- e -

  • enableAQ : _NV_ENC_RC_PARAMS
  • enableConstrainedEncoding : _NV_ENC_CONFIG_H264
  • enableEncodeAsync : _NV_ENC_INITIALIZE_PARAMS
  • enableExternalMEHints : _NV_ENC_INITIALIZE_PARAMS
  • enableExtQPDeltaMap : _NV_ENC_RC_PARAMS
  • enableInitialRCQP : _NV_ENC_RC_PARAMS
  • enableIntraRefresh : _NV_ENC_CONFIG_HEVC , _NV_ENC_CONFIG_H264
  • enableLTR : _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG_HEVC
  • enableMaxQP : _NV_ENC_RC_PARAMS
  • enableMinQP : _NV_ENC_RC_PARAMS
  • enablePTD : _NV_ENC_INITIALIZE_PARAMS
  • enableStereoMVC : _NV_ENC_CONFIG_H264
  • enableSubFrameWrite : _NV_ENC_INITIALIZE_PARAMS
  • enableTemporalSVC : _NV_ENC_CONFIG_H264
  • enableVFR : _NV_ENC_CONFIG_H264
  • encodeCodecConfig : _NV_ENC_CONFIG
  • encodeConfig : _NV_ENC_INITIALIZE_PARAMS
  • encodeGUID : _NV_ENC_INITIALIZE_PARAMS
  • encodeHeight : _NV_ENC_INITIALIZE_PARAMS
  • encodePicFlags : _NV_ENC_PIC_PARAMS
  • encodeWidth : _NV_ENC_INITIALIZE_PARAMS
  • entropyCodingMode : _NV_ENC_CONFIG_H264


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- f -

  • fmoMode : _NV_ENC_CONFIG_H264
  • forceIDR : _NV_ENC_RECONFIGURE_PARAMS
  • forceIntraRefreshWithFrameCnt : _NV_ENC_PIC_PARAMS_HEVC , _NV_ENC_PIC_PARAMS_H264
  • frameAvgQP : _NV_ENC_LOCK_BITSTREAM
  • frameFieldMode : _NV_ENC_CONFIG
  • frameIdx : _NV_ENC_LOCK_BITSTREAM , _NV_ENC_PIC_PARAMS
  • frameIntervalP : _NV_ENC_CONFIG
  • frameRateDen : _NV_ENC_INITIALIZE_PARAMS
  • frameRateNum : _NV_ENC_INITIALIZE_PARAMS
  • frameSatd : _NV_ENC_LOCK_BITSTREAM


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- g -

  • gopLength : _NV_ENC_CONFIG


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- h -

  • h264Config : _NV_ENC_CODEC_CONFIG
  • h264PicParams : _NV_ENC_CODEC_PIC_PARAMS
  • h264VUIParameters : _NV_ENC_CONFIG_H264
  • height : _NV_ENC_CREATE_INPUT_BUFFER , _NV_ENC_REGISTER_RESOURCE
  • hevcConfig : _NV_ENC_CODEC_CONFIG
  • hevcPicParams : _NV_ENC_CODEC_PIC_PARAMS
  • hierarchicalBFrames : _NV_ENC_CONFIG_H264
  • hierarchicalPFrames : _NV_ENC_CONFIG_H264
  • hwEncodeStatus : _NV_ENC_LOCK_BITSTREAM


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- i -

  • idrPeriod : _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG_HEVC
  • inBufferSize : _NV_ENC_SEQUENCE_PARAM_PAYLOAD
  • initialRCQP : _NV_ENC_RC_PARAMS
  • inputBuffer : _NV_ENC_CREATE_INPUT_BUFFER , _NV_ENC_PIC_PARAMS , _NV_ENC_LOCK_INPUT_BUFFER
  • inputDuration : _NV_ENC_PIC_PARAMS
  • inputHeight : _NV_ENC_PIC_PARAMS
  • inputPitch : _NV_ENC_PIC_PARAMS
  • inputResource : _NV_ENC_MAP_INPUT_RESOURCE
  • inputTimeStamp : _NV_ENC_PIC_PARAMS
  • inputWidth : _NV_ENC_PIC_PARAMS
  • intraRefreshCnt : _NV_ENC_CONFIG_HEVC , _NV_ENC_CONFIG_H264
  • intraRefreshPeriod : _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG_HEVC


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- l -

  • lastOfMB : _NVENC_EXTERNAL_ME_HINT
  • lastofPart : _NVENC_EXTERNAL_ME_HINT
  • lastValidByteOffset : _NV_ENC_STAT
  • left : _NVENC_RECT
  • level : _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG_HEVC
  • ltrFrame : _NV_ENC_LOCK_BITSTREAM
  • ltrFrameBitmap : _NV_ENC_LOCK_BITSTREAM
  • ltrFrameIdx : _NV_ENC_LOCK_BITSTREAM
  • ltrMarkFrame : _NV_ENC_PIC_PARAMS_H264 , _NV_ENC_PIC_PARAMS_HEVC
  • ltrMarkFrameIdx : _NV_ENC_PIC_PARAMS_H264 , _NV_ENC_PIC_PARAMS_HEVC
  • ltrNumFrames : _NV_ENC_CONFIG_HEVC , _NV_ENC_CONFIG_H264
  • ltrTrustMode : _NV_ENC_CONFIG_H264
  • ltrUsageMode : _NV_ENC_PIC_PARAMS_HEVC , _NV_ENC_PIC_PARAMS_H264
  • ltrUseFrameBitmap : _NV_ENC_PIC_PARAMS_H264 , _NV_ENC_PIC_PARAMS_HEVC
  • ltrUseFrames : _NV_ENC_PIC_PARAMS_HEVC , _NV_ENC_PIC_PARAMS_H264


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- m -

  • mappedBufferFmt : _NV_ENC_MAP_INPUT_RESOURCE
  • mappedResource : _NV_ENC_MAP_INPUT_RESOURCE
  • maxBitRate : _NV_ENC_RC_PARAMS
  • maxCUSize : _NV_ENC_CONFIG_HEVC
  • maxEncodeHeight : _NV_ENC_INITIALIZE_PARAMS
  • maxEncodeWidth : _NV_ENC_INITIALIZE_PARAMS
  • maxMEHintCountsPerBlock : _NV_ENC_INITIALIZE_PARAMS
  • maxNumRefFrames : _NV_ENC_CONFIG_H264
  • maxNumRefFramesInDPB : _NV_ENC_CONFIG_HEVC
  • maxQP : _NV_ENC_RC_PARAMS
  • maxTemporalLayersMinus1 : _NV_ENC_CONFIG_HEVC
  • meExternalHints : _NV_ENC_PIC_PARAMS
  • meHintCountsPerBlock : _NV_ENC_PIC_PARAMS
  • memoryHeap : _NV_ENC_CREATE_BITSTREAM_BUFFER , _NV_ENC_CREATE_INPUT_BUFFER
  • minCUSize : _NV_ENC_CONFIG_HEVC
  • minQP : _NV_ENC_RC_PARAMS
  • monoChromeEncoding : _NV_ENC_CONFIG
  • mvPrecision : _NV_ENC_CONFIG
  • mvx : _NVENC_EXTERNAL_ME_HINT
  • mvy : _NVENC_EXTERNAL_ME_HINT


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- n -

  • numCandsPerBlk16x16 : _NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE
  • numCandsPerBlk16x8 : _NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE
  • numCandsPerBlk8x16 : _NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE
  • numCandsPerBlk8x8 : _NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE
  • numSlices : _NV_ENC_LOCK_BITSTREAM
  • numTemporalLayers : _NV_ENC_CONFIG_H264
  • nvEncCreateBitstreamBuffer : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncCreateInputBuffer : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncDestroyBitstreamBuffer : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncDestroyEncoder : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncDestroyInputBuffer : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncEncodePicture : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncGetEncodeCaps : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncGetEncodeGUIDCount : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncGetEncodeGUIDs : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncGetEncodePresetConfig : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncGetEncodePresetCount : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncGetEncodePresetGUIDs : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncGetEncodeProfileGUIDCount : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncGetEncodeProfileGUIDs : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncGetEncodeStats : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncGetInputFormatCount : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncGetInputFormats : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncGetSequenceParams : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncInitializeEncoder : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncInvalidateRefFrames : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncLockBitstream : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncLockInputBuffer : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncMapInputResource : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncOpenEncodeSession : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncOpenEncodeSessionEx : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncReconfigureEncoder : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncRegisterAsyncEvent : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncRegisterResource : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncUnlockBitstream : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncUnlockInputBuffer : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncUnmapInputResource : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncUnregisterAsyncEvent : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncUnregisterResource : _NV_ENCODE_API_FUNCTION_LIST


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- o -

  • outputAUD : _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG_HEVC
  • outputBitstream : _NV_ENC_PIC_PARAMS , _NV_ENC_LOCK_BITSTREAM
  • outputBitStream : _NV_ENC_STAT
  • outputBufferingPeriodSEI : _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG_HEVC
  • outputDuration : _NV_ENC_LOCK_BITSTREAM
  • outputFramePackingSEI : _NV_ENC_CONFIG_H264
  • outputPictureTimingSEI : _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG_HEVC
  • outputRecoveryPointSEI : _NV_ENC_CONFIG_H264
  • outputTimeStamp : _NV_ENC_LOCK_BITSTREAM
  • outSPSPPSPayloadSize : _NV_ENC_SEQUENCE_PARAM_PAYLOAD
  • overscanInfo : _NV_ENC_CONFIG_H264_VUI_PARAMETERS
  • overscanInfoPresentFlag : _NV_ENC_CONFIG_H264_VUI_PARAMETERS


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- p -

  • partType : _NVENC_EXTERNAL_ME_HINT
  • payload : _NV_ENC_H264_SEI_PAYLOAD
  • payloadSize : _NV_ENC_H264_SEI_PAYLOAD
  • payloadType : _NV_ENC_H264_SEI_PAYLOAD
  • picIdx : _NV_ENC_STAT
  • pictureStruct : _NV_ENC_PIC_PARAMS , _NV_ENC_LOCK_BITSTREAM
  • pictureType : _NV_ENC_PIC_PARAMS , _NV_ENC_LOCK_BITSTREAM
  • picType : _NV_ENC_STAT
  • pitch : _NV_ENC_LOCK_INPUT_BUFFER , _NV_ENC_REGISTER_RESOURCE
  • ppsId : _NV_ENC_SEQUENCE_PARAM_PAYLOAD , _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG_HEVC
  • presetCfg : _NV_ENC_PRESET_CONFIG
  • presetGUID : _NV_ENC_INITIALIZE_PARAMS
  • privData : _NV_ENC_INITIALIZE_PARAMS
  • privDataSize : _NV_ENC_INITIALIZE_PARAMS
  • profileGUID : _NV_ENC_CONFIG
  • pSysMemBuffer : _NV_ENC_CREATE_INPUT_BUFFER


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- q -

  • qpDeltaMap : _NV_ENC_PIC_PARAMS
  • qpDeltaMapSize : _NV_ENC_PIC_PARAMS
  • qpPrimeYZeroTransformBypassFlag : _NV_ENC_CONFIG_H264


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- r -

  • rateControlMode : _NV_ENC_RC_PARAMS
  • rcParams : _NV_ENC_CONFIG
  • refidx : _NVENC_EXTERNAL_ME_HINT
  • refPicFlag : _NV_ENC_PIC_PARAMS_H264 , _NV_ENC_PIC_PARAMS_HEVC
  • registeredResource : _NV_ENC_MAP_INPUT_RESOURCE , _NV_ENC_REGISTER_RESOURCE
  • reInitEncodeParams : _NV_ENC_RECONFIGURE_PARAMS
  • repeatSPSPPS : _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG_HEVC
  • reportSliceOffsets : _NV_ENC_INITIALIZE_PARAMS
  • reserved : _NV_ENC_CONFIG_HEVC , _NV_ENC_CODEC_CONFIG , _NV_ENC_CONFIG , _NV_ENC_INITIALIZE_PARAMS , _NV_ENC_PIC_PARAMS_H264 , _NV_ENC_PIC_PARAMS_HEVC , _NV_ENC_CODEC_PIC_PARAMS , _NV_ENC_LOCK_BITSTREAM , _NV_ENC_CAPS_PARAM , _NV_ENC_STAT , _NV_ENC_SEQUENCE_PARAM_PAYLOAD , _NV_ENC_CREATE_INPUT_BUFFER , _NV_ENC_EVENT_PARAMS , _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS , _NV_ENC_CREATE_BITSTREAM_BUFFER , _NV_ENCODE_API_FUNCTION_LIST , _NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE
  • reserved1 : _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG_HEVC , _NV_ENC_PRESET_CONFIG , _NV_ENC_PIC_PARAMS , _NV_ENC_LOCK_INPUT_BUFFER , _NV_ENC_MAP_INPUT_RESOURCE , _NV_ENC_REGISTER_RESOURCE , _NV_ENC_STAT , _NV_ENC_EVENT_PARAMS , _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS , _NV_ENC_CREATE_INPUT_BUFFER , _NV_ENC_CREATE_BITSTREAM_BUFFER , _NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE
  • reserved2 : _NV_ENC_INITIALIZE_PARAMS , _NV_ENC_EVENT_PARAMS , _NV_ENC_CREATE_BITSTREAM_BUFFER , _NV_ENC_CONFIG_HEVC , _NV_ENC_PIC_PARAMS_H264 , _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS , _NV_ENC_CREATE_INPUT_BUFFER , _NV_ENCODE_API_FUNCTION_LIST , _NV_ENC_REGISTER_RESOURCE , _NV_ENC_LOCK_BITSTREAM , _NV_ENC_PIC_PARAMS_HEVC , _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG , _NV_ENC_LOCK_INPUT_BUFFER , _NV_ENC_SEQUENCE_PARAM_PAYLOAD , _NV_ENC_PRESET_CONFIG , _NV_ENC_MAP_INPUT_RESOURCE , _NV_ENC_STAT , _NV_ENC_PIC_PARAMS
  • reserved3 : _NV_ENC_PIC_PARAMS_H264 , _NV_ENC_PIC_PARAMS
  • reserved4 : _NV_ENC_PIC_PARAMS
  • reservedBitFields : _NV_ENC_LOCK_BITSTREAM , _NV_ENC_LOCK_INPUT_BUFFER , _NV_ENC_CONFIG_H264 , _NV_ENC_RC_PARAMS , _NV_ENC_INITIALIZE_PARAMS , _NV_ENC_PIC_PARAMS_HEVC , _NV_ENC_PIC_PARAMS , _NV_ENC_PIC_PARAMS_H264
  • resetEncoder : _NV_ENC_RECONFIGURE_PARAMS
  • resourceToRegister : _NV_ENC_REGISTER_RESOURCE
  • resourceType : _NV_ENC_REGISTER_RESOURCE
  • right : _NVENC_RECT


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- s -

  • seiPayloadArray : _NV_ENC_PIC_PARAMS_H264
  • seiPayloadArrayCnt : _NV_ENC_PIC_PARAMS_H264
  • separateColourPlaneFlag : _NV_ENC_CONFIG_H264
  • size : _NV_ENC_CREATE_BITSTREAM_BUFFER
  • sliceMode : _NV_ENC_PIC_PARAMS_HEVC , _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG_HEVC , _NV_ENC_PIC_PARAMS_H264
  • sliceModeData : _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG_HEVC , _NV_ENC_PIC_PARAMS_H264 , _NV_ENC_PIC_PARAMS_HEVC
  • sliceModeDataUpdate : _NV_ENC_PIC_PARAMS_H264 , _NV_ENC_PIC_PARAMS_HEVC
  • sliceOffsets : _NV_ENC_STAT , _NV_ENC_LOCK_BITSTREAM
  • sliceTypeArrayCnt : _NV_ENC_PIC_PARAMS_HEVC
  • sliceTypeData : _NV_ENC_PIC_PARAMS_HEVC
  • spsId : _NV_ENC_CONFIG_HEVC , _NV_ENC_SEQUENCE_PARAM_PAYLOAD , _NV_ENC_CONFIG_H264
  • spsppsBuffer : _NV_ENC_SEQUENCE_PARAM_PAYLOAD
  • stereoMode : _NV_ENC_CONFIG_H264
  • subResourceIndex : _NV_ENC_MAP_INPUT_RESOURCE , _NV_ENC_REGISTER_RESOURCE


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- t -

  • temporalId : _NV_ENC_PIC_PARAMS_HEVC
  • temporallayerIdxMask : _NV_ENC_RC_PARAMS
  • temporalLayerQP : _NV_ENC_RC_PARAMS
  • tier : _NV_ENC_CONFIG_HEVC
  • top : _NVENC_RECT
  • transferCharacteristics : _NV_ENC_CONFIG_H264_VUI_PARAMETERS


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- u -

  • useConstrainedIntraPred : _NV_ENC_CONFIG_HEVC


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- v -

  • vbvBufferSize : _NV_ENC_RC_PARAMS
  • vbvInitialDelay : _NV_ENC_RC_PARAMS
  • version : _NV_ENC_CREATE_INPUT_BUFFER , _NV_ENC_RECONFIGURE_PARAMS , _NV_ENC_SEQUENCE_PARAM_PAYLOAD , _NV_ENCODE_API_FUNCTION_LIST , _NV_ENC_EVENT_PARAMS , _NV_ENC_PRESET_CONFIG , _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS , _NV_ENC_STAT , _NV_ENC_REGISTER_RESOURCE , _NV_ENC_MAP_INPUT_RESOURCE , _NV_ENC_LOCK_INPUT_BUFFER , _NV_ENC_LOCK_BITSTREAM , _NV_ENC_CREATE_BITSTREAM_BUFFER , _NV_ENC_PIC_PARAMS , _NV_ENC_CAPS_PARAM , _NV_ENC_INITIALIZE_PARAMS , _NV_ENC_CONFIG
  • videoFormat : _NV_ENC_CONFIG_H264_VUI_PARAMETERS
  • videoFullRangeFlag : _NV_ENC_CONFIG_H264_VUI_PARAMETERS
  • videoSignalTypePresentFlag : _NV_ENC_CONFIG_H264_VUI_PARAMETERS
  • vpsId : _NV_ENC_CONFIG_HEVC


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- w -

  • width : _NV_ENC_CREATE_INPUT_BUFFER , _NV_ENC_REGISTER_RESOURCE


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- a -

  • adaptiveTransformMode : _NV_ENC_CONFIG_H264
  • apiVersion : _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS
  • averageBitRate : _NV_ENC_RC_PARAMS


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- b -

  • bdirectMode : _NV_ENC_CONFIG_H264
  • bitstreamBuffer : _NV_ENC_CREATE_BITSTREAM_BUFFER
  • bitstreamBufferPtr : _NV_ENC_LOCK_BITSTREAM , _NV_ENC_CREATE_BITSTREAM_BUFFER
  • bitstreamRestrictionFlag : _NV_ENC_CONFIG_H264_VUI_PARAMETERS
  • bitStreamSize : _NV_ENC_STAT
  • bitstreamSizeInBytes : _NV_ENC_LOCK_BITSTREAM
  • bottom : _NVENC_RECT
  • bufferDataPtr : _NV_ENC_LOCK_INPUT_BUFFER
  • bufferFmt : _NV_ENC_PIC_PARAMS , _NV_ENC_CREATE_INPUT_BUFFER
  • bufferFormat : _NV_ENC_REGISTER_RESOURCE


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- c -

  • capsToQuery : _NV_ENC_CAPS_PARAM
  • chromaFormatIDC : _NV_ENC_CONFIG_H264
  • chromaSampleLocationBot : _NV_ENC_CONFIG_H264_VUI_PARAMETERS
  • chromaSampleLocationFlag : _NV_ENC_CONFIG_H264_VUI_PARAMETERS
  • chromaSampleLocationTop : _NV_ENC_CONFIG_H264_VUI_PARAMETERS
  • codecPicParams : _NV_ENC_PIC_PARAMS
  • colourDescriptionPresentFlag : _NV_ENC_CONFIG_H264_VUI_PARAMETERS
  • colourMatrix : _NV_ENC_CONFIG_H264_VUI_PARAMETERS
  • colourPlaneId : _NV_ENC_PIC_PARAMS_H264
  • colourPrimaries : _NV_ENC_CONFIG_H264_VUI_PARAMETERS
  • completionEvent : _NV_ENC_PIC_PARAMS , _NV_ENC_EVENT_PARAMS
  • constQP : _NV_ENC_RC_PARAMS
  • constrainedFrame : _NV_ENC_PIC_PARAMS_HEVC , _NV_ENC_PIC_PARAMS_H264


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- d -

  • darHeight : _NV_ENC_INITIALIZE_PARAMS
  • darWidth : _NV_ENC_INITIALIZE_PARAMS
  • Data1 : GUID
  • Data2 : GUID
  • Data3 : GUID
  • Data4 : GUID
  • device : _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS
  • deviceType : _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS
  • dir : _NVENC_EXTERNAL_ME_HINT
  • disableDeblockAcrossSliceBoundary : _NV_ENC_CONFIG_HEVC
  • disableDeblockingFilterIDC : _NV_ENC_CONFIG_H264
  • disableSPSPPS : _NV_ENC_CONFIG_HEVC , _NV_ENC_CONFIG_H264
  • displayPOCSyntax : _NV_ENC_PIC_PARAMS_HEVC , _NV_ENC_PIC_PARAMS_H264
  • doNotWait : _NV_ENC_LOCK_BITSTREAM , _NV_ENC_LOCK_INPUT_BUFFER


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- e -

  • enableAQ : _NV_ENC_RC_PARAMS
  • enableConstrainedEncoding : _NV_ENC_CONFIG_H264
  • enableEncodeAsync : _NV_ENC_INITIALIZE_PARAMS
  • enableExternalMEHints : _NV_ENC_INITIALIZE_PARAMS
  • enableExtQPDeltaMap : _NV_ENC_RC_PARAMS
  • enableInitialRCQP : _NV_ENC_RC_PARAMS
  • enableIntraRefresh : _NV_ENC_CONFIG_HEVC , _NV_ENC_CONFIG_H264
  • enableLTR : _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG_HEVC
  • enableMaxQP : _NV_ENC_RC_PARAMS
  • enableMinQP : _NV_ENC_RC_PARAMS
  • enablePTD : _NV_ENC_INITIALIZE_PARAMS
  • enableStereoMVC : _NV_ENC_CONFIG_H264
  • enableSubFrameWrite : _NV_ENC_INITIALIZE_PARAMS
  • enableTemporalSVC : _NV_ENC_CONFIG_H264
  • enableVFR : _NV_ENC_CONFIG_H264
  • encodeCodecConfig : _NV_ENC_CONFIG
  • encodeConfig : _NV_ENC_INITIALIZE_PARAMS
  • encodeGUID : _NV_ENC_INITIALIZE_PARAMS
  • encodeHeight : _NV_ENC_INITIALIZE_PARAMS
  • encodePicFlags : _NV_ENC_PIC_PARAMS
  • encodeWidth : _NV_ENC_INITIALIZE_PARAMS
  • entropyCodingMode : _NV_ENC_CONFIG_H264


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- f -

  • fmoMode : _NV_ENC_CONFIG_H264
  • forceIDR : _NV_ENC_RECONFIGURE_PARAMS
  • forceIntraRefreshWithFrameCnt : _NV_ENC_PIC_PARAMS_HEVC , _NV_ENC_PIC_PARAMS_H264
  • frameAvgQP : _NV_ENC_LOCK_BITSTREAM
  • frameFieldMode : _NV_ENC_CONFIG
  • frameIdx : _NV_ENC_LOCK_BITSTREAM , _NV_ENC_PIC_PARAMS
  • frameIntervalP : _NV_ENC_CONFIG
  • frameRateDen : _NV_ENC_INITIALIZE_PARAMS
  • frameRateNum : _NV_ENC_INITIALIZE_PARAMS
  • frameSatd : _NV_ENC_LOCK_BITSTREAM


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- g -

  • gopLength : _NV_ENC_CONFIG


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- h -

  • h264Config : _NV_ENC_CODEC_CONFIG
  • h264PicParams : _NV_ENC_CODEC_PIC_PARAMS
  • h264VUIParameters : _NV_ENC_CONFIG_H264
  • height : _NV_ENC_CREATE_INPUT_BUFFER , _NV_ENC_REGISTER_RESOURCE
  • hevcConfig : _NV_ENC_CODEC_CONFIG
  • hevcPicParams : _NV_ENC_CODEC_PIC_PARAMS
  • hierarchicalBFrames : _NV_ENC_CONFIG_H264
  • hierarchicalPFrames : _NV_ENC_CONFIG_H264
  • hwEncodeStatus : _NV_ENC_LOCK_BITSTREAM


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- i -

  • idrPeriod : _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG_HEVC
  • inBufferSize : _NV_ENC_SEQUENCE_PARAM_PAYLOAD
  • initialRCQP : _NV_ENC_RC_PARAMS
  • inputBuffer : _NV_ENC_CREATE_INPUT_BUFFER , _NV_ENC_PIC_PARAMS , _NV_ENC_LOCK_INPUT_BUFFER
  • inputDuration : _NV_ENC_PIC_PARAMS
  • inputHeight : _NV_ENC_PIC_PARAMS
  • inputPitch : _NV_ENC_PIC_PARAMS
  • inputResource : _NV_ENC_MAP_INPUT_RESOURCE
  • inputTimeStamp : _NV_ENC_PIC_PARAMS
  • inputWidth : _NV_ENC_PIC_PARAMS
  • intraRefreshCnt : _NV_ENC_CONFIG_HEVC , _NV_ENC_CONFIG_H264
  • intraRefreshPeriod : _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG_HEVC


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- l -

  • lastOfMB : _NVENC_EXTERNAL_ME_HINT
  • lastofPart : _NVENC_EXTERNAL_ME_HINT
  • lastValidByteOffset : _NV_ENC_STAT
  • left : _NVENC_RECT
  • level : _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG_HEVC
  • ltrFrame : _NV_ENC_LOCK_BITSTREAM
  • ltrFrameBitmap : _NV_ENC_LOCK_BITSTREAM
  • ltrFrameIdx : _NV_ENC_LOCK_BITSTREAM
  • ltrMarkFrame : _NV_ENC_PIC_PARAMS_H264 , _NV_ENC_PIC_PARAMS_HEVC
  • ltrMarkFrameIdx : _NV_ENC_PIC_PARAMS_H264 , _NV_ENC_PIC_PARAMS_HEVC
  • ltrNumFrames : _NV_ENC_CONFIG_HEVC , _NV_ENC_CONFIG_H264
  • ltrTrustMode : _NV_ENC_CONFIG_H264
  • ltrUsageMode : _NV_ENC_PIC_PARAMS_HEVC , _NV_ENC_PIC_PARAMS_H264
  • ltrUseFrameBitmap : _NV_ENC_PIC_PARAMS_H264 , _NV_ENC_PIC_PARAMS_HEVC
  • ltrUseFrames : _NV_ENC_PIC_PARAMS_HEVC , _NV_ENC_PIC_PARAMS_H264


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- m -

  • mappedBufferFmt : _NV_ENC_MAP_INPUT_RESOURCE
  • mappedResource : _NV_ENC_MAP_INPUT_RESOURCE
  • maxBitRate : _NV_ENC_RC_PARAMS
  • maxCUSize : _NV_ENC_CONFIG_HEVC
  • maxEncodeHeight : _NV_ENC_INITIALIZE_PARAMS
  • maxEncodeWidth : _NV_ENC_INITIALIZE_PARAMS
  • maxMEHintCountsPerBlock : _NV_ENC_INITIALIZE_PARAMS
  • maxNumRefFrames : _NV_ENC_CONFIG_H264
  • maxNumRefFramesInDPB : _NV_ENC_CONFIG_HEVC
  • maxQP : _NV_ENC_RC_PARAMS
  • maxTemporalLayersMinus1 : _NV_ENC_CONFIG_HEVC
  • meExternalHints : _NV_ENC_PIC_PARAMS
  • meHintCountsPerBlock : _NV_ENC_PIC_PARAMS
  • memoryHeap : _NV_ENC_CREATE_BITSTREAM_BUFFER , _NV_ENC_CREATE_INPUT_BUFFER
  • minCUSize : _NV_ENC_CONFIG_HEVC
  • minQP : _NV_ENC_RC_PARAMS
  • monoChromeEncoding : _NV_ENC_CONFIG
  • mvPrecision : _NV_ENC_CONFIG
  • mvx : _NVENC_EXTERNAL_ME_HINT
  • mvy : _NVENC_EXTERNAL_ME_HINT


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- n -

  • numCandsPerBlk16x16 : _NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE
  • numCandsPerBlk16x8 : _NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE
  • numCandsPerBlk8x16 : _NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE
  • numCandsPerBlk8x8 : _NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE
  • numSlices : _NV_ENC_LOCK_BITSTREAM
  • numTemporalLayers : _NV_ENC_CONFIG_H264
  • nvEncCreateBitstreamBuffer : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncCreateInputBuffer : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncDestroyBitstreamBuffer : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncDestroyEncoder : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncDestroyInputBuffer : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncEncodePicture : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncGetEncodeCaps : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncGetEncodeGUIDCount : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncGetEncodeGUIDs : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncGetEncodePresetConfig : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncGetEncodePresetCount : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncGetEncodePresetGUIDs : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncGetEncodeProfileGUIDCount : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncGetEncodeProfileGUIDs : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncGetEncodeStats : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncGetInputFormatCount : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncGetInputFormats : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncGetSequenceParams : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncInitializeEncoder : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncInvalidateRefFrames : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncLockBitstream : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncLockInputBuffer : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncMapInputResource : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncOpenEncodeSession : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncOpenEncodeSessionEx : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncReconfigureEncoder : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncRegisterAsyncEvent : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncRegisterResource : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncUnlockBitstream : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncUnlockInputBuffer : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncUnmapInputResource : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncUnregisterAsyncEvent : _NV_ENCODE_API_FUNCTION_LIST
  • nvEncUnregisterResource : _NV_ENCODE_API_FUNCTION_LIST


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- o -

  • outputAUD : _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG_HEVC
  • outputBitstream : _NV_ENC_PIC_PARAMS , _NV_ENC_LOCK_BITSTREAM
  • outputBitStream : _NV_ENC_STAT
  • outputBufferingPeriodSEI : _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG_HEVC
  • outputDuration : _NV_ENC_LOCK_BITSTREAM
  • outputFramePackingSEI : _NV_ENC_CONFIG_H264
  • outputPictureTimingSEI : _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG_HEVC
  • outputRecoveryPointSEI : _NV_ENC_CONFIG_H264
  • outputTimeStamp : _NV_ENC_LOCK_BITSTREAM
  • outSPSPPSPayloadSize : _NV_ENC_SEQUENCE_PARAM_PAYLOAD
  • overscanInfo : _NV_ENC_CONFIG_H264_VUI_PARAMETERS
  • overscanInfoPresentFlag : _NV_ENC_CONFIG_H264_VUI_PARAMETERS


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- p -

  • partType : _NVENC_EXTERNAL_ME_HINT
  • payload : _NV_ENC_H264_SEI_PAYLOAD
  • payloadSize : _NV_ENC_H264_SEI_PAYLOAD
  • payloadType : _NV_ENC_H264_SEI_PAYLOAD
  • picIdx : _NV_ENC_STAT
  • pictureStruct : _NV_ENC_PIC_PARAMS , _NV_ENC_LOCK_BITSTREAM
  • pictureType : _NV_ENC_PIC_PARAMS , _NV_ENC_LOCK_BITSTREAM
  • picType : _NV_ENC_STAT
  • pitch : _NV_ENC_LOCK_INPUT_BUFFER , _NV_ENC_REGISTER_RESOURCE
  • ppsId : _NV_ENC_SEQUENCE_PARAM_PAYLOAD , _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG_HEVC
  • presetCfg : _NV_ENC_PRESET_CONFIG
  • presetGUID : _NV_ENC_INITIALIZE_PARAMS
  • privData : _NV_ENC_INITIALIZE_PARAMS
  • privDataSize : _NV_ENC_INITIALIZE_PARAMS
  • profileGUID : _NV_ENC_CONFIG
  • pSysMemBuffer : _NV_ENC_CREATE_INPUT_BUFFER


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- q -

  • qpDeltaMap : _NV_ENC_PIC_PARAMS
  • qpDeltaMapSize : _NV_ENC_PIC_PARAMS
  • qpPrimeYZeroTransformBypassFlag : _NV_ENC_CONFIG_H264


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- r -

  • rateControlMode : _NV_ENC_RC_PARAMS
  • rcParams : _NV_ENC_CONFIG
  • refidx : _NVENC_EXTERNAL_ME_HINT
  • refPicFlag : _NV_ENC_PIC_PARAMS_H264 , _NV_ENC_PIC_PARAMS_HEVC
  • registeredResource : _NV_ENC_MAP_INPUT_RESOURCE , _NV_ENC_REGISTER_RESOURCE
  • reInitEncodeParams : _NV_ENC_RECONFIGURE_PARAMS
  • repeatSPSPPS : _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG_HEVC
  • reportSliceOffsets : _NV_ENC_INITIALIZE_PARAMS
  • reserved : _NV_ENC_CONFIG_HEVC , _NV_ENC_CODEC_CONFIG , _NV_ENC_CONFIG , _NV_ENC_INITIALIZE_PARAMS , _NV_ENC_PIC_PARAMS_H264 , _NV_ENC_PIC_PARAMS_HEVC , _NV_ENC_CODEC_PIC_PARAMS , _NV_ENC_LOCK_BITSTREAM , _NV_ENC_CAPS_PARAM , _NV_ENC_STAT , _NV_ENC_SEQUENCE_PARAM_PAYLOAD , _NV_ENC_CREATE_INPUT_BUFFER , _NV_ENC_EVENT_PARAMS , _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS , _NV_ENC_CREATE_BITSTREAM_BUFFER , _NV_ENCODE_API_FUNCTION_LIST , _NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE
  • reserved1 : _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG_HEVC , _NV_ENC_PRESET_CONFIG , _NV_ENC_PIC_PARAMS , _NV_ENC_LOCK_INPUT_BUFFER , _NV_ENC_MAP_INPUT_RESOURCE , _NV_ENC_REGISTER_RESOURCE , _NV_ENC_STAT , _NV_ENC_EVENT_PARAMS , _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS , _NV_ENC_CREATE_INPUT_BUFFER , _NV_ENC_CREATE_BITSTREAM_BUFFER , _NVENC_EXTERNAL_ME_HINT_COUNTS_PER_BLOCKTYPE
  • reserved2 : _NV_ENC_INITIALIZE_PARAMS , _NV_ENC_EVENT_PARAMS , _NV_ENC_CREATE_BITSTREAM_BUFFER , _NV_ENC_CONFIG_HEVC , _NV_ENC_PIC_PARAMS_H264 , _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS , _NV_ENC_CREATE_INPUT_BUFFER , _NV_ENCODE_API_FUNCTION_LIST , _NV_ENC_REGISTER_RESOURCE , _NV_ENC_LOCK_BITSTREAM , _NV_ENC_PIC_PARAMS_HEVC , _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG , _NV_ENC_LOCK_INPUT_BUFFER , _NV_ENC_SEQUENCE_PARAM_PAYLOAD , _NV_ENC_PRESET_CONFIG , _NV_ENC_MAP_INPUT_RESOURCE , _NV_ENC_STAT , _NV_ENC_PIC_PARAMS
  • reserved3 : _NV_ENC_PIC_PARAMS_H264 , _NV_ENC_PIC_PARAMS
  • reserved4 : _NV_ENC_PIC_PARAMS
  • reservedBitFields : _NV_ENC_LOCK_BITSTREAM , _NV_ENC_LOCK_INPUT_BUFFER , _NV_ENC_CONFIG_H264 , _NV_ENC_RC_PARAMS , _NV_ENC_INITIALIZE_PARAMS , _NV_ENC_PIC_PARAMS_HEVC , _NV_ENC_PIC_PARAMS , _NV_ENC_PIC_PARAMS_H264
  • resetEncoder : _NV_ENC_RECONFIGURE_PARAMS
  • resourceToRegister : _NV_ENC_REGISTER_RESOURCE
  • resourceType : _NV_ENC_REGISTER_RESOURCE
  • right : _NVENC_RECT


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- s -

  • seiPayloadArray : _NV_ENC_PIC_PARAMS_H264
  • seiPayloadArrayCnt : _NV_ENC_PIC_PARAMS_H264
  • separateColourPlaneFlag : _NV_ENC_CONFIG_H264
  • size : _NV_ENC_CREATE_BITSTREAM_BUFFER
  • sliceMode : _NV_ENC_PIC_PARAMS_HEVC , _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG_HEVC , _NV_ENC_PIC_PARAMS_H264
  • sliceModeData : _NV_ENC_CONFIG_H264 , _NV_ENC_CONFIG_HEVC , _NV_ENC_PIC_PARAMS_H264 , _NV_ENC_PIC_PARAMS_HEVC
  • sliceModeDataUpdate : _NV_ENC_PIC_PARAMS_H264 , _NV_ENC_PIC_PARAMS_HEVC
  • sliceOffsets : _NV_ENC_STAT , _NV_ENC_LOCK_BITSTREAM
  • sliceTypeArrayCnt : _NV_ENC_PIC_PARAMS_HEVC
  • sliceTypeData : _NV_ENC_PIC_PARAMS_HEVC
  • spsId : _NV_ENC_CONFIG_HEVC , _NV_ENC_SEQUENCE_PARAM_PAYLOAD , _NV_ENC_CONFIG_H264
  • spsppsBuffer : _NV_ENC_SEQUENCE_PARAM_PAYLOAD
  • stereoMode : _NV_ENC_CONFIG_H264
  • subResourceIndex : _NV_ENC_MAP_INPUT_RESOURCE , _NV_ENC_REGISTER_RESOURCE


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- t -

  • temporalId : _NV_ENC_PIC_PARAMS_HEVC
  • temporallayerIdxMask : _NV_ENC_RC_PARAMS
  • temporalLayerQP : _NV_ENC_RC_PARAMS
  • tier : _NV_ENC_CONFIG_HEVC
  • top : _NVENC_RECT
  • transferCharacteristics : _NV_ENC_CONFIG_H264_VUI_PARAMETERS


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- u -

  • useConstrainedIntraPred : _NV_ENC_CONFIG_HEVC


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- v -

  • vbvBufferSize : _NV_ENC_RC_PARAMS
  • vbvInitialDelay : _NV_ENC_RC_PARAMS
  • version : _NV_ENC_CREATE_INPUT_BUFFER , _NV_ENC_RECONFIGURE_PARAMS , _NV_ENC_SEQUENCE_PARAM_PAYLOAD , _NV_ENCODE_API_FUNCTION_LIST , _NV_ENC_EVENT_PARAMS , _NV_ENC_PRESET_CONFIG , _NV_ENC_OPEN_ENCODE_SESSIONEX_PARAMS , _NV_ENC_STAT , _NV_ENC_REGISTER_RESOURCE , _NV_ENC_MAP_INPUT_RESOURCE , _NV_ENC_LOCK_INPUT_BUFFER , _NV_ENC_LOCK_BITSTREAM , _NV_ENC_CREATE_BITSTREAM_BUFFER , _NV_ENC_PIC_PARAMS , _NV_ENC_CAPS_PARAM , _NV_ENC_INITIALIZE_PARAMS , _NV_ENC_CONFIG
  • videoFormat : _NV_ENC_CONFIG_H264_VUI_PARAMETERS
  • videoFullRangeFlag : _NV_ENC_CONFIG_H264_VUI_PARAMETERS
  • videoSignalTypePresentFlag : _NV_ENC_CONFIG_H264_VUI_PARAMETERS
  • vpsId : _NV_ENC_CONFIG_HEVC


  • Data Structure Index
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- w -

  • width : _NV_ENC_CREATE_INPUT_BUFFER , _NV_ENC_REGISTER_RESOURCE


NVENC - NVIDIA Video Encoder Library Documentation